aboutsummaryrefslogtreecommitdiffstats
path: root/packages/netbase
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-05-30 06:12:33 +0000
committerJohn Bowler <jbowler@nslu2-linux.org>2005-05-30 06:12:33 +0000
commit6950e496815f69df7b50f4664b654ac6b3e4f7de (patch)
tree0cd12f2251a5a0590d3c511d60d8a26dc10575e9 /packages/netbase
parenta4912c88f3ebe4f5e322773b655b4300f1e39e07 (diff)
downloadopenembedded-6950e496815f69df7b50f4664b654ac6b3e4f7de.tar.gz
Initscripts patch.
This changes the order of the shutdown scripts in openslug to ensure that the network shutdown does not happen before network file systems have been unmounted. It also adds some missing scripts - hwclock.sh (load/save the hwclock, otherwise it gets loaded but not saved, in the absence of NTP). alignment.sh (added to openslug, was in 'arm' before), and umountfs (excluded from oe). The file system unmount scripts use /proc/mounts (not fstab) and unmount in the correct order (the old scripts only worked if nothing was mounted within a mounted file system). Scripts have been patched (openslug only patches) to make them work correctly with openslug NFS, flash and disk root and to arrange for syslog to run as long as possible (it's now in S/0/6, not in the user run levels). Directory struction of openslug-init has been tidied up, with all the initscripts in a sub-dirctory. initscritps-openslug is an openslug specific variant of initscripts which tracks it and fails safe (an update/change to initscripts will cause initscripts-openslug to fail rather than build strangeness). turnup also contains a fix for slugbug 150. BKrev: 429aaed1D-1XOdk8brF2bP9C9EEEJQ
Diffstat (limited to 'packages/netbase')
-rw-r--r--packages/netbase/netbase_4.21.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/packages/netbase/netbase_4.21.bb b/packages/netbase/netbase_4.21.bb
index e69de29bb2..06e3a3c1b9 100644
--- a/packages/netbase/netbase_4.21.bb
+++ b/packages/netbase/netbase_4.21.bb
@@ -0,0 +1,42 @@
+SECTION = "base"
+DESCRIPTION = "This package provides the necessary \
+infrastructure for basic TCP/IP based networking."
+LICENSE = "GPL"
+PR = "r6"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "networking"
+INITSCRIPT_PARAMS = "start 40 S . stop 40 0 6 1 ."
+# On MNCI, start very late so that our own apps come up faster
+INITSCRIPT_PARAMS_ramses = "start 85 1 2 3 4 5 . stop 85 0 6 1 ."
+# On OpenSlug delay the stop until after network apps have exited
+# Do not stop in single user - there's no way to sulogin!
+INITSCRIPT_PARAMS_openslug = "start 40 S 0 6 ."
+
+SRC_URI = "${DEBIAN_MIRROR}/main/n/netbase/netbase_${PV}.tar.gz \
+ file://options \
+ file://init \
+ file://hosts \
+ file://interfaces"
+
+do_install () {
+ install -d ${D}${sysconfdir}/init.d \
+ ${D}${sbindir} \
+ ${D}${mandir}/man8 \
+ ${D}${sysconfdir}/network/if-pre-up.d \
+ ${D}${sysconfdir}/network/if-up.d \
+ ${D}${sysconfdir}/network/if-down.d \
+ ${D}${sysconfdir}/network/if-post-down.d
+ install -m 0644 ${WORKDIR}/options ${D}${sysconfdir}/network/options
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/networking
+ install -m 0644 ${WORKDIR}/hosts ${D}${sysconfdir}/hosts
+ install -m 0644 etc-rpc ${D}${sysconfdir}/rpc
+ install -m 0644 etc-protocols ${D}${sysconfdir}/protocols
+ install -m 0644 etc-services ${D}${sysconfdir}/services
+ install -m 0755 update-inetd ${D}${sbindir}/
+ install -m 0644 update-inetd.8 ${D}${mandir}/man8/
+ install -m 0644 ${WORKDIR}/interfaces ${D}${sysconfdir}/network/interfaces
+}
+
+CONFFILES_${PN} = "${sysconfdir}/network/options ${sysconfdir}/hosts ${sysconfdir}/network/interfaces"