aboutsummaryrefslogtreecommitdiffstats
path: root/packages/notecase
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-11-14 12:46:06 +0000
committerKoen Kooi <koen@openembedded.org>2006-11-14 12:46:06 +0000
commitbcf9873f703cf10d51bcd4800a959079cf6ce41c (patch)
treedccb979757038dcc1f15b4e435cb8a06c0d02c4b /packages/notecase
parent13e4ed0f57d560f8d035e0d0fcad5e6f8d0b09d3 (diff)
downloadopenembedded-bcf9873f703cf10d51bcd4800a959079cf6ce41c.tar.gz
notecase: add 1.2.6 of the notecase outliner
* hand written makefile that has 'CXX=gcc', among other things....
Diffstat (limited to 'packages/notecase')
-rw-r--r--packages/notecase/.mtn2git_empty0
-rw-r--r--packages/notecase/notecase_1.2.6.bb21
2 files changed, 21 insertions, 0 deletions
diff --git a/packages/notecase/.mtn2git_empty b/packages/notecase/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/notecase/.mtn2git_empty
diff --git a/packages/notecase/notecase_1.2.6.bb b/packages/notecase/notecase_1.2.6.bb
new file mode 100644
index 0000000000..7a38480f22
--- /dev/null
+++ b/packages/notecase/notecase_1.2.6.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "NoteCase is a hierarchical note manager (aka. outliner)." "
+LICENSE = "BSD"
+
+DEPENDS = "zlib gtk+ gnome-vfs"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}_src.tar.gz \
+ file://no-hardcoded-cxx.patch;patch=1"
+
+inherit pkgconfig
+
+do_compile_prepend() {
+ cp ${STAGING_LIBDIR}/libz.a ${S}/src/lib/zlib/
+}
+
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/applications
+ install -m 644 ${S}/docs/notecase.desktop ${D}${datadir}/applications
+ install -m 755 ${S}/bin/notecase ${D}${bindir}/
+}