aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ntop
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-08-16 17:26:20 +0000
committerPhilippe De Swert <philippedeswert@scarlet.be>2007-08-16 17:26:20 +0000
commit623fb64de43b262e242dca42e1e625387c8810f9 (patch)
tree0ce1c27a3412d203d22ded91f14b42bd5d8a0509 /packages/ntop
parentae27e00cdc06bede6f1a35d455d6387f52db3f56 (diff)
downloadopenembedded-623fb64de43b262e242dca42e1e625387c8810f9.tar.gz
ntop: fix compilation issue (bug #1993)
* applied patch by Jamie Lenehan
Diffstat (limited to 'packages/ntop')
-rw-r--r--packages/ntop/ntop-3.0/autotools.patch20
-rw-r--r--packages/ntop/ntop_3.0.bb9
2 files changed, 21 insertions, 8 deletions
diff --git a/packages/ntop/ntop-3.0/autotools.patch b/packages/ntop/ntop-3.0/autotools.patch
index e40735c681..07ed6afd62 100644
--- a/packages/ntop/ntop-3.0/autotools.patch
+++ b/packages/ntop/ntop-3.0/autotools.patch
@@ -1,6 +1,16 @@
---- tmp/base/ntop-3.0-r0/ntop-3.0/acinclude.m4 2004-03-09 12:19:57.000000000 -0500
-+++ ntop-3.0/acinclude.m4 2004-03-09 12:19:57.000000000 -0500
-@@ -205,433 +205,3 @@
+--- ntop-3.0/acinclude.m4 2007/03/15 23:08:29 1.1
++++ ntop-3.0/acinclude.m4 2007/03/15 23:08:43
+@@ -34,6 +34,9 @@
+ dnl> #undef HAVE_<typedef>
+ dnl>
+
++LIBTOOL='$host_alias-libtool'
++AC_SUBST(LIBTOOL)dnl
++
+ AC_DEFUN([AC_CHECK_TYPEDEF],[dnl
+ AC_REQUIRE([AC_HEADER_STDC])dnl
+ AC_MSG_CHECKING(for typedef $1)
+@@ -205,433 +208,3 @@
fi
# Finished expansion of NTOPCONFIGDEBUG_SETTINGS()
])
@@ -434,8 +444,8 @@
-
-dnl This is just to silence aclocal about the macro not being used
-ifelse([AC_DISABLE_FAST_INSTALL])dnl
---- tmp/base/ntop-3.0-r0/ntop-3.0/configure.in 2004-03-21 18:45:04.000000000 -0500
-+++ ntop-3.0/configure.in 2004-05-22 14:20:07.000000000 -0400
+--- ntop-3.0/configure.in 2007/03/15 23:08:29 1.1
++++ ntop-3.0/configure.in 2007/03/15 23:08:34
@@ -190,7 +190,6 @@
AC_PROG_INSTALL
AC_PROG_LN_S
diff --git a/packages/ntop/ntop_3.0.bb b/packages/ntop/ntop_3.0.bb
index 051b5beb91..aa725222e9 100644
--- a/packages/ntop/ntop_3.0.bb
+++ b/packages/ntop/ntop_3.0.bb
@@ -3,6 +3,7 @@ DESCRIPTION = "ntop is network top"
SECTION = "console/network"
PRIORITY = "optional"
DEPENDS = "gdbm zlib libpcap libpng gd"
+PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/ntop/ntop-${PV}.tgz \
file://${FILESDIR}/autotools.patch;patch=1 \
@@ -25,11 +26,13 @@ EXTRA_OECONF += " --without-ssl \
FILES_ntop_append = " ${libdir}/ntop/plugins/*.so ${libdir}/libntop-*.so \
${libdir}/libntopreport-*.so"
FILES_${PN}-dev = "${includedir} ${libdir}/libntop.so ${libdir}/libntopreport.so \
- ${libdir}/libntop.a ${libdir}/libntopreport.a ${libdir}/*.la"
+ ${libdir}/*.a ${libdir}/libntopreport.a ${libdir}/*.la"
+FILES_${PN}-dbg += "${libdir}/ntop/plugins/.debug"
-do_configure () {
+do_configure_prepend () {
if [ ! -e acinclude.m4 ]; then
mv acinclude.m4.ntop acinclude.m4
fi
- autotools_do_configure
+ rm -f libtool
+ cp ${STAGING_BINDIR_NATIVE}/${TARGET_SYS}-libtool libtool
}