aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ntp
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-08-05 13:57:14 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-05 13:57:14 +0000
commit563289bea1ac6965e3cabcb59e2a80b6f11ed206 (patch)
treecb671c95c6a4a2a8396338b9498e86fd735e3101 /packages/ntp
parente790bee4030cd69ebd4c4aa9d33c79c89bbdceee (diff)
downloadopenembedded-563289bea1ac6965e3cabcb59e2a80b6f11ed206.tar.gz
Split tickadj to separate package, add RDEPENDS in ntp. Noone should notice ;)
Diffstat (limited to 'packages/ntp')
-rw-r--r--packages/ntp/ntp_4.2.0.bb12
1 files changed, 8 insertions, 4 deletions
diff --git a/packages/ntp/ntp_4.2.0.bb b/packages/ntp/ntp_4.2.0.bb
index ee1794de44..752fd1f266 100644
--- a/packages/ntp/ntp_4.2.0.bb
+++ b/packages/ntp/ntp_4.2.0.bb
@@ -6,7 +6,7 @@ HOMEPAGE = "http://ntp.isc.org/bin/view/Main/WebHome"
SECTION = "console/network"
PRIORITY = "optional"
LICENSE = "ntp"
-PR = "r3"
+PR = "r4"
# OE core: this is here to prevent this version of ntp from
# changing OE distros other than openslug. This code has
# only been tested on openslug. Feel free to remove these lines!
@@ -31,7 +31,7 @@ inherit autotools update-rc.d
EXTRA_OECONF = "--without-openssl --without-crypto ac_cv_header_readline_history_h=no"
CFLAGS_append = " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
-PACKAGES = "ntpdate ntp-bin ntp"
+PACKAGES = "ntpdate ntp-bin ntp ntp-tickadj"
# NOTE: you don't need ntpdate, use "ntpdc -q -g -x"
PROVIDES = "ntpdate-${PV} ntpdate-${PV}-${PR} ntpdate"
@@ -41,8 +41,12 @@ FILES_ntpdate = "${bindir}/ntpdate ${sysconfdir}/init.d/ntpdate"
#perl scripts, and installing perl is an enormous overhead for a user who only
#needs ntpq
#RDEPENDS_ntp-bin = perl
-FILES_ntp-bin = "${bindir}/ntp-wait ${bindir}/ntpdc ${bindir}/ntpq ${bindir}/ntptime ${bindir}/ntptrace"
-FILES_ntp = "${bindir}/ntpd ${bindir}/tickadj ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd"
+# ntp originally includes tickadj. It's split off for inclusion in small firmware images on platforms
+# with wonky clocks (e.g. OpenSlug)
+RDEPENDS_${PN} = ${PN}-tickadj
+FILES_${PN}-bin = "${bindir}/ntp-wait ${bindir}/ntpdc ${bindir}/ntpq ${bindir}/ntptime ${bindir}/ntptrace"
+FILES_${PN} = "${bindir}/ntpd ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd"
+FILES_${PN}-tickadj = "${bindir}/tickadj"
do_install_append() {
install -d ${D}/${sysconfdir}/init.d