aboutsummaryrefslogtreecommitdiffstats
path: root/packages/nylon/nylon-statistics.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2004-12-14 12:49:04 +0000
committerMichael Lauer <mickey@vanille-media.de>2004-12-14 12:49:04 +0000
commitfe938bbed352811a2e176797d9f5295d270564e8 (patch)
treeb482ac8d4bbe1d878d08b41d7f73d95b00459474 /packages/nylon/nylon-statistics.bb
parent8c45dce3743063bf4f15c5c17597fbeb15061d5f (diff)
downloadopenembedded-fe938bbed352811a2e176797d9f5295d270564e8.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2004/12/14 12:27:14+01:00 (none)!br1 Merge http://oe-devel@oe-devel.bkbits.net/openembedded into null.(none):/data/mtx/oe/openembedded 2004/12/14 12:26:43+01:00 (none)!br1 add mtx-1 i2c support 2004/12/14 11:02:03+01:00 (none)!br1 unik-olsrd 0.4.8 2004/12/14 11:00:53+01:00 (none)!br1 little fixes for bitbake 2004/12/14 10:59:06+01:00 (none)!br1 nylon updates 2004/12/14 03:27:14-06:00 ti.com!kergoth More PACKAGE_ARCH/MACHINE_ARCH updates for the multi-z builds. BKrev: 41bee140kQ_QwKwcIxgyouZUyeqwmA
Diffstat (limited to 'packages/nylon/nylon-statistics.bb')
-rw-r--r--packages/nylon/nylon-statistics.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/nylon/nylon-statistics.bb b/packages/nylon/nylon-statistics.bb
index e69de29bb2..bca72ae75b 100644
--- a/packages/nylon/nylon-statistics.bb
+++ b/packages/nylon/nylon-statistics.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "statistics & graphing for nylon"
+RDEPENDS = "rrdtool"
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+LICENSE = "GPLv2"
+
+SRC_URI = "svn://meshcube.org/svn/application;module=${PN};proto=http"
+S = "${WORKDIR}/${PN}"
+
+do_install() {
+ install -d ${D}/srv/www/cgi-bin
+ install -d ${D}/${sbindir}
+ ln -s /var/tmp ${D}/srv/www/rrd-img
+ install -m 755 ${S}/*.html ${D}/srv/www/cgi-bin
+ install -m 755 ${S}/collect.sh ${D}/${sbindir}
+}
+
+pkg_postinst() {
+if test "x$D" == "x"; then
+ mkdir -p /etc/cron/crontabs
+ if ! grep -q collect.sh /etc/cron/crontabs/root; then
+ echo "adding crontab"
+ echo "*/5 * * * * /usr/sbin/collect.sh" >> /etc/cron/crontabs/root
+ fi
+ update-rc.d -s busybox-cron defaults
+ if [ ! -e /etc/httpd.conf ]; then
+ echo "A:*" > /etc/httpd.conf
+ fi
+ update-rc.d -s busybox-httpd defaults
+fi
+}
+
+FILES_${PN} += "/srv" \ No newline at end of file