aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openldap
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-11-15 19:07:32 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-15 19:07:32 +0000
commit921364525a0ae781b2528a7e922e8b2c7d119e75 (patch)
tree9e0793f11fb1b8feea4343a845f146eca6f11403 /packages/openldap
parent7de998bd4b1d2417fc4702756668da58bdb977bd (diff)
downloadopenembedded-921364525a0ae781b2528a7e922e8b2c7d119e75.tar.gz
openldap: (libldap) upgrade to 2.3.11
- 2.3.11 now passes the most basic tests, which is all the previous - version ever passed.
Diffstat (limited to 'packages/openldap')
-rw-r--r--packages/openldap/openldap_2.3.11.bb40
1 files changed, 16 insertions, 24 deletions
diff --git a/packages/openldap/openldap_2.3.11.bb b/packages/openldap/openldap_2.3.11.bb
index 84b93d1d8e..f15de41116 100644
--- a/packages/openldap/openldap_2.3.11.bb
+++ b/packages/openldap/openldap_2.3.11.bb
@@ -12,8 +12,7 @@ PRIORITY = "optional"
LICENSE = "OpenLDAP"
SECTION = "libs"
-PR = "r0"
-DEFAULT_PREFERENCE = "-1"
+PR = "r1"
LDAP_VER = "${@'.'.join(bb.data.getVar('PV',d,1).split('.')[0:2])}"
@@ -55,10 +54,17 @@ EXTRA_OECONF += "--enable-dynamic"
#
# Disable TLS to remove the need for openssl/libcrypto
OPENLDAP_OPTION_tls ?= "--without-tls"
-# set the following to " openssl" to build tls support
-OPENLDAP_DEPENDS_tls ?=
+# set the following to "openssl" to build tls support
+OPENLDAP_DEPENDS_tls ?= ""
EXTRA_OECONF += "${OPENLDAP_OPTION_tls}"
DEPENDS += "${OPENLDAP_DEPENDS_tls}"
+#
+# Disable Cyrus SASL, which may or may not be working at present...
+OPENLDAP_OPTION_sasl ?= "--without-cyrus-sasl"
+# set the following to "cyrus-sasl" to build SASL support
+OPENLDAP_DEPENDS_sasl ?= ""
+EXTRA_OECONF += "${OPENLDAP_OPTION_sasl}"
+DEPENDS += "${OPENLDAP_DEPENDS_sasl}"
# SLAPD options
#
@@ -249,28 +255,14 @@ PACKAGES += "${PN}-slapd ${PN}-slurpd ${PN}-bin"
# Package contents - shift most standard contents to -bin
FILES_${PN} = "${libdir}/lib*.so.* ${sysconfdir}/openldap/ldap.* ${localstatedir}/openldap-data"
-FILES_${PN}-slapd = "${libexecdir}/slapd ${sbindir} ${datadir}/openldap/ucdata \
- ${localstatedir}/run ${sysconfdir}/openldap/slapd.* ${sysconfdir}/openldap/schema"
+FILES_${PN}-slapd = "${libexecdir}/slapd ${sbindir} ${localstatedir}/run \
+ ${sysconfdir}/openldap/slapd.* ${sysconfdir}/openldap/schema \
+ ${sysconfdir}/openldap/DB_CONFIG.example"
FILES_${PN}-slurpd = "${libexecdir}/slurpd ${localstatedir}/openldap-slurp ${localstatedir}/run"
FILES_${PN}-bin = "${bindir}"
FILES_${PN}-dev = "${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libdir}/*.a ${libexecdir}/openldap/*.a"
-# Run ucgendat, and remove it.
-# This is a painful and annoying way around the use of machine-generated
-# tables within the build. The alternative is to rewrite the ucgendat
-# stuff and associated liblunicode code to use machine-independent data
-# files - the current code seems to at least assume byte sex.
-DATFILES = "case.dat cmbcl.dat comp.dat ctype.dat decomp.dat num.dat kdecomp.dat"
-pkg_postinst_openldap-slapd() {
-test -n "${DESTDIR}" -o "${BUILD_ARCH}" = "${HOST_ARCH}" || (
- cd "${datadir}/${PN}/ucdata" &&
- ./ucgendat UnicodeData.txt -x CompositionExclusions.txt &&
- # This saves about 1MByte
- rm ucgendat UnicodeData.txt CompositionExclusions.txt
-)
-}
-pkg_prerm_openldap-slapd() {
-test "${BUILD_ARCH}" = "${HOST_ARCH}" || (
- cd "${datadir}/${PN}/ucdata" && rm ${DATFILES}
-)
+do_install_append() {
+ # This is duplicated in /etc/openldap and is for slapd
+ rm -f ${D}${localstatedir}/openldap-data/DB_CONFIG.example
}