aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openntpd
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-07-04 09:52:42 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-04 09:52:42 +0000
commit25c8282e9c1accf15757ac1a7a103fba68ded050 (patch)
tree413bbdcd8c087845af191ece17f404b8784cd648 /packages/openntpd
parent94dbd7d90040202048c041d8f7e8860c297a5038 (diff)
downloadopenembedded-25c8282e9c1accf15757ac1a7a103fba68ded050.tar.gz
Added patch for openntpd-3.7p1 to use the adjtimex() call.
Diffstat (limited to 'packages/openntpd')
-rw-r--r--packages/openntpd/files/adjtimex-3.7p1.patch172
1 files changed, 172 insertions, 0 deletions
diff --git a/packages/openntpd/files/adjtimex-3.7p1.patch b/packages/openntpd/files/adjtimex-3.7p1.patch
new file mode 100644
index 0000000000..12a4184443
--- /dev/null
+++ b/packages/openntpd/files/adjtimex-3.7p1.patch
@@ -0,0 +1,172 @@
+diff -u -p -r1.46 client.c
+--- openntpd-3.7p1/client.c 13 Mar 2005 12:36:43 -0000 1.46
++++ openntpd-3.7p1/client.c 26 Jun 2005 03:15:54 -0000
+@@ -306,7 +306,7 @@ client_update(struct ntp_peer *p)
+ priv_adjtime();
+
+ for (i = 0; i < OFFSET_ARRAY_SIZE; i++)
+- if (p->reply[i].rcvd <= p->reply[best].rcvd)
++ /* if (p->reply[i].rcvd <= p->reply[best].rcvd) */
+ p->reply[i].good = 0;
+
+ return (0);
+--- openntpd-3.7p1/configure.ac 23 May 2005 11:10:34 -0000 1.62
++++ openntpd-3.7p1/configure.ac 26 Jun 2005 03:15:54 -0000
+@@ -466,6 +466,11 @@ AC_ARG_WITH(builtin-arc4random,
+ [ builtin_arc4random=$withval ]
+ )
+
++AC_ARG_WITH(adjtimex,
++ [ --with-adjtimex Use adjtimex to adjust kernel skew],
++ [ AC_DEFINE(USE_ADJTIMEX, [], [Use adjust skew with adjtimex (experimental)]) ]
++)
++
+ # Search for OpenSSL if required.
+ if test "$ac_cv_func_arc4random" != "yes" && test "x$builtin_arc4random" != "xyes"; then
+ saved_CPPFLAGS="$CPPFLAGS"
+--- openntpd-3.7p1/defines.h 23 May 2005 00:16:15 -0000 1.23
++++ openntpd-3.7p1/defines.h 26 Jun 2005 03:15:54 -0000
+@@ -20,6 +20,10 @@
+ # define setproctitle(x)
+ #endif
+
++#ifdef USE_ADJTIMEX
++# define adjtime(a,b) (_compat_adjtime((a),(b)))
++#endif
++
+ #if !defined(SA_LEN)
+ # if defined(HAVE_STRUCT_SOCKADDR_SA_LEN)
+ # define SA_LEN(x) ((x)->sa_len)
+--- openntpd-3.7p1/openbsd-compat/Makefile.in 19 Dec 2004 23:41:28 -0000 1.10
++++ openntpd-3.7p1/openbsd-compat/Makefile.in 26 Jun 2005 03:17:15 -0000
+@@ -9,7 +9,7 @@ all: libopenbsd-compat.a
+ OPENBSD= asprintf.o daemon.o inet_pton.o strlcpy.o
+ COMPAT= atomicio.o bsd-arc4random.o bsd-misc.o bsd-poll.o \
+ bsd-snprintf.o fake-rfc2553.o uidswap.o
+-PORT= port-qnx.o
++PORT= port-linux.o port-qnx.o
+
+ VPATH=@srcdir@
+ CC=@CC@
+--- openntpd-3.7p1/openbsd-compat/openbsd-compat.h 19 Dec 2004 03:04:22 -0000 1.15
++++ openntpd-3.7p1/openbsd-compat/openbsd-compat.h 26 Jun 2005 03:15:54 -0000
+@@ -44,6 +44,11 @@ int asprintf(char **, const char *,
+ __attribute__((__format__ (printf, 2, 3)));
+ #endif
+
++#ifdef USE_ADJTIMEX
++# include <sys/time.h>
++int _compat_adjtime(const struct timeval *, struct timeval *);
++#endif
++
+ #ifndef HAVE_INET_PTON
+ int inet_pton(int, const char *, void *);
+ #endif
+--- /dev/null 1 Jan 1970 00:00:00 -0000
++++ openntpd-3.7p1/openbsd-compat/port-linux.c 10 Dec 2004 01:10:30 -0000
+@@ -0,0 +1,105 @@
++/* $Id$ */
++
++/*
++ * Copyright (c) 2004 Darren Tucker <dtucker at zip com au>
++ *
++ * Permission to use, copy, modify, and distribute this software for any
++ * purpose with or without fee is hereby granted, provided that the above
++ * copyright notice and this permission notice appear in all copies.
++ *
++ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
++ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
++ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
++ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
++ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
++ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
++ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
++ */
++
++#include "includes.h"
++
++#ifdef USE_ADJTIMEX
++#include <sys/timex.h>
++#include <errno.h>
++#ifdef adjtime
++# undef adjtime
++#endif
++
++#include "ntpd.h"
++
++/* scale factor used by adjtimex freq param. 1 ppm = 65536 */
++#define ADJTIMEX_FREQ_SCALE 65536
++
++/* maximum change to skew per adjustment, in PPM */
++#define MAX_SKEW_DELTA 5.0
++
++int
++_compat_adjtime(const struct timeval *delta, struct timeval *olddelta)
++{
++ static struct timeval tlast = {0,0};
++ static double tskew = 0;
++ static int synced = -1;
++ struct timeval tnow, tdelta;
++ double skew = 0, newskew, deltaskew, adjust, interval = 0;
++ struct timex tmx;
++ int result, saved_errno;
++
++ gettimeofday(&tnow, NULL);
++ adjust = (double)delta->tv_sec;
++ adjust += (double)delta->tv_usec / 1000000;
++
++ /* Even if the caller doesn't care about the olddelta, we do */
++ if (olddelta == NULL)
++ olddelta = &tdelta;
++
++ result = adjtime(delta, olddelta);
++ saved_errno = errno;
++
++ if (olddelta->tv_sec == 0 && olddelta->tv_usec == 0 &&
++ synced != INT_MAX)
++ synced++;
++ else
++ synced = 0;
++
++ /*
++ * do skew calculations if we have synced
++ */
++ if (synced == 0 ) {
++ tmx.modes = 0;
++ if (adjtimex(&tmx) == -1)
++ log_warn("adjtimex get failed");
++ else
++ tskew = (double)tmx.freq / ADJTIMEX_FREQ_SCALE;
++ } else if (synced >= 1) {
++ interval = (double)(tnow.tv_sec - tlast.tv_sec);
++ interval += (double)(tnow.tv_usec - tlast.tv_usec) / 1000000;
++
++ skew = (adjust * 1000000) / interval;
++ newskew = ((tskew * synced) + skew) / synced;
++ deltaskew = newskew - tskew;
++
++ if (deltaskew > MAX_SKEW_DELTA) {
++ log_info("skew change %0.3lf exceeds limit", deltaskew);
++ tskew += MAX_SKEW_DELTA;
++ } else if (deltaskew < -MAX_SKEW_DELTA) {
++ log_info("skew change %0.3lf exceeds limit", deltaskew);
++ tskew -= MAX_SKEW_DELTA;
++ } else {
++ tskew = newskew;
++ }
++
++ /* Adjust the kernel skew. */
++ tmx.freq = (long)(tskew * ADJTIMEX_FREQ_SCALE);
++ tmx.modes = ADJ_FREQUENCY;
++ if (adjtimex(&tmx) == -1)
++ log_warn("adjtimex set freq failed");
++ }
++
++ log_debug("interval %0.3lf skew %0.3lf total skew %0.3lf", interval,
++ skew, tskew);
++
++ tlast = tnow;
++ errno = saved_errno;
++ return result;
++}
++#endif