aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openntpd
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-07-04 09:51:36 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-04 09:51:36 +0000
commit94dbd7d90040202048c041d8f7e8860c297a5038 (patch)
tree4c8d6a8e5e94b563316f5d08acf29e5cec07e6d6 /packages/openntpd
parente2e6ff42af82041c268819fd2c121f007cc1fb58 (diff)
downloadopenembedded-94dbd7d90040202048c041d8f7e8860c297a5038.tar.gz
Fixed makefile to ignore that the ntpd user may not exist on the build system.
Diffstat (limited to 'packages/openntpd')
-rw-r--r--packages/openntpd/files/makefile-install.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/openntpd/files/makefile-install.patch b/packages/openntpd/files/makefile-install.patch
new file mode 100644
index 0000000000..b11c1aedd3
--- /dev/null
+++ b/packages/openntpd/files/makefile-install.patch
@@ -0,0 +1,29 @@
+--- openntpd-3.7p1/Makefile.in.original 2005-07-02 06:08:47.795870784 +0200
++++ openntpd-3.7p1/Makefile.in 2005-07-02 06:15:34.768001616 +0200
+@@ -78,26 +78,6 @@
+ else \
+ echo "$(DESTDIR)$(sysconfdir)/ntpd.conf already exists, install will not overwrite"; \
+ fi
+- @if [ ! -d $(DESTDIR)$(PRIVSEP_PATH) ]; then \
+- mkdir -p $(DESTDIR)$(PRIVSEP_PATH) ;\
+- chown 0 $(DESTDIR)$(PRIVSEP_PATH) ; \
+- chgrp 0 $(DESTDIR)$(PRIVSEP_PATH) ; \
+- chmod 0755 $(DESTDIR)$(PRIVSEP_PATH) ; \
+- fi
+- @if grep "$(PRIVSEP_USER):" /etc/group >/dev/null; then \
+- : ;\
+- else \
+- echo "Please create a dedicated group for ntpd." ;\
+- echo "This is system-dependant, possibly:" ;\
+- echo "# groupadd $(PRIVSEP_USER)" ;\
+- fi
+- @if grep "$(PRIVSEP_USER):" /etc/passwd >/dev/null; then \
+- : ;\
+- else \
+- echo "Please create a dedicated user for ntpd and ensure it can" ;\
+- echo "not be used to log in. This is system-dependant, possibly:" ;\
+- echo "# useradd -g $(PRIVSEP_USER) -s /sbin/nologin -d $(PRIVSEP_PATH) -c 'OpenNTP daemon' $(PRIVSEP_USER)" ;\
+- fi
+
+ diff:
+ -diff -x CVS -x Makefile -ru /usr/src/usr.sbin/ntpd ./ | \