aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openntpd
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/openntpd
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/openntpd')
-rw-r--r--packages/openntpd/.mtn2git_empty0
-rw-r--r--packages/openntpd/files/.mtn2git_empty0
-rw-r--r--packages/openntpd/files/autofoo.patch52
-rw-r--r--packages/openntpd/openntpd_3.6.1p1.bb15
4 files changed, 67 insertions, 0 deletions
diff --git a/packages/openntpd/.mtn2git_empty b/packages/openntpd/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/openntpd/.mtn2git_empty
diff --git a/packages/openntpd/files/.mtn2git_empty b/packages/openntpd/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/openntpd/files/.mtn2git_empty
diff --git a/packages/openntpd/files/autofoo.patch b/packages/openntpd/files/autofoo.patch
index e69de29bb2..605558e6fd 100644
--- a/packages/openntpd/files/autofoo.patch
+++ b/packages/openntpd/files/autofoo.patch
@@ -0,0 +1,52 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- openntpd-3.6.1p1/configure.ac~autofoo
++++ openntpd-3.6.1p1/configure.ac
+@@ -500,8 +500,11 @@
+ [
+ AC_MSG_RESULT(not found)
+ AC_MSG_ERROR(OpenSSL version header not found.)
+- ]
+-)
++ ],[
++ AC_MSG_RESULT(unknown)
++ AC_MSG_WARN(Skipping OpenSSL header version check due to crosscompilation.)
++
++])
+
+ # Determine OpenSSL library version
+ AC_MSG_CHECKING([OpenSSL library version])
+@@ -533,6 +536,9 @@
+ [
+ AC_MSG_RESULT(not found)
+ AC_MSG_ERROR(OpenSSL library not found.)
++ ],[
++ AC_MSG_RESULT(unknown)
++ AC_MSG_WARN(Skipping OpenSSL library version check due to crosscompilation.)
+ ]
+ )
+
+@@ -552,6 +558,9 @@
+ AC_MSG_ERROR([Your OpenSSL headers do not match your library.
+ Check config.log for details.
+ Also see contrib/findssl.sh for help identifying header/library mismatches.])
++ ],[
++ AC_MSG_RESULT(unknown)
++ AC_MSG_WARN(Skipping OpenSSL version comparison due to crosscompilation.)
+ ]
+ )
+
+@@ -572,6 +581,10 @@
+ [
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR(OpenNTPd requires a self-seeding OpenSSL)
++ ],
++ [
++ AC_MSG_RESULT(cross, assuming yes)
++ OPENSSL_SEEDS_ITSELF=yes
+ ]
+ )
+ fi
diff --git a/packages/openntpd/openntpd_3.6.1p1.bb b/packages/openntpd/openntpd_3.6.1p1.bb
index e69de29bb2..b924b4a0c6 100644
--- a/packages/openntpd/openntpd_3.6.1p1.bb
+++ b/packages/openntpd/openntpd_3.6.1p1.bb
@@ -0,0 +1,15 @@
+DEPENDS += "openssl"
+DESCRIPTION = "OpenNTPD is a FREE, easy to use implementation of the \
+Network Time Protocol."
+HOMEPAGE = "http://www.openntpd.org/"
+LICENSE = "BSD"
+SECTION = "console/network"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+
+SRC_URI = "ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/openntpd-${PV}.tar.gz \
+ file://autofoo.patch;patch=1"
+S = "${WORKDIR}/openntpd-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF += "--disable-strip"