aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openntpd
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-07-04 10:11:07 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-04 10:11:07 +0000
commited24399db8b8937d6094e5916ded0695fafb0b8b (patch)
treed515e44b89e9ef136160194b011d21b0b364c4c9 /packages/openntpd
parent233b4de6a3fb445b4af0ce7e5d478e43b6f3e040 (diff)
downloadopenembedded-ed24399db8b8937d6094e5916ded0695fafb0b8b.tar.gz
Added new version of openntpd.
Diffstat (limited to 'packages/openntpd')
-rw-r--r--packages/openntpd/openntpd_3.7p1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/openntpd/openntpd_3.7p1.bb b/packages/openntpd/openntpd_3.7p1.bb
new file mode 100644
index 0000000000..033f959510
--- /dev/null
+++ b/packages/openntpd/openntpd_3.7p1.bb
@@ -0,0 +1,30 @@
+DEPENDS += "openssl"
+DESCRIPTION = "OpenNTPD is a FREE, easy to use implementation of the \
+Network Time Protocol."
+HOMEPAGE = "http://www.openntpd.org/"
+LICENSE = "BSD"
+SECTION = "console/network"
+MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
+PR="r1"
+
+SRC_URI = "http://www.zip.com.au/~dtucker/openntpd/release/openntpd-${PV}.tar.gz \
+ file://autofoo.patch;patch=1 \
+ file://adjtimex-${PV}.patch;patch=1 \
+ file://makefile-install.patch;patch=1 \
+ file://init"
+S = "${WORKDIR}/openntpd-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF += "CFLAGS=-DUSE_ADJTIMEX --disable-strip --prefix=/usr \
+ --sysconfdir=/etc --with-privsep-path=/var/shared/empty \
+ --with-privsep-user=ntpd"
+
+do_install_prepend() {
+ install -d ${D}${sysconfdir}/init.d
+}
+
+do_install_append() {
+ install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/openntpd
+ install -d ${D}${localstatedir}/shared/empty
+}