aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openslug-init
diff options
context:
space:
mode:
authorg2@giantshoulder.com <g2@giantshoulder.com>2005-02-26 03:25:40 +0000
committerg2@giantshoulder.com <g2@giantshoulder.com>2005-02-26 03:25:40 +0000
commita106a489550602245c24b896c8f85fc364a1ffcc (patch)
tree69dd20004f7479a30deee3a61e8c6a63f4c190bf /packages/openslug-init
parent3f35df48ac0854fe481f2e3d928a18cab5e29627 (diff)
downloadopenembedded-a106a489550602245c24b896c8f85fc364a1ffcc.tar.gz
Add LED indications on boot
BKrev: 421fec346zGluzSFGdScgnxvxMA7Vw
Diffstat (limited to 'packages/openslug-init')
-rw-r--r--packages/openslug-init/openslug-init-0.10/leds.c0
-rw-r--r--packages/openslug-init/openslug-init-0.10/leds.h0
-rw-r--r--packages/openslug-init/openslug-init-0.10/leds_rs_green0
-rw-r--r--packages/openslug-init/openslug-init_0.10.bb10
4 files changed, 9 insertions, 1 deletions
diff --git a/packages/openslug-init/openslug-init-0.10/leds.c b/packages/openslug-init/openslug-init-0.10/leds.c
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/openslug-init/openslug-init-0.10/leds.c
diff --git a/packages/openslug-init/openslug-init-0.10/leds.h b/packages/openslug-init/openslug-init-0.10/leds.h
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/openslug-init/openslug-init-0.10/leds.h
diff --git a/packages/openslug-init/openslug-init-0.10/leds_rs_green b/packages/openslug-init/openslug-init-0.10/leds_rs_green
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/openslug-init/openslug-init-0.10/leds_rs_green
diff --git a/packages/openslug-init/openslug-init_0.10.bb b/packages/openslug-init/openslug-init_0.10.bb
index d781987c4b..6b076c7eee 100644
--- a/packages/openslug-init/openslug-init_0.10.bb
+++ b/packages/openslug-init/openslug-init_0.10.bb
@@ -2,13 +2,16 @@ DESCRIPTION = "Openslug initial network config via sysconf"
SECTION = "console/network"
LICENSE = "GPL"
DEPENDS = "base-files"
-PR = "r9"
+PR = "r10"
OPENSLUG_VERSION = "1.3-alpha"
SRC_URI = "file://sysconfsetup \
file://modutils.txt \
file://modprobe.conf \
+ file://leds_rs_green \
+ file://leds.h \
+ file://leds.c \
file://kern_header.c"
inherit autotools update-rc.d
@@ -18,6 +21,7 @@ INITSCRIPT_PARAMS = "defaults 39"
do_compile() {
${CC} -o ${S}/../kern_header ${S}/../kern_header.c
+ ${CC} -o ${S}/../leds ${S}/../leds.c
}
do_install() {
@@ -27,15 +31,19 @@ do_install() {
${D}/${sysconfdir}/init.d \
${D}/${sysconfdir}/modutils \
${D}/${sysconfdir}/rcS.d \
+ ${D}/${sysconfdir}/rc2.d \
${D}/${sbindir}
install -d ${D}/initrd
install -m 0755 ${D}/../kern_header ${D}${sbindir}/kern_header
+ install -m 0755 ${D}/../leds ${D}${sbindir}/leds
install -m 0755 ${D}/../sysconfsetup ${D}${sysconfdir}/init.d/
+ install -m 0755 ${D}/../leds_rs_green ${D}${sysconfdir}/init.d/
install -m 0644 ${D}/../modutils.txt ${D}${sysconfdir}/modutils/
install -m 0644 ${D}/../modprobe.conf ${D}${sysconfdir}/
ln -s /etc/init.d/sysconfsetup ${D}${sysconfdir}/rcS.d/S39sysconfsetup
+ ln -s /etc/init.d/leds_rs_green ${D}${sysconfdir}/rc2.d/S98leds_rs_green
}
FILES_${PN} = "/"