aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openslug-init
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-10-05 18:15:38 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-05 18:15:38 +0000
commita2e86652b541c85a5cb3ba83875f2c21d365405c (patch)
tree4d4ad286a756fc9e0225f245e5d67fe6c4713055 /packages/openslug-init
parent2260652d80d4481e2a4950677bf1ffee2e9ab02b (diff)
downloadopenembedded-a2e86652b541c85a5cb3ba83875f2c21d365405c.tar.gz
openslug-init(modprobe.conf),nslu2.conf: generate the correct ixp-eth alias, support le
modprobe.conf is now machine generated to use the PROVIDER of virtual/ixp-eth in place of a hard code module name - PREFERRED_PROVIDER_virtual/ixp-eth must be specified to make this work, the configuration files have been updated appropriate. openslug-image now pulls in virtual/ixp-eth, not a specific provider and uses the PREFERRED_PROVIDER of that module as the RDEPENDS. nslu2.conf and ucslugc.conf have changes to support configuration of the build endianness correctly - not fully functional because the flash read code still needs word swapping on LE.
Diffstat (limited to 'packages/openslug-init')
-rw-r--r--packages/openslug-init/openslug-init-0.10/modprobe.conf7
-rw-r--r--packages/openslug-init/openslug-init_0.10.bb6
2 files changed, 7 insertions, 6 deletions
diff --git a/packages/openslug-init/openslug-init-0.10/modprobe.conf b/packages/openslug-init/openslug-init-0.10/modprobe.conf
index 9ed854742e..08482e8c6d 100644
--- a/packages/openslug-init/openslug-init-0.10/modprobe.conf
+++ b/packages/openslug-init/openslug-init-0.10/modprobe.conf
@@ -1,4 +1,3 @@
-# Add an alias for eth0 to ixp425_eth to cause the S40networking
-# init script to load the ixp425_eth driver on the frist boot
-alias eth0 ixp425_eth
-
+# Add an alias for eth0 to MODULE to cause the S40networking
+# init script to load the MODULE driver on the first boot
+alias eth0 MODULE
diff --git a/packages/openslug-init/openslug-init_0.10.bb b/packages/openslug-init/openslug-init_0.10.bb
index e5665d4519..fa85d9c6f7 100644
--- a/packages/openslug-init/openslug-init_0.10.bb
+++ b/packages/openslug-init/openslug-init_0.10.bb
@@ -3,7 +3,7 @@ SECTION = "console/network"
LICENSE = "GPL"
DEPENDS = "base-files devio"
RDEPENDS = "busybox devio"
-PR = "r43"
+PR = "r44"
SRC_URI = "file://linuxrc \
file://boot/flash \
@@ -99,7 +99,9 @@ do_install() {
# Configuration files
install -m 0644 conffiles ${D}${sysconfdir}/default
- install -m 0644 modprobe.conf ${D}${sysconfdir}/
+ # Change MODULE in modprobe.conf to the correct module name
+ rm -f ${D}${sysconfdir}/modprobe.conf
+ sed 's/MODULE/'"$(echo '${PREFERRED_PROVIDER_virtual/ixp-eth}'|sed 's/-/_/g')"'/g' modprobe.conf >${D}${sysconfdir}/modprobe.conf
set +ex
}