aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openslug-init
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-06-15 14:28:12 +0000
committerJohn Bowler <jbowler@nslu2-linux.org>2005-06-15 14:28:12 +0000
commitc25f48128377f6497d9be77e074e07c30d755002 (patch)
tree91143a3581ceb8c3e54cc46df3929e23c8acd282 /packages/openslug-init
parente0662cf888c3e344dbc4230c51e56af5a4ab647e (diff)
downloadopenembedded-c25f48128377f6497d9be77e074e07c30d755002.tar.gz
Change conffiles and fix /dev bug in turnup.
BKrev: 42b03afcRUFZrFbVGDwsxNY2C-eKfA
Diffstat (limited to 'packages/openslug-init')
-rw-r--r--packages/openslug-init/openslug-init-0.10/conffiles49
-rw-r--r--packages/openslug-init/openslug-init-0.10/turnup16
-rw-r--r--packages/openslug-init/openslug-init_0.10.bb2
3 files changed, 61 insertions, 6 deletions
diff --git a/packages/openslug-init/openslug-init-0.10/conffiles b/packages/openslug-init/openslug-init-0.10/conffiles
index e69de29bb2..5f05a495a2 100644
--- a/packages/openslug-init/openslug-init-0.10/conffiles
+++ b/packages/openslug-init/openslug-init-0.10/conffiles
@@ -0,0 +1,49 @@
+# conffiles
+# Known OpenSlug configuration files. These files are preserved on
+# a flash upgrade. Other configuration files, found from:
+#
+# /usr/lib/ipkg/*.conffiles
+# /etc/*.conf
+#
+# are preserved too with an operation of 'diff' if they have been
+# changed since /etc/.configured was created.
+#
+# Lines starting with # are comments, other lines have
+# two fields:
+#
+# operation file
+#
+# The file must *NOT* have a leading /
+#
+# operation may be:
+# ignore Do not preserve this file
+# preserve Preserve this file unconditionally
+# diff Compare file with the new version, ask if different
+#
+preserve linuxrc
+preserve etc/.configured
+preserve etc/default/sysconf
+diff etc/default/conffiles
+diff etc/default/devpts
+diff etc/default/rcS
+diff etc/default/usbd
+preserve etc/profile
+preserve etc/hostname
+preserve etc/hosts
+preserve etc/defaultdomain
+preserve etc/resolv.conf
+preserve etc/syslog.conf
+preserve etc/motd
+preserve etc/network/interfaces
+preserve etc/dropbear/dropbear_rsa_host_key
+preserve etc/dropbear/dropbear_dss_host_key
+preserve etc/passwd
+preserve etc/shadow
+preserve etc/group
+preserve etc/gshadow
+preserve etc/ntp.drift
+preserve etc/timezone
+preserve etc/localtime
+preserve etc/TZ
+ignore etc/modules.conf
+ignore etc/modules
diff --git a/packages/openslug-init/openslug-init-0.10/turnup b/packages/openslug-init/openslug-init-0.10/turnup
index c6d422a2c7..ade85f0533 100644
--- a/packages/openslug-init/openslug-init-0.10/turnup
+++ b/packages/openslug-init/openslug-init-0.10/turnup
@@ -121,17 +121,23 @@ copy_rootfs() {
# In flash file systems /dev is in ramfs, in disk systems /dev
# can be populated permanently. This is done by creating a
# single entry '.noram' in /dev - the devices init script will
-# then populate the directory. The passed in device_table is
-# not currently used.
+# then populate the directory without overmounting it. The
+# devices in the passed in device table are also created, but
+# note that this is insufficient, /etc/init.d/devices must
+# also run.
setup_dev() {
test -n "$1" -a -d "$1"/dev -a -r "$2" || {
echo "turnup: setup_dev($1,$2): expected a directory and a file" >&2
return 1
}
- # at present the device_table is not used because it is incomplete,
- # /etc/init.d/devices adds extra stuff, it seems fine to leave
- # things this way
echo "turnup: initialising dev file system" >&2
+ # init tries to open the following devices:
+ # /dev/console
+ # /dev/tty0
+ # /dev/null
+ # syslog, and maybe other things, only work if fd 1 is valid, therefore
+ # we must create these devices here...
+ makedevs --root="$1" --devtable="$2"
:>"$1"/dev/.noram
return 0
}
diff --git a/packages/openslug-init/openslug-init_0.10.bb b/packages/openslug-init/openslug-init_0.10.bb
index ee619f0f31..76bd00754a 100644
--- a/packages/openslug-init/openslug-init_0.10.bb
+++ b/packages/openslug-init/openslug-init_0.10.bb
@@ -3,7 +3,7 @@ SECTION = "console/network"
LICENSE = "GPL"
DEPENDS = "base-files devio"
RDEPENDS = "busybox devio"
-PR = "r30"
+PR = "r31"
SRC_URI = "file://linuxrc \
file://boot/flash \