aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openssh
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-08-05 01:38:36 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-05 01:38:36 +0000
commit0a27b492faffa3c9bc088b7b6ece6b245f335a93 (patch)
treef366146788688c6676331d648af03bc81f89e069 /packages/openssh
parented02e99289cb9720b1cda4f0897b662f2d5936fe (diff)
downloadopenembedded-0a27b492faffa3c9bc088b7b6ece6b245f335a93.tar.gz
Add update-alternatives in pkg_postrm too
Diffstat (limited to 'packages/openssh')
-rw-r--r--packages/openssh/openssh_4.0p1.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/packages/openssh/openssh_4.0p1.bb b/packages/openssh/openssh_4.0p1.bb
index 47225eb532..2146813f83 100644
--- a/packages/openssh/openssh_4.0p1.bb
+++ b/packages/openssh/openssh_4.0p1.bb
@@ -11,7 +11,7 @@ used to provide applications with a secure communication channel."
HOMEPAGE = "http://www.openssh.org/"
LICENSE = "BSD"
MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
-PR = "r4"
+PR = "r5"
SRC_URI = "ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
file://configure.patch;patch=1 \
@@ -79,6 +79,14 @@ pkg_postinst_openssh-ssh() {
update-alternatives --install ${bindir}/ssh ssh ssh.${PN} 90
}
+pkg_postrm_openssh-ssh() {
+ update-alternatives --remove ${bindir}/ssh ssh.${PN}
+}
+
+pkg_postrm_openssh-scp() {
+ update-alternatives --remove ${bindir}/scp scp.${PN}
+}
+
pkg_postrm_openssh-sshd() {
if test "x$D" != "x"; then
exit 1