aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openssh
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-08-03 01:05:25 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-03 01:05:25 +0000
commita9687b1d451e962ea99b9a6097367057318440fe (patch)
treeb8a313584e59914434ce7274f2b3a7141669a253 /packages/openssh
parent1f46d61330cef352542dede22fb1c654ea7ddbd4 (diff)
downloadopenembedded-a9687b1d451e962ea99b9a6097367057318440fe.tar.gz
Update openssh to use update-alternatives
Diffstat (limited to 'packages/openssh')
-rw-r--r--packages/openssh/openssh_4.0p1.bb16
1 files changed, 13 insertions, 3 deletions
diff --git a/packages/openssh/openssh_4.0p1.bb b/packages/openssh/openssh_4.0p1.bb
index e3f78c2de5..e5b37d59b6 100644
--- a/packages/openssh/openssh_4.0p1.bb
+++ b/packages/openssh/openssh_4.0p1.bb
@@ -11,7 +11,7 @@ used to provide applications with a secure communication channel."
HOMEPAGE = "http://www.openssh.org/"
LICENSE = "BSD"
MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
-PR = "r1"
+PR = "r3"
SRC_URI = "ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
file://configure.patch;patch=1 \
@@ -46,11 +46,13 @@ do_compile_append () {
do_install_append() {
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/sshd
+ mv ${D}${bindir}/scp ${D}${bindir}/scp.openssh
+ mv ${D}${bindir}/ssh ${D}${bindir}/ssh.openssh
}
PACKAGES =+ " openssh-scp openssh-ssh openssh-sshd openssh-sftp openssh-misc"
-FILES_openssh-scp = "${bindir}/scp"
-FILES_openssh-ssh = "${bindir}/ssh ${bindir}/slogin /${sysconfdir}/ssh/ssh_config"
+FILES_openssh-scp = "${bindir}/scp.${PN}"
+FILES_openssh-ssh = "${bindir}/ssh.${PN} ${bindir}/slogin /${sysconfdir}/ssh/ssh_config"
FILES_openssh-sshd = "${sbindir}/sshd /${sysconfdir}/init.d/sshd ${bindir}/ssh-keygen"
FILES_openssh-sshd += " /${sysconfdir}/ssh/moduli /${sysconfdir}/ssh/sshd_config /var/run/sshd"
FILES_openssh-sftp = "${bindir}/sftp ${libdir}exec/sftp-server"
@@ -69,6 +71,14 @@ else
fi
}
+pkg_postinst_openssh-scp() {
+ update-alternatives --install ${bindir}/scp scp scp.${PN} 90
+}
+
+pkg_postinst_openssh-ssh() {
+ update-alternatives --install ${bindir}/ssh ssh ssh.${PN} 90
+}
+
pkg_postrm_openssh-sshd() {
if test "x$D" != "x"; then
exit 1