aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openssl
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2005-01-24 19:39:40 +0000
committerHolger Freyther <zecke@selfish.org>2005-01-24 19:39:40 +0000
commit0afae7a0356c706015bbae9e57f87169178d4f95 (patch)
treec730b6c0606e155c3efddbdc78d94e4f9a9780b3 /packages/openssl
parentaae545fceb3d3f3429579d1950816b24dcf6a603 (diff)
downloadopenembedded-0afae7a0356c706015bbae9e57f87169178d4f95.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into handhelds.org:/home/ich/programming/oe/openembedded 2005/01/23 22:23:54+01:00 handhelds.org!zecke OpenSSL 0.9.7e compile fix: -Push directory to util before calling perpathl.pl BKrev: 41f54efco8zZ89gchmcIY78Kw3zTRA
Diffstat (limited to 'packages/openssl')
-rw-r--r--packages/openssl/openssl_0.9.7e.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/packages/openssl/openssl_0.9.7e.bb b/packages/openssl/openssl_0.9.7e.bb
index e69de29bb2..2edb672d67 100644
--- a/packages/openssl/openssl_0.9.7e.bb
+++ b/packages/openssl/openssl_0.9.7e.bb
@@ -0,0 +1,79 @@
+SECTION = "libs"
+DESCRIPTION = "Secure Socket Layer (SSL) binary and related cryptographic tools."
+HOMEPAGE = "http://www.openssl.org/"
+LICENSE = "openssl"
+
+SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz \
+ file://debian.patch;patch=1"
+S = "${WORKDIR}/openssl-${PV}"
+
+AR_append = " r"
+export CFLAG = "-fPIC -DTHREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -DL_ENDIAN -DTERMIO -Wall ${FULL_OPTIMIZATION}"
+
+# -02 does not work on mipsel: ssh hangs when it tries to read /dev/urandom
+export CFLAG_mtx-1 := "${@'${CFLAG}'.replace('-O2', '')}"
+
+export DIRS = "crypto ssl apps"
+export EX_LIBS = "-lgcc -ldl -L${STAGING_LIBDIR}"
+export AS = "${CC} -c"
+
+PACKAGES =+ "libcrypto libssl"
+FILES_libcrypto = "${libdir}/libcrypto.so*"
+FILES_libssl = "${libdir}/libssl.so*"
+
+do_compile () {
+ pushd util
+ perl perlpath.pl ${bindir}
+ popd
+ ln -sf apps/openssl.pod crypto/crypto.pod ssl/ssl.pod doc/
+
+ #
+ # NOTE: Yes. This does suck. Ugh.
+ #
+ os=${HOST_OS}
+ if [ "x$os" = "xlinux-uclibc" ]; then
+ os=linux
+ fi
+ case $os-${HOST_ARCH} in
+ linux-arm)
+ target=linux-elf-arm
+ ;;
+ linux-i[34]86)
+ target=linux-elf
+ ;;
+ linux-i586)
+ target=linux-pentium
+ ;;
+ linux-i686)
+ target=linux-ppro
+ ;;
+ linux-mipsel)
+ target=linux-mipsel
+ ;;
+ linux-powerpc)
+ target=linux-ppc
+ ;;
+ linux-x86_64)
+ target=linux-x86_64
+ ;;
+ *)
+ die "Unsupported OS-ARCH ${HOST_OS}-${HOST_ARCH}"
+ ;;
+ esac
+ perl ./Configure shared --prefix=${prefix} --openssldir=${libdir}/ssl $target
+ oe_runmake
+}
+
+do_stage () {
+ cp --dereference -R include/openssl ${STAGING_INCDIR}/
+ oe_libinstall -a -so libcrypto ${STAGING_LIBDIR}
+ oe_libinstall -a -so libssl ${STAGING_LIBDIR}
+}
+
+do_install () {
+ install -m 0755 -d ${D}/${libdir}/pkgconfig
+ oe_runmake INSTALL_PREFIX="${D}" install
+ chmod 644 ${D}/${libdir}/pkgconfig/openssl.pc
+ oe_libinstall -so libcrypto ${D}/${libdir}
+ oe_libinstall -so libssl ${D}/${libdir}
+}