aboutsummaryrefslogtreecommitdiffstats
path: root/packages/opie-appearance
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-10-30 17:47:54 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-30 17:47:54 +0000
commit54dafed36398565d3d77e15ea6bec587af6f6575 (patch)
treef04bd9173da1473fd88abc1595833faaa375bbbd /packages/opie-appearance
parent999c5127d107e0d9a76a5383b59da8c35e3fd882 (diff)
downloadopenembedded-54dafed36398565d3d77e15ea6bec587af6f6575.tar.gz
opie-appearance 1.2.1: updated CVS backport of icon size settings
Diffstat (limited to 'packages/opie-appearance')
-rw-r--r--packages/opie-appearance/opie-appearance-1.2.1/add-ui-settings.patch26
-rw-r--r--packages/opie-appearance/opie-appearance_1.2.1.bb2
2 files changed, 14 insertions, 14 deletions
diff --git a/packages/opie-appearance/opie-appearance-1.2.1/add-ui-settings.patch b/packages/opie-appearance/opie-appearance-1.2.1/add-ui-settings.patch
index 821798720c..27fc32bac3 100644
--- a/packages/opie-appearance/opie-appearance-1.2.1/add-ui-settings.patch
+++ b/packages/opie-appearance/opie-appearance-1.2.1/add-ui-settings.patch
@@ -1,11 +1,11 @@
-Index: appearance2/appearance.cpp
+Index: appearance.cpp
===================================================================
RCS file: /cvs/opie/noncore/settings/appearance2/appearance.cpp,v
retrieving revision 1.35
-retrieving revision 1.36
-diff -u -u -r1.35 -r1.36
+retrieving revision 1.37
+diff -u -r1.35 -r1.37
--- appearance2/appearance.cpp 9 Jun 2005 20:47:58 -0000 1.35
-+++ appearance2/appearance.cpp 17 Oct 2005 13:28:09 -0000 1.36
++++ appearance2/appearance.cpp 26 Oct 2005 15:36:04 -0000 1.37
@@ -394,6 +394,39 @@
m_rotdir_ccw-> setChecked ( rot == CCW );
m_rotdir_flip-> setChecked ( rot == Flip );
@@ -17,11 +17,11 @@ diff -u -u -r1.35 -r1.36
+
+ QHBoxLayout *bigIconlay = new QHBoxLayout ( vertLayout, 3 );
+
-+ QLabel* label2 = new QLabel( tr( "&Big Icon size:" ), tab );
++ QLabel* label2 = new QLabel( tr( "Big Icon size:" ), tab );
+ bigIconlay-> addWidget ( label2, 0, 0 );
+
+ m_bigIconSize = new QSpinBox(0, 128, 1, tab);
-+ m_bigIconSize->setValue(cfg.readNumEntry( "BigIconSize" ));
++ m_bigIconSize->setValue(cfg.readNumEntry( "BigIconSize", AppLnk::bigIconSize() ));
+ bigIconlay->addWidget( m_bigIconSize );
+ label2->setBuddy( m_bigIconSize );
+ QWhatsThis::add( label2, tr( "Big Icon Size determines the size of the application icons in Launcher" ) );
@@ -29,20 +29,20 @@ diff -u -u -r1.35 -r1.36
+
+ QHBoxLayout *smallIconlay = new QHBoxLayout ( vertLayout, 3 );
+
-+ QLabel* label3 = new QLabel( tr( "&Small Icon size:" ), tab );
++ QLabel* label3 = new QLabel( tr( "Small Icon size:" ), tab );
+ smallIconlay-> addWidget ( label3, 0, 0 );
+
+ m_smallIconSize = new QSpinBox(0, 128, 1, tab);
-+ m_smallIconSize->setValue(cfg.readNumEntry( "SmallIconSize" ));
++ m_smallIconSize->setValue(cfg.readNumEntry( "SmallIconSize", AppLnk::smallIconSize() ));
+ smallIconlay->addWidget( m_smallIconSize );
+ label3->setBuddy( m_smallIconSize );
+ QWhatsThis::add( label3, tr( "Small Icon Size determines the size of many of the icons seen in applications (in menus, tab bars, tool bars, etc.), as well as the size of taskbar." ) );
+ QWhatsThis::add( m_smallIconSize, tr( "Small Icon Size determines the size of many of the icons seen in applications (in menus, tab bars, tool bars, etc.), as well as the size of taskbar." ) );
+
-+ m_useBigPixmaps = new QCheckBox( tr("use Big &Pixmaps"), tab);
-+ m_useBigPixmaps->setChecked(cfg.readBoolEntry( "useBigPixmaps" ));
++ m_useBigPixmaps = new QCheckBox( tr("use Big Pixmaps"), tab);
++ m_useBigPixmaps->setChecked(cfg.readBoolEntry( "useBigPixmaps", qApp->desktop()->width() > 320 ));
+ vertLayout->addWidget( m_useBigPixmaps );
-+ QWhatsThis::add( m_useBigPixmaps, tr( "Enlarge toolbar pixmaps" ) );
++ QWhatsThis::add( m_useBigPixmaps, tr( "Enlarge toolbar pixmaps, you probably want to enable this option for devices with screen resolution greater than 240x320" ) );
/*
* add a spacing
@@ -57,12 +57,12 @@ diff -u -u -r1.35 -r1.36
config. write ( ); // need to flush the config info first
Global::applyStyle ( );
-Index: appearance2/appearance.h
+Index: appearance.h
===================================================================
RCS file: /cvs/opie/noncore/settings/appearance2/appearance.h,v
retrieving revision 1.13
retrieving revision 1.14
-diff -u -u -r1.13 -r1.14
+diff -u -r1.13 -r1.14
--- appearance2/appearance.h 5 Jun 2005 22:47:00 -0000 1.13
+++ appearance2/appearance.h 17 Oct 2005 13:28:10 -0000 1.14
@@ -37,6 +37,7 @@
diff --git a/packages/opie-appearance/opie-appearance_1.2.1.bb b/packages/opie-appearance/opie-appearance_1.2.1.bb
index 312c715c6e..d6ba9fb452 100644
--- a/packages/opie-appearance/opie-appearance_1.2.1.bb
+++ b/packages/opie-appearance/opie-appearance_1.2.1.bb
@@ -1,6 +1,6 @@
include ${PN}.inc
-PR = "r1"
+PR = "r2"
SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/settings/appearance2 \
${HANDHELDS_CVS};tag=${TAG};module=opie/pics \