aboutsummaryrefslogtreecommitdiffstats
path: root/packages/pcmciautils
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-05-09 21:23:55 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-09 21:23:55 +0000
commite40b22d0624ef5fcba85ccd1c2d067f6f13449ab (patch)
tree72f82f1145c669a605bed8630cc93e8cc7eeaddb /packages/pcmciautils
parent83143fcd0fe903b86d8c803934529de4f7ae826d (diff)
downloadopenembedded-e40b22d0624ef5fcba85ccd1c2d067f6f13449ab.tar.gz
Add pcmciautils 013 including patches to remove hardcoded paths and a workaround for the toolchain bug that causes pccardctl to segfault
Diffstat (limited to 'packages/pcmciautils')
-rw-r--r--packages/pcmciautils/pcmciautils-013/.mtn2git_empty0
-rw-r--r--packages/pcmciautils/pcmciautils-013/makefile_fix.patch20
-rw-r--r--packages/pcmciautils/pcmciautils-013/version_workaround.patch16
-rw-r--r--packages/pcmciautils/pcmciautils_013.bb33
4 files changed, 69 insertions, 0 deletions
diff --git a/packages/pcmciautils/pcmciautils-013/.mtn2git_empty b/packages/pcmciautils/pcmciautils-013/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/pcmciautils/pcmciautils-013/.mtn2git_empty
diff --git a/packages/pcmciautils/pcmciautils-013/makefile_fix.patch b/packages/pcmciautils/pcmciautils-013/makefile_fix.patch
new file mode 100644
index 0000000000..a45f9e20e3
--- /dev/null
+++ b/packages/pcmciautils/pcmciautils-013/makefile_fix.patch
@@ -0,0 +1,20 @@
+Hardcoded paths are bad...
+
+Index: pcmciautils-013/Makefile
+===================================================================
+--- pcmciautils-013.orig/Makefile 2006-03-26 11:56:41.000000000 +0100
++++ pcmciautils-013/Makefile 2006-05-09 22:10:16.000000000 +0100
+@@ -69,11 +69,11 @@
+ mandir = ${prefix}/usr/share/man
+ srcdir = .
+
+-INSTALL = /usr/bin/install -c
++INSTALL = install -c
+ INSTALL_PROGRAM = ${INSTALL}
+ INSTALL_DATA = ${INSTALL} -m 644
+ INSTALL_SCRIPT = ${INSTALL_PROGRAM}
+-SYMLINK = /usr/bin/ln -sf
++SYMLINK = ln -sf
+
+ # place to put our hotplug scripts nodes
+ hotplugdir = ${etcdir}/hotplug
diff --git a/packages/pcmciautils/pcmciautils-013/version_workaround.patch b/packages/pcmciautils/pcmciautils-013/version_workaround.patch
new file mode 100644
index 0000000000..ff34e139b3
--- /dev/null
+++ b/packages/pcmciautils/pcmciautils-013/version_workaround.patch
@@ -0,0 +1,16 @@
+PCMCIAUTILS_VERSION is specified on the commandline but doesn't compile properly
+under arm gcc 3.4.x so we work around it.
+
+Index: pcmciautils-013/src/pccardctl.c
+===================================================================
+--- pcmciautils-013.orig/src/pccardctl.c 2006-03-26 11:56:41.000000000 +0100
++++ pcmciautils-013/src/pccardctl.c 2006-05-09 22:11:09.000000000 +0100
+@@ -350,7 +350,7 @@
+ }
+
+ static void print_header(void) {
+- printf("pcmciautils %s\n", PCMCIAUTILS_VERSION);
++ printf("pcmciautils 013\n");
+ printf("Copyright (C) 2004-2005 Dominik Brodowski, (C) 1999 David A. Hinds\n");
+ printf("Report errors and bugs to <linux-pcmcia@lists.infradead.org>, please.\n");
+ }
diff --git a/packages/pcmciautils/pcmciautils_013.bb b/packages/pcmciautils/pcmciautils_013.bb
new file mode 100644
index 0000000000..3dde683012
--- /dev/null
+++ b/packages/pcmciautils/pcmciautils_013.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Linux Kernel 2.6 Userland Utilities for the PCMCIA Subsystem"
+DEPENDS = "sysfsutils udev module-init-tools"
+RDEPENDS = "udev module-init-tools"
+HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+
+SRC_URI = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmciautils-${PV}.tar.bz2 \
+ file://makefile_fix.patch;patch=1 \
+ file://version_workaround.patch;patch=1"
+S = "${WORKDIR}/pcmciautils-${PV}"
+
+PR = "r0"
+
+export HOSTCC = "${BUILD_CC}"
+export etcdir = "${sysconfdir}"
+export sbindir = "${base_sbindir}"
+export pcmciaconfdir = "${sysconfdir}/pcmcia"
+export udevrulesdir = "${sysconfdir}/udev/rules.d"
+export UDEV = 1
+LD = "${CC}"
+CFLAGS =+ "-I${S}/src"
+CFLAGS =+ '-DPCMCIAUTILS_VERSION=013'
+
+PARALLEL_MAKE = ""
+EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs'"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+CONFFILES_${PN} += "${sysconfdir}/pcmcia/config.opts"
+RCONFLICTS_${PN} += "pcmcia-cs"