aboutsummaryrefslogtreecommitdiffstats
path: root/packages/pkgconfig
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2007-07-24 17:25:33 +0000
committerPhilip Balister <philip@balister.org>2007-07-24 17:25:33 +0000
commit13c300738c6a70493554efcda0a6705d44155152 (patch)
treeb45fd111115931edb03b7ec2efb9451e510a9469 /packages/pkgconfig
parent92be60866ede8c60c2be1e3445b5f0ba5b2db18d (diff)
downloadopenembedded-13c300738c6a70493554efcda0a6705d44155152.tar.gz
pkgconfig : Add support for pkgconfig-0.22. DEFAULT_PREF = -1 pending
further testing. pkconfig-0.22.bb does not build. Native version builds and corrects at least one issue with older pkgconfig.
Diffstat (limited to 'packages/pkgconfig')
-rw-r--r--packages/pkgconfig/pkgconfig-0.22/.mtn2git_empty0
-rw-r--r--packages/pkgconfig/pkgconfig-0.22/glibconfig-sysdefs.h6
-rw-r--r--packages/pkgconfig/pkgconfig-native_0.22.bb7
-rw-r--r--packages/pkgconfig/pkgconfig_0.22.bb30
4 files changed, 43 insertions, 0 deletions
diff --git a/packages/pkgconfig/pkgconfig-0.22/.mtn2git_empty b/packages/pkgconfig/pkgconfig-0.22/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/pkgconfig/pkgconfig-0.22/.mtn2git_empty
diff --git a/packages/pkgconfig/pkgconfig-0.22/glibconfig-sysdefs.h b/packages/pkgconfig/pkgconfig-0.22/glibconfig-sysdefs.h
new file mode 100644
index 0000000000..1329e7f21c
--- /dev/null
+++ b/packages/pkgconfig/pkgconfig-0.22/glibconfig-sysdefs.h
@@ -0,0 +1,6 @@
+#define GLIB_SYSDEF_POLLIN =1
+#define GLIB_SYSDEF_POLLOUT =4
+#define GLIB_SYSDEF_POLLPRI =2
+#define GLIB_SYSDEF_POLLERR =8
+#define GLIB_SYSDEF_POLLHUP =16
+#define GLIB_SYSDEF_POLLNVAL =32
diff --git a/packages/pkgconfig/pkgconfig-native_0.22.bb b/packages/pkgconfig/pkgconfig-native_0.22.bb
new file mode 100644
index 0000000000..507a74b7d9
--- /dev/null
+++ b/packages/pkgconfig/pkgconfig-native_0.22.bb
@@ -0,0 +1,7 @@
+SECTION = "console/utils"
+require pkgconfig_${PV}.bb
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/pkgconfig-${PV}"
+
+S = "${WORKDIR}/pkg-config-${PV}/"
+inherit native
+DEPENDS = ""
diff --git a/packages/pkgconfig/pkgconfig_0.22.bb b/packages/pkgconfig/pkgconfig_0.22.bb
new file mode 100644
index 0000000000..f634a87940
--- /dev/null
+++ b/packages/pkgconfig/pkgconfig_0.22.bb
@@ -0,0 +1,30 @@
+SECTION = "console/utils"
+DESCRIPTION = "pkg-config is a system for managing library \
+compile/link flags that works with automake and autoconf. \
+It replaces the ubiquitous *-config scripts you may have \
+seen with a single tool."
+HOMEPAGE = "http://pkg-config.freedesktop.org/wiki/"
+LICENSE = "GPL"
+PR = "r0"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://pkgconfig.freedesktop.org/releases/pkg-config-${PV}.tar.gz \
+ file://glibconfig-sysdefs.h"
+
+S = "${WORKDIR}/pkg-config-${PV}/"
+
+inherit autotools
+
+acpaths = "-I ."
+do_configure () {
+ install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h glib-1.2.8/
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+do_stage_prepend() {
+ install -d -m 0755 ${STAGING_DATADIR}/pkgconfig
+
+}