aboutsummaryrefslogtreecommitdiffstats
path: root/packages/psmisc
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-06-28 00:32:21 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-28 00:32:21 +0000
commitd0b038d42a9b6cc23f98e974ef4b7e4397073dfd (patch)
tree69a539f98bd3cd31e74fda13f975dfa2f278f604 /packages/psmisc
parent6ee41b771288404380e3e3f88828b61328822be6 (diff)
downloadopenembedded-d0b038d42a9b6cc23f98e974ef4b7e4397073dfd.tar.gz
psmisc 21.8: Update for uClibc. psmisc requires libintl on uClibc which it
correctly determines in the configure script but fails to actually use. Patch Makefile.am to link to libintl if it determines that it's required. Has no effect on the glibc build. Also added virtual/libintl to the DEPENDS.
Diffstat (limited to 'packages/psmisc')
-rw-r--r--packages/psmisc/psmisc-21.8/libintl-link.patch29
-rw-r--r--packages/psmisc/psmisc_21.8.bb7
2 files changed, 33 insertions, 3 deletions
diff --git a/packages/psmisc/psmisc-21.8/libintl-link.patch b/packages/psmisc/psmisc-21.8/libintl-link.patch
new file mode 100644
index 0000000000..d9cdd90d71
--- /dev/null
+++ b/packages/psmisc/psmisc-21.8/libintl-link.patch
@@ -0,0 +1,29 @@
+uClibc needs to link against an external libintl but it doesn't do this by
+default. The configure script correctly figures out if this is needed, but
+doesn't actually link to the libraries it decides on. This makes it link to
+them if they are needed:
+
+--- psmisc-22.2/src/Makefile.am 2006/06/28 00:14:07 1.1
++++ psmisc-22.2/src/Makefile.am 2006/06/28 00:14:24
+@@ -5,15 +5,19 @@
+
+ oldfuser_SOURCES = oldfuser.c comm.h signals.c signals.h loop.h i18n.h
+
++oldfuser_LDADD = @INTLLIBS@
++
+ fuser_SOURCES = fuser.c comm.h signals.c signals.h i18n.h fuser.h
+
++fuser_LDADD = @INTLLIBS@
++
+ killall_SOURCES = killall.c comm.h signals.c signals.h i18n.h
+
+-killall_LDADD = @SELINUX_LIB@
++killall_LDADD = @SELINUX_LIB@ @INTLLIBS@
+
+ pstree_SOURCES = pstree.c comm.h i18n.h
+
+-pstree_LDADD = @TERMCAP_LIB@ @SELINUX_LIB@
++pstree_LDADD = @TERMCAP_LIB@ @SELINUX_LIB@ @INTLLIBS@
+
+ BUILT_SOURCES = signames.h
+
diff --git a/packages/psmisc/psmisc_21.8.bb b/packages/psmisc/psmisc_21.8.bb
index 4d10633a3f..f7d6828a94 100644
--- a/packages/psmisc/psmisc_21.8.bb
+++ b/packages/psmisc/psmisc_21.8.bb
@@ -3,11 +3,12 @@ DESCRIPTION = "procfs tools"
SECTION = "base"
PRIORITY = "required"
MAINTAINER = "Greg Gilbert <greg@treke.net>"
-DEPENDS = "ncurses"
-PR = "r0"
+DEPENDS = "ncurses virtual/libintl"
+PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/psmisc/psmisc-${PV}.tar.gz \
- file://signames-header-fix.patch;patch=1"
+ file://signames-header-fix.patch;patch=1 \
+ file://libintl-link.patch;patch=1"
S = "${WORKDIR}/psmisc-${PV}"
inherit autotools gettext