aboutsummaryrefslogtreecommitdiffstats
path: root/packages/pth
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-01-26 12:42:05 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-01-26 12:42:05 +0000
commit82f5acfeac4e585adb7982155b80916469b4098c (patch)
tree9af985c4bcdd4d6f08bf111c71249f2920d45f99 /packages/pth
parent4db45153b6aa998fa97eef95212f5d0b972f1030 (diff)
downloadopenembedded-82f5acfeac4e585adb7982155b80916469b4098c.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/01/26 13:41:52+01:00 uni-frankfurt.de!mickeyl add usb patches courtesy Dave Brownell BKrev: 41f7901dbnSa5Pz5GULnKaUyvY55Mg
Diffstat (limited to 'packages/pth')
-rw-r--r--packages/pth/pth_2.0.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/pth/pth_2.0.2.bb b/packages/pth/pth_2.0.2.bb
index e69de29bb2..14621818da 100644
--- a/packages/pth/pth_2.0.2.bb
+++ b/packages/pth/pth_2.0.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "GNU Portable Threads"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+PR = "r0"
+
+SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz"
+
+inherit autotools
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_stage() {
+ oe_libinstall -so libpth ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/
+ for X in pth.h
+ do
+ install -m 0644 ${S}/$X ${STAGING_INCDIR}/$X
+ done
+
+ install -d ${STAGING_DATADIR}/aclocal
+ install pth.m4 ${STAGING_DATADIR}/aclocal/
+}