aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-05-31 13:01:02 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-31 13:01:02 +0000
commite07562d35a38b7d7643e805b1911132160caf37c (patch)
tree90855b053697652ae09c644b375156a74bf0d82f /packages/python
parent8956cf5769f9a3169f22b4fda1da2a57abbc9749 (diff)
downloadopenembedded-e07562d35a38b7d7643e805b1911132160caf37c.tar.gz
python-formencode: added 0.4
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-formencode/.mtn2git_empty0
-rw-r--r--packages/python/python-formencode/setup.py.diff13
-rw-r--r--packages/python/python-formencode_0.4.bb13
3 files changed, 26 insertions, 0 deletions
diff --git a/packages/python/python-formencode/.mtn2git_empty b/packages/python/python-formencode/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-formencode/.mtn2git_empty
diff --git a/packages/python/python-formencode/setup.py.diff b/packages/python/python-formencode/setup.py.diff
new file mode 100644
index 0000000000..dc9db4352e
--- /dev/null
+++ b/packages/python/python-formencode/setup.py.diff
@@ -0,0 +1,13 @@
+--- python-formencode-0.4.orig/setup.py
++++ python-formencode-0.4/setup.py
+@@ -1,6 +1,7 @@
+-from ez_setup import use_setuptools
+-use_setuptools()
+-from setuptools import setup
++#from ez_setup import use_setuptools
++#use_setuptools()
++#from setuptools import setup
++from distutils.core import setup
+
+ version = '0.4'
+
diff --git a/packages/python/python-formencode_0.4.bb b/packages/python/python-formencode_0.4.bb
new file mode 100644
index 0000000000..40e1f3e359
--- /dev/null
+++ b/packages/python/python-formencode_0.4.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "HTML form validation, generation, and conversion package"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "sqlite3"
+SRCNAME = "FormEncode"
+
+inherit distutils
+
+SRC_URI = "http://cheeseshop.python.org/packages/source/F/FormEncode/FormEncode-${PV}.tar.gz \
+file://setup.py.diff;patch=1"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"