aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-02-16 21:43:38 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-02-16 21:43:38 +0100
commit8e153638402df20f80361a55f527427abf0ac961 (patch)
tree35caa3e117a92959d8bb7f7b083b3a9b64d5d05f /packages/python
parent9924d91be0e298c2267238cd638a10f328ab7f8a (diff)
downloadopenembedded-8e153638402df20f80361a55f527427abf0ac961.tar.gz
python-native-2.5.1: remove forgotten dir
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-native-2.5.1/bindir-libdir.patch18
-rw-r--r--packages/python/python-native-2.5.1/catchup-with-swig.patch13
-rw-r--r--packages/python/python-native-2.5.1/cross-distutils.patch36
-rw-r--r--packages/python/python-native-2.5.1/default-is-optimized.patch13
-rw-r--r--packages/python/python-native-2.5.1/dont-modify-shebang-line.patch16
-rw-r--r--packages/python/python-native-2.5.1/fix-staging.patch38
6 files changed, 0 insertions, 134 deletions
diff --git a/packages/python/python-native-2.5.1/bindir-libdir.patch b/packages/python/python-native-2.5.1/bindir-libdir.patch
deleted file mode 100644
index 999bddc449..0000000000
--- a/packages/python/python-native-2.5.1/bindir-libdir.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Made by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- Python-2.3.1/Makefile.pre.in~bindir-libdir 2003-09-20 12:50:28.000000000 +0200
-+++ Python-2.3.1/Makefile.pre.in 2003-11-02 19:53:17.000000000 +0100
-@@ -78,8 +78,8 @@
- exec_prefix= @exec_prefix@
-
- # Expanded directories
--BINDIR= $(exec_prefix)/bin
--LIBDIR= $(exec_prefix)/lib
-+BINDIR= @bindir@
-+LIBDIR= @libdir@
- MANDIR= @mandir@
- INCLUDEDIR= @includedir@
- CONFINCLUDEDIR= $(exec_prefix)/include
diff --git a/packages/python/python-native-2.5.1/catchup-with-swig.patch b/packages/python/python-native-2.5.1/catchup-with-swig.patch
deleted file mode 100644
index f049b759f4..0000000000
--- a/packages/python/python-native-2.5.1/catchup-with-swig.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: Python-2.5.1/Lib/distutils/command/build_ext.py
-===================================================================
---- Python-2.5.1.orig/Lib/distutils/command/build_ext.py
-+++ Python-2.5.1/Lib/distutils/command/build_ext.py
-@@ -513,7 +513,7 @@ class build_ext (Command):
- target_lang=language)
-
-
-- def swig_sources (self, sources, extension):
-+ def swig_sources (self, sources, extension=None):
-
- """Walk the list of source files in 'sources', looking for SWIG
- interface (.i) files. Run SWIG on all that are found, and
diff --git a/packages/python/python-native-2.5.1/cross-distutils.patch b/packages/python/python-native-2.5.1/cross-distutils.patch
deleted file mode 100644
index 3356c1abbe..0000000000
--- a/packages/python/python-native-2.5.1/cross-distutils.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- Python-2.3.3/Lib/distutils/sysconfig.py~cross-distutils 2003-02-10 15:02:33.000000000 +0100
-+++ Python-2.3.3/Lib/distutils/sysconfig.py 2004-03-02 20:15:05.000000000 +0100
-@@ -19,8 +19,8 @@
- from errors import DistutilsPlatformError
-
- # These are needed in a couple of spots, so just compute them once.
--PREFIX = os.path.normpath(sys.prefix)
--EXEC_PREFIX = os.path.normpath(sys.exec_prefix)
-+PREFIX = os.path.normpath(sys.prefix).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
-+EXEC_PREFIX = os.path.normpath(sys.exec_prefix).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
-
- # python_build: (Boolean) if true, we're either building Python or
- # building an extension with an un-installed Python, so we use
-@@ -192,7 +192,7 @@
- else:
- # The name of the config.h file changed in 2.2
- config_h = 'pyconfig.h'
-- return os.path.join(inc_dir, config_h)
-+ return os.path.join(inc_dir, config_h).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
-
-
- def get_makefile_filename():
-@@ -200,7 +200,7 @@
- if python_build:
- return os.path.join(os.path.dirname(sys.executable), "Makefile")
- lib_dir = get_python_lib(plat_specific=1, standard_lib=1)
-- return os.path.join(lib_dir, "config", "Makefile")
-+ return os.path.join(lib_dir, "config", "Makefile").replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
-
-
- def parse_config_h(fp, g=None):
diff --git a/packages/python/python-native-2.5.1/default-is-optimized.patch b/packages/python/python-native-2.5.1/default-is-optimized.patch
deleted file mode 100644
index 6beeb6e022..0000000000
--- a/packages/python/python-native-2.5.1/default-is-optimized.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: Python-2.5.1/Python/compile.c
-===================================================================
---- Python-2.5.1.orig/Python/compile.c
-+++ Python-2.5.1/Python/compile.c
-@@ -30,7 +30,7 @@
- #include "symtable.h"
- #include "opcode.h"
-
--int Py_OptimizeFlag = 0;
-+int Py_OptimizeFlag = 1;
-
- /*
- ISSUES:
diff --git a/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch b/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch
deleted file mode 100644
index 54109afd62..0000000000
--- a/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-
-#
-# Signed off by Michael 'Mickey' Lauer <mickey@Vanille.de>
-#
-
---- Python-2.4/Lib/distutils/command/build_scripts.py~dont-modify-shebang-line
-+++ Python-2.4/Lib/distutils/command/build_scripts.py
-@@ -87,7 +87,7 @@
- continue
-
- match = first_line_re.match(first_line)
-- if match:
-+ if False: #match:
- adjust = 1
- post_interp = match.group(1) or ''
-
diff --git a/packages/python/python-native-2.5.1/fix-staging.patch b/packages/python/python-native-2.5.1/fix-staging.patch
deleted file mode 100644
index 087c813fd4..0000000000
--- a/packages/python/python-native-2.5.1/fix-staging.patch
+++ /dev/null
@@ -1,38 +0,0 @@
----
- Lib/distutils/sysconfig.py | 10 ++++++++--
- 1 file changed, 8 insertions(+), 2 deletions(-)
-
---- Python-2.5.1.orig/Lib/distutils/sysconfig.py
-+++ Python-2.5.1/Lib/distutils/sysconfig.py
-@@ -52,11 +52,14 @@ def get_python_inc(plat_specific=0, pref
-
- If 'prefix' is supplied, use it instead of sys.prefix or
- sys.exec_prefix -- i.e., ignore 'plat_specific'.
- """
- if prefix is None:
-- prefix = plat_specific and EXEC_PREFIX or PREFIX
-+ if plat_specific:
-+ prefix = plat_specific and os.environ['STAGING_INCDIR'].rstrip('include')
-+ else:
-+ prefix = plat_specific and EXEC_PREFIX or PREFIX
- if os.name == "posix":
- if python_build:
- base = os.path.dirname(os.path.abspath(sys.executable))
- if plat_specific:
- inc_dir = base
-@@ -94,11 +97,14 @@ def get_python_lib(plat_specific=0, stan
-
- If 'prefix' is supplied, use it instead of sys.prefix or
- sys.exec_prefix -- i.e., ignore 'plat_specific'.
- """
- if prefix is None:
-- prefix = plat_specific and EXEC_PREFIX or PREFIX
-+ if plat_specific:
-+ prefix = plat_specific and os.environ['STAGING_LIBDIR'].rstrip('lib')
-+ else:
-+ prefix = plat_specific and EXEC_PREFIX or PREFIX
-
- if os.name == "posix":
- libpython = os.path.join(prefix,
- "lib", "python" + get_python_version())
- if standard_lib: