aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-03-06 17:09:44 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-03-06 17:09:44 +0000
commit0b80abf3a5a3256700ca39d5a41b8c5877f3080c (patch)
tree6e9893d5dad1ebff64f5c00c365c8bca10b261fd /packages/python
parent9fab57528848c104a95662bfb416378d7e50d666 (diff)
downloadopenembedded-0b80abf3a5a3256700ca39d5a41b8c5877f3080c.tar.gz
python 2.5.2 ship _sqlite3.so binary module in python-sqlite3 (thanks emdete for spotting)
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-2.5-manifest.inc12
-rw-r--r--packages/python/python_2.5.2.bb7
2 files changed, 8 insertions, 11 deletions
diff --git a/packages/python/python-2.5-manifest.inc b/packages/python/python-2.5-manifest.inc
index 5288bafbf4..9c4e68dfce 100644
--- a/packages/python/python-2.5-manifest.inc
+++ b/packages/python/python-2.5-manifest.inc
@@ -1,5 +1,5 @@
-########################################################################################################################
-### AUTO-GENERATED by './generate-manifest-2.5.py' [(C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>] on Wed Feb 27 13:29:38 2008
+#######################################################################################################################
+### AUTO-GENERATED by './contrib/python/generate-manifest-2.5.py' [(C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>] on Thu Mar 6 18:04:21 2008
###
### Visit THE Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
###
@@ -127,7 +127,7 @@ PR_python-unixadmin="ml0"
RDEPENDS_python-unixadmin="python-core"
FILES_python-unixadmin="${libdir}/python2.5/lib-dynload/nis.so ${libdir}/python2.5/lib-dynload/grp.so ${libdir}/python2.5/lib-dynload/pwd.so ${libdir}/python2.5/getpass.* "
-DESCRIPTION_python-syslog="Python's syslog Interface"
+DESCRIPTION_python-syslog="Python's Syslog Interface"
PR_python-syslog="ml0"
RDEPENDS_python-syslog="python-core"
FILES_python-syslog="${libdir}/python2.5/lib-dynload/syslog.so "
@@ -213,9 +213,9 @@ RDEPENDS_python-mime="python-core python-io"
FILES_python-mime="${libdir}/python2.5/mimetools.* ${libdir}/python2.5/uu.* ${libdir}/python2.5/quopri.* ${libdir}/python2.5/rfc822.* "
DESCRIPTION_python-sqlite3="Python Sqlite3 Database Support"
-PR_python-sqlite3="ml0"
+PR_python-sqlite3="ml1"
RDEPENDS_python-sqlite3="python-core"
-FILES_python-sqlite3="${libdir}/python2.5/sqlite3 "
+FILES_python-sqlite3="${libdir}/python2.5/lib-dynload/_sqlite3.so ${libdir}/python2.5/sqlite3 "
DESCRIPTION_python-tests="Python Tests"
PR_python-tests="ml0"
@@ -278,7 +278,7 @@ RDEPENDS_python-db="python-core"
FILES_python-db="${libdir}/python2.5/anydbm.* ${libdir}/python2.5/dumbdbm.* ${libdir}/python2.5/whichdb.* "
DESCRIPTION_python-crypt="Python Basic Cryptographic and Hashing Support"
-PR_python-crypt="ml0"
+PR_python-crypt="ml1"
RDEPENDS_python-crypt="python-core"
FILES_python-crypt="${libdir}/python2.5/hashlib.* ${libdir}/python2.5/md5.* ${libdir}/python2.5/sha.* ${libdir}/python2.5/lib-dynload/crypt.so ${libdir}/python2.5/lib-dynload/_hashlib.so ${libdir}/python2.5/lib-dynload/_sha256.so ${libdir}/python2.5/lib-dynload/_sha512.so "
diff --git a/packages/python/python_2.5.2.bb b/packages/python/python_2.5.2.bb
index e6667cc04b..af907f23c9 100644
--- a/packages/python/python_2.5.2.bb
+++ b/packages/python/python_2.5.2.bb
@@ -5,9 +5,7 @@ SECTION = "devel/python"
PRIORITY = "optional"
DEPENDS = "python-native readline zlib gdbm openssl sqlite3 tcl tk"
DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
-
-# NOTE: Keep the digit in sync with BASEREV in contrib/generate-manifest-2.5.py
-PR = "ml0"
+PR = "ml1"
PYTHON_MAJMIN = "2.5"
@@ -82,11 +80,10 @@ do_install() {
require python-${PYTHON_MAJMIN}-manifest.inc
-# manual additions
+# manual dependency additions
RPROVIDES_python-core = "python"
RRECOMMENDS_python-core = "python-readline"
RRECOMMENDS_python-crypt = "openssl"
-PR_python-crypt = "ml1"
# add sitecustomize
FILES_python-core += "${libdir}/python${PYTHON_MAJMIN}/sitecustomize.py"