aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-05-01 10:28:12 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-05-01 10:28:12 +0000
commit3338a47c2494662ce4e277c7215c1584ec6b0f53 (patch)
treeb6cc5463b7274966d3d4328944c5bdffc88ec44e /packages/python
parent15e55042eecb5d0586b82b176d5b6a25382cb91f (diff)
downloadopenembedded-3338a47c2494662ce4e277c7215c1584ec6b0f53.tar.gz
python-setuptools 0.6c6 add -native package, fix dependencies, make it a non-native package
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-setuptools-native_0.6c6.bb8
-rw-r--r--packages/python/python-setuptools_0.6c6.bb7
2 files changed, 9 insertions, 6 deletions
diff --git a/packages/python/python-setuptools-native_0.6c6.bb b/packages/python/python-setuptools-native_0.6c6.bb
new file mode 100644
index 0000000000..1b9f90911d
--- /dev/null
+++ b/packages/python/python-setuptools-native_0.6c6.bb
@@ -0,0 +1,8 @@
+require python-setuptools_${PV}.bb
+
+DEPENDS = "python-native"
+
+do_stage() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ ${STAGING_BINDIR_NATIVE}/python setup.py install
+}
diff --git a/packages/python/python-setuptools_0.6c6.bb b/packages/python/python-setuptools_0.6c6.bb
index ef56b9b652..721b29961e 100644
--- a/packages/python/python-setuptools_0.6c6.bb
+++ b/packages/python/python-setuptools_0.6c6.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
SECTION = "devel/python"
PRIORITY = "optional"
LICENSE = "MIT-like"
-RDEPENDS = "python-core python-zlib"
+RDEPENDS = "python-distutils python-compression"
SRCNAME = "setuptools"
PR = "ml1"
@@ -15,8 +15,3 @@ inherit distutils
do_install_prepend() {
install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
}
-
-do_stage() {
- BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
- ${STAGING_BINDIR_NATIVE}/python setup.py install
-}