aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-02-19 00:24:34 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-02-19 00:24:34 +0000
commit3c93cedf7c10f7751de0209cd33338cca8005c11 (patch)
tree1cdc036280079e61843763486b291c3775a5135c /packages/python
parent0d892325e298089764eeb56f6202f545a1187a45 (diff)
downloadopenembedded-3c93cedf7c10f7751de0209cd33338cca8005c11.tar.gz
python-dbus 0.81.1 update to 0.82.4, patches no longer necessary
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-dbus/.mtn2git_empty0
-rw-r--r--packages/python/python-dbus/allow-older-autotools.patch27
-rw-r--r--packages/python/python-dbus/python-path.patch21
-rw-r--r--packages/python/python-dbus_0.82.4.bb (renamed from packages/python/python-dbus_0.81.1.bb)12
4 files changed, 5 insertions, 55 deletions
diff --git a/packages/python/python-dbus/.mtn2git_empty b/packages/python/python-dbus/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/python/python-dbus/.mtn2git_empty
+++ /dev/null
diff --git a/packages/python/python-dbus/allow-older-autotools.patch b/packages/python/python-dbus/allow-older-autotools.patch
deleted file mode 100644
index 7595f70e5d..0000000000
--- a/packages/python/python-dbus/allow-older-autotools.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-#
-# so it looks like dbus-python really doesn't make use of any 2.59c features
-# Signed-Off: mickey@openmoko.org
-#
-Index: dbus-python-0.81.1/configure.ac
-===================================================================
---- dbus-python-0.81.1.orig/configure.ac 2007-06-04 13:17:10.000000000 +0000
-+++ dbus-python-0.81.1/configure.ac 2007-06-11 06:57:20.000000000 +0000
-@@ -1,5 +1,5 @@
- -*- mode: m4 -*-
--AC_PREREQ(2.59c)
-+AC_PREREQ(2.59)
-
- dnl If not 1, append datestamp to the version number
- m4_define(dbus_python_released, 1)
-Index: dbus-python-0.81.1/Makefile.am
-===================================================================
---- dbus-python-0.81.1.orig/Makefile.am 2007-05-09 09:44:40.000000000 +0000
-+++ dbus-python-0.81.1/Makefile.am 2007-06-11 06:59:23.000000000 +0000
-@@ -38,6 +38,7 @@
-
- TXT_RSTDOCS = doc/tutorial.txt doc/API_CHANGES.txt doc/HACKING.txt
- RSTDOCS = README NEWS TODO
-+docdir=foo
- dist_doc_DATA = $(TXT_RSTDOCS) $(RSTDOCS)
-
- maintainer-update-website: _maintainer-update-apidocs \
diff --git a/packages/python/python-dbus/python-path.patch b/packages/python/python-dbus/python-path.patch
deleted file mode 100644
index 6bdbd19d03..0000000000
--- a/packages/python/python-dbus/python-path.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- dbus-python-0.81.1/m4.orig/am-check-python-headers.m4
-+++ dbus-python-0.81.1/m4/am-check-python-headers.m4
-@@ -7214,12 +7214,18 @@
- [AC_REQUIRE([AM_PATH_PYTHON])
- AC_MSG_CHECKING(for headers required to compile python extensions)
- dnl deduce PYTHON_INCLUDES
-+AC_ARG_WITH(python-includes,
-+ [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
-+if test x$py_exec_prefix != x; then
-+PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
-+else
- py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
- py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
- PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
- if test "$py_prefix" != "$py_exec_prefix"; then
- PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
- fi
-+fi
- AC_SUBST(PYTHON_INCLUDES)
- dnl check if the headers exist:
- save_CPPFLAGS="$CPPFLAGS"
diff --git a/packages/python/python-dbus_0.81.1.bb b/packages/python/python-dbus_0.82.4.bb
index 86628bad26..9f00c64701 100644
--- a/packages/python/python-dbus_0.81.1.bb
+++ b/packages/python/python-dbus_0.82.4.bb
@@ -1,20 +1,18 @@
DESCRIPTION = "Python bindings for DBus, a socket-based message bus system for interprocess communication"
SECTION = "devel/python"
HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
-LICENSE = "GPL"
+LICENSE = "MIT"
DEPENDS = "expat glib-2.0 virtual/libintl python-pyrex-native python"
RDEPENDS = "dbus python-threading python-io python-stringold python-logging"
-PR = "ml2"
-
-SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
- file://allow-older-autotools.patch;patch=1 \
- file://python-path.patch;patch=1"
+PR = "ml0"
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
S = "${WORKDIR}/dbus-python-${PV}"
inherit distutils-base autotools
-EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+export BUILD_SYS := "${BUILD_SYS}"
+export HOST_SYS := "${HOST_SYS}"
do_stage() {
autotools_stage_all