aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-03-08 11:48:19 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-03-08 11:48:19 +0000
commit9d42c6d52697e45545f2a83dd014278c038f75ca (patch)
treefe9d3db680bc80e005dcc9e1879030612a34c789 /packages/python
parentc2c6dc9df65d2f7f5d1aad7af5c5e2b4167e1335 (diff)
downloadopenembedded-9d42c6d52697e45545f2a83dd014278c038f75ca.tar.gz
python-pyiw 0.3.3 fix unpacking
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-pyiw_0.3.3.bb15
1 files changed, 7 insertions, 8 deletions
diff --git a/packages/python/python-pyiw_0.3.3.bb b/packages/python/python-pyiw_0.3.3.bb
index aa86a07e8f..aaa18c7ee9 100644
--- a/packages/python/python-pyiw_0.3.3.bb
+++ b/packages/python/python-pyiw_0.3.3.bb
@@ -5,25 +5,24 @@ SECTION = "devel/python"
PRIORITY = "optional"
LICENSE = "GPL"
DEPENDS = "wireless-tools"
-RDEPENDS = "python-core libiw"
+RDEPENDS = "python-core"
PR = "ml0"
+inherit autotools pkgconfig distutils-base
+
+CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR}"
+
SRC_URI = "http://downloads.emperorlinux.com/contrib/pyiw/pyiw-${PV}.tbz2 \
file://Makefile"
-
-S="${WORKDIR}/pyiw-${PV}"
+S = "${WORKDIR}/pyiw-${PV}"
do_unpack_real () {
- tar jxvf pyiw-${PV}.tbz2
+ tar jxvf ${DL_DIR}/pyiw-${PV}.tbz2
cp Makefile pyiw-${PV}/
}
do_unpack_real[dirs] = "${WORKDIR}"
addtask unpack_real before do_patch after do_unpack
-inherit autotools pkgconfig distutils-base
-
-CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR}"
-
do_install() {
install -d ${D}${libdir}/${PYTHON_DIR}/site-packages/
install -m 0755 pyiw.so ${D}${libdir}/${PYTHON_DIR}/site-packages/pyiw.so