aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2007-12-07 12:25:16 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2007-12-07 12:25:16 +0000
commit40706bdd536c7e23644d5502267b1e5f691864fc (patch)
treed2c1c0e12f190536073d61b71bc77307cb1405ec /packages/python
parent16263835f024bde8c8fd7a69f1ac49b3506c8e39 (diff)
downloadopenembedded-40706bdd536c7e23644d5502267b1e5f691864fc.tar.gz
python-pysqlite2: add pysqlite Python interface to SQLite 3
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-pysqlite2/.mtn2git_empty0
-rw-r--r--packages/python/python-pysqlite2/fix-setup.patch9
-rw-r--r--packages/python/python-pysqlite2_2.4.0.bb17
3 files changed, 26 insertions, 0 deletions
diff --git a/packages/python/python-pysqlite2/.mtn2git_empty b/packages/python/python-pysqlite2/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-pysqlite2/.mtn2git_empty
diff --git a/packages/python/python-pysqlite2/fix-setup.patch b/packages/python/python-pysqlite2/fix-setup.patch
new file mode 100644
index 0000000000..fb732a1c3d
--- /dev/null
+++ b/packages/python/python-pysqlite2/fix-setup.patch
@@ -0,0 +1,9 @@
+diff -urN pysqlite-2.4.0.orig/setup.cfg pysqlite-2.4.0/setup.cfg
+--- pysqlite-2.4.0.orig/setup.cfg 2007-11-25 17:56:17.000000000 +0100
++++ pysqlite-2.4.0/setup.cfg 2007-12-07 09:59:36.000000000 +0100
+@@ -1,5 +1,3 @@
+ [build_ext]
+ define=
+-include_dirs=/usr/include
+-library_dirs=/usr/lib
+ libraries=sqlite3
diff --git a/packages/python/python-pysqlite2_2.4.0.bb b/packages/python/python-pysqlite2_2.4.0.bb
new file mode 100644
index 0000000000..751122e10e
--- /dev/null
+++ b/packages/python/python-pysqlite2_2.4.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Python interface to SQLite 3"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "BSD"
+DEPENDS = "sqlite3"
+SRCNAME = "pysqlite"
+
+SRC_URI = "http://initd.org/pub/software/pysqlite/releases/2.4/${PV}/${SRCNAME}-${PV}.tar.gz \
+ file://fix-setup.patch;patch=1"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_install_append() {
+ install -d ${D}${datadir}/doc/
+ mv ${D}${datadir}/pysqlite2-doc ${D}${datadir}/doc/${PN}
+}