aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-05-31 13:04:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-31 13:04:37 +0000
commitf0b7c45a78ccb9ac551797288f25e891c4031e56 (patch)
treef7e3f431b6fa133f39f53a2105516128c5c3bd87 /packages/python
parentbc52fc5d5ace3786c60f6aff09dc4e661a887a75 (diff)
downloadopenembedded-f0b7c45a78ccb9ac551797288f25e891c4031e56.tar.gz
python-imaging: added 1.1.5 (also called PIL)
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-imaging/.mtn2git_empty0
-rw-r--r--packages/python/python-imaging/path.patch37
-rw-r--r--packages/python/python-imaging_1.1.5.bb33
3 files changed, 70 insertions, 0 deletions
diff --git a/packages/python/python-imaging/.mtn2git_empty b/packages/python/python-imaging/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-imaging/.mtn2git_empty
diff --git a/packages/python/python-imaging/path.patch b/packages/python/python-imaging/path.patch
new file mode 100644
index 0000000000..1dc467a56d
--- /dev/null
+++ b/packages/python/python-imaging/path.patch
@@ -0,0 +1,37 @@
+Index: Imaging-1.1.5/setup.py
+===================================================================
+--- Imaging-1.1.5.orig/setup.py 2005-03-23 19:16:40.000000000 +0100
++++ Imaging-1.1.5/setup.py 2006-05-31 14:36:07.000000000 +0200
+@@ -28,12 +28,13 @@
+ #
+ # TIFF_ROOT = libinclude("/opt/tiff")
+
+-FREETYPE_ROOT = None
+-JPEG_ROOT = None
++FREETYPE_ROOT = os.environ['STAGING_LIBDIR'], os.environ['STAGING_INCDIR']
++JPEG_ROOT = os.environ['STAGING_LIBDIR']
+ TIFF_ROOT = None
+-ZLIB_ROOT = None
++ZLIB_ROOT = os.environ['STAGING_LIBDIR']
+ TCL_ROOT = None
+
++
+ # FIXME: add mechanism to explicitly *disable* the use of a library
+
+ # --------------------------------------------------------------------
+@@ -175,15 +176,6 @@
+ add_directory(include_dirs, include_root)
+
+ #
+- # add standard directories
+-
+- add_directory(library_dirs, "/usr/local/lib")
+- add_directory(include_dirs, "/usr/local/include")
+-
+- add_directory(library_dirs, "/usr/lib")
+- add_directory(include_dirs, "/usr/include")
+-
+- #
+ # insert new dirs *before* default libs, to avoid conflicts
+ # between Python PYD stub libs and real libraries
+
diff --git a/packages/python/python-imaging_1.1.5.bb b/packages/python/python-imaging_1.1.5.bb
new file mode 100644
index 0000000000..ddd3eef863
--- /dev/null
+++ b/packages/python/python-imaging_1.1.5.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Python Imaging Library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "freetype jpeg tiff"
+SRCNAME = "Imaging"
+
+SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
+file://path.patch;patch=1"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_compile() {
+
+ export STAGING_LIBDIR=${STAGING_LIBDIR}
+ export STAGING_INCDIR=${STAGING_INCDIR}
+ distutils_do_compile
+}
+
+do_install() {
+
+ export STAGING_LIBDIR=${STAGING_LIBDIR}
+ export STAGING_INCDIR=${STAGING_INCDIR}
+
+ distutils_do_install
+
+ install -d ${D}${datadir}/doc/${PN}/html/
+ install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/
+ install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/
+
+}