aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qpdf2
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-03-20 18:26:16 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-20 18:26:16 +0000
commit234c92fa56963ab907b9667d2cc28b6e0ade6791 (patch)
tree570c04222ee2366502eb90dbca5f3c44f6ea9a4e /packages/qpdf2
parent97964b6f55be174b13ce082a37da7a786d75d02f (diff)
downloadopenembedded-234c92fa56963ab907b9667d2cc28b6e0ade6791.tar.gz
qpdf 2.2.1: add patch to make it compile w/ gcc4
Diffstat (limited to 'packages/qpdf2')
-rw-r--r--packages/qpdf2/files/gcc4.patch31
-rw-r--r--packages/qpdf2/qpdf2_2.2.1.bb8
2 files changed, 35 insertions, 4 deletions
diff --git a/packages/qpdf2/files/gcc4.patch b/packages/qpdf2/files/gcc4.patch
new file mode 100644
index 0000000000..5e90302bd6
--- /dev/null
+++ b/packages/qpdf2/files/gcc4.patch
@@ -0,0 +1,31 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- qpdf2_2.2.1/qdocnotes.h~gcc4 2004-02-17 18:13:18.000000000 +0100
++++ qpdf2_2.2.1/qdocnotes.h 2006-03-20 19:16:38.000000000 +0100
+@@ -1,6 +1,6 @@
+ #include "xmlparser.h"
+ #include <qmap.h>
+-
++class QDocNotes;
+ class QDocNote {
+ public:
+ friend class QDocNotes;
+--- qpdf2_2.2.1/xpdf/TextOutputDev.h~gcc4 2004-02-17 18:13:18.000000000 +0100
++++ qpdf2_2.2.1/xpdf/TextOutputDev.h 2006-03-20 19:19:47.000000000 +0100
+@@ -139,6 +139,13 @@
+ //------------------------------------------------------------------------
+ // TextPool
+ //------------------------------------------------------------------------
++class TextPool;
++class TextLine;
++class TextBlock;
++class TextFlow;
++class TextWordList;
++class TextPage;
++class TextLineFrag;
+
+ class TextPool {
+ public:
diff --git a/packages/qpdf2/qpdf2_2.2.1.bb b/packages/qpdf2/qpdf2_2.2.1.bb
index 6f853339e6..6e31f40bd6 100644
--- a/packages/qpdf2/qpdf2_2.2.1.bb
+++ b/packages/qpdf2/qpdf2_2.2.1.bb
@@ -1,19 +1,19 @@
DESCRIPTION = "QPDF2 is a Viewer for PDF documents. An unnecessary fork based on opie-qpdf."
PRIORITY = "optional"
SECTION = "opie/applications"
+HOMEPAGE = "http://qpdf2.sf.net"
LICENSE = "GPL"
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-NOTE = "This is so hacky you won't believe it until you look at the source..."
DEPENDS = "t1lib freetype"
APPNAME = "qpdf"
APPTYPE = "binary"
APPDESKTOP = "${S}/ipkg-render-freetype/opt/QtPalmtop/apps/Applications"
-PR = "r2"
+PR = "r3"
SRC_URI = "${SOURCEFORGE_MIRROR}/qpdf2/qpdf2_2.2.1_20040217b.tgz \
file://hack-the-hack.patch;patch=1 \
file://fix-sigsegv.patch;patch=1 \
- file://fix_qtversion_check.patch;patch=1"
+ file://fix_qtversion_check.patch;patch=1 \
+ file://gcc4.patch;patch=1"
S = "${WORKDIR}/qpdf2_${PV}"
inherit opie