aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qpe-gaim
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-03-29 23:41:28 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-03-29 23:41:28 +0000
commitaa826608ebaa8dfba42855ac2f1639c633d4eb21 (patch)
tree9a99bcff731d33fd652987f18b7e918a2d9a2540 /packages/qpe-gaim
parentd1bea3bfd2b52c12d163da5af221bb379da539d6 (diff)
downloadopenembedded-aa826608ebaa8dfba42855ac2f1639c633d4eb21.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/03/30 01:37:10+02:00 handhelds.org!zecke Opie Obex: -Fix beaming because receivers can't cope with path names 2005/03/30 01:11:09+02:00 handhelds.org!zecke Base File: Symlink /proc/mounts to /etc/mtab regardless of having tmpfs, ramnfs in the fstab. Most of our handhelds do build a busybox without mtab creation so we need that /proc/mounts. I hope that doesn't break for the nslu folks and others 2005/03/30 01:04:31+02:00 handhelds.org!zecke QPE Gaim: -Rename the gaim-1.1.4 forward port to the old name -Remove the old versions -Renamed the patches BKrev: 4249e7a8ecBI-EI1fC6yVB1s15Sw4g
Diffstat (limited to 'packages/qpe-gaim')
-rw-r--r--packages/qpe-gaim/files/qpe-gaim.patch (renamed from packages/qpe-gaim/files/qpe-gaim-1.1.4.patch)0
-rw-r--r--packages/qpe-gaim/files/vit.patch327
-rw-r--r--packages/qpe-gaim/qpe-gaim1_1.1.4.bb0
-rw-r--r--packages/qpe-gaim/qpe-gaim_20041030.bb5
-rw-r--r--packages/qpe-gaim/qpe-libgaim1_1.1.4.bb53
-rw-r--r--packages/qpe-gaim/qpe-libgaim_1.1.4.bb (renamed from packages/qpe-gaim/files/vit-1.1.4.patch)0
-rw-r--r--packages/qpe-gaim/qpe-libgaim_20041030.bb46
7 files changed, 329 insertions, 102 deletions
diff --git a/packages/qpe-gaim/files/qpe-gaim-1.1.4.patch b/packages/qpe-gaim/files/qpe-gaim.patch
index e69de29bb2..e69de29bb2 100644
--- a/packages/qpe-gaim/files/qpe-gaim-1.1.4.patch
+++ b/packages/qpe-gaim/files/qpe-gaim.patch
diff --git a/packages/qpe-gaim/files/vit.patch b/packages/qpe-gaim/files/vit.patch
index e69de29bb2..fa480507d9 100644
--- a/packages/qpe-gaim/files/vit.patch
+++ b/packages/qpe-gaim/files/vit.patch
@@ -0,0 +1,327 @@
+Index: qpe-gaim/src/QGaimAccountsWindow.cpp
+===================================================================
+--- qpe-gaim.orig/src/QGaimAccountsWindow.cpp 2005-03-06 21:16:47.098868556 +0100
++++ qpe-gaim/src/QGaimAccountsWindow.cpp 2005-03-06 21:16:47.353832369 +0100
+@@ -40,6 +40,7 @@
+ #include <qtimer.h>
+ #include <qtoolbar.h>
+ #include <qtoolbutton.h>
++#include <qmessagebox.h>
+
+ /**************************************************************************
+ * QGaimAccountListItem
+@@ -525,7 +526,7 @@
+ if (meter == NULL)
+ meter = meters->addConnection(gc);
+
+- meter->update(QString(text), step, step_count);
++ meter->update(QString::fromUtf8(text), step, step_count);
+ }
+
+ static void
+@@ -553,11 +554,19 @@
+ }
+
+ static void
++qGaimReportDisconnected(GaimConnection *gc, const char *text)
++{
++// if (QMessageBox::critical (NULL, "Disconnected", QString("<p>")+text+QString("</p>"), "Retry", "Cancel") == 0)
++ QMessageBox::critical (NULL, "Disconnected", QString("<p>")+text+QString("</p>"));
++}
++
++static void
+ qGaimConnNotice(GaimConnection *gc, const char *text)
+ {
+ /* XXX */
+ gc = NULL;
+ text = NULL;
++// QMessageBox::information (NULL, "Notice", QString::fromUtf8(text));
+ }
+
+ static GaimConnectionUiOps connUiOps =
+@@ -566,7 +575,7 @@
+ qGaimConnConnected,
+ qGaimConnDisconnected,
+ qGaimConnNotice,
+- NULL
++ qGaimReportDisconnected
+ };
+
+ GaimConnectionUiOps *
+Index: qpe-gaim/src/QGaimBListWindow.cpp
+===================================================================
+--- qpe-gaim.orig/src/QGaimBListWindow.cpp 2005-03-06 21:16:47.099868414 +0100
++++ qpe-gaim/src/QGaimBListWindow.cpp 2005-03-06 21:16:47.354832227 +0100
+@@ -428,7 +428,7 @@
+ dialog = new QGaimAddBuddyDialog(this, "", true);
+
+ if (group != NULL)
+- dialog->setGroup(group->name);
++ dialog->setGroup(QString::fromUtf8(group->name));
+
+ dialog->showMaximized();
+ }
+@@ -469,7 +469,7 @@
+ dialog = new QGaimAddChatDialog(this, "", true);
+
+ if (group != NULL)
+- dialog->setGroup(group->name);
++ dialog->setGroup(QString::fromUtf8(group->name));
+
+ dialog->showMaximized();
+ }
+Index: qpe-gaim/src/QGaimBuddyList.cpp
+===================================================================
+--- qpe-gaim.orig/src/QGaimBuddyList.cpp 2005-03-06 21:16:47.101868130 +0100
++++ qpe-gaim/src/QGaimBuddyList.cpp 2005-03-06 21:18:39.073975291 +0100
+@@ -131,7 +131,7 @@
+ setText(1, text);
+ }
+
+- setText(0, gaim_buddy_get_alias(buddy));
++ setText(0, QString::fromUtf8(gaim_buddy_get_alias(buddy)));
+ }
+ else if (GAIM_BLIST_NODE_IS_BUDDY(node))
+ {
+@@ -164,8 +164,8 @@
+ text += idle;
+ }
+
+- setPixmap(0, QGaimBuddyList::getBuddyStatusIcon(node, pixmapSize));
+- setText(0, gaim_buddy_get_alias(buddy));
++ setPixmap(0, QGaimBuddyList::getBuddyStatusIcon(node, pixmapSize));
++ setText(0, QString::fromUtf8(gaim_buddy_get_alias(buddy)));
+ setText(1, text);
+ }
+ else if (GAIM_BLIST_NODE_IS_CHAT(node))
+@@ -325,9 +325,9 @@
+ statusText = QObject::tr("Offline ");
+
+ if (contact != NULL && !isExpanded() && contact->alias != NULL)
+- topText = contact->alias;
++ topText = QString::fromUtf8(contact->alias);
+ else
+- topText = gaim_buddy_get_alias(buddy);
++ topText = QString::fromUtf8(gaim_buddy_get_alias(buddy));
+
+ bottomText = statusText + idleTime + warning;
+
+@@ -401,7 +401,7 @@
+ QString groupName, detail;
+ QFont f = p->font();
+
+- groupName = group->name;
++ groupName = QString::fromUtf8(group->name);
+
+ if (gaim_prefs_get_bool("/gaim/qpe/blist/show_group_count"))
+ {
+Index: qpe-gaim/src/QGaimConnectionMeter.cpp
+===================================================================
+--- qpe-gaim.orig/src/QGaimConnectionMeter.cpp 2005-03-06 21:16:47.101868130 +0100
++++ qpe-gaim/src/QGaimConnectionMeter.cpp 2005-03-06 21:16:47.355832086 +0100
+@@ -74,14 +74,12 @@
+ }
+
+ void
+-QGaimConnectionMeter::update(QString, int progress, int totalSteps)
++QGaimConnectionMeter::update(QString str, int progress, int totalSteps)
+ {
+ if (progress == 0)
+ progressBar->setTotalSteps(totalSteps);
+
+ progressBar->setProgress(progress);
+-
+-// progressBar->setIndicator(str, progress, totalSteps);
+ }
+
+ GaimConnection *
+Index: qpe-gaim/src/QGaimConvWindow.cpp
+===================================================================
+--- qpe-gaim.orig/src/QGaimConvWindow.cpp 2005-03-06 21:16:47.103867846 +0100
++++ qpe-gaim/src/QGaimConvWindow.cpp 2005-03-06 21:16:47.357831802 +0100
+@@ -93,7 +93,7 @@
+ if (flags & GAIM_MESSAGE_SYSTEM)
+ {
+ txt = "<b>";
+- txt += message;
++ txt += QString::fromUtf8(message);
+ txt += "</b><br>\n";
+ }
+ else
+@@ -109,13 +109,13 @@
+ if (meify(newMessage, length))
+ {
+ nick = "***";
+- nick += who;
++ nick += QString::fromUtf8(who);
+ color = "#6C2585";
+ }
+ else
+ {
+ nick = "*";
+- nick += who;
++ nick += QString::fromUtf8(who);
+ nick += "*:";
+ color = "#00FF00";
+ }
+@@ -129,7 +129,7 @@
+ else
+ nick = "***";
+
+- nick += who;
++ nick += QString::fromUtf8(who);
+
+ if (flags & GAIM_MESSAGE_NICK)
+ color = "#AF7F00";
+@@ -138,7 +138,7 @@
+ }
+ else
+ {
+- nick = who;
++ nick = QString::fromUtf8(who);
+
+ if (flags & GAIM_MESSAGE_AUTO_RESP)
+ nick += "&lt;AUTO-REPLY&gt; :";
+@@ -158,7 +158,7 @@
+ txt += nick;
+ txt += "</b></font> ";
+
+- txt += stripFontFace(newMessage);
++ txt += stripFontFace(QString::fromUtf8(newMessage));
+ txt += "<br>\n";
+
+ g_free(newMessage);
+@@ -353,7 +353,7 @@
+ else
+ item->setText(0, " ");
+
+- item->setText(1, user);
++ item->setText(1, QString::fromUtf8(user));
+ userList->insertItem(item);
+ }
+
+@@ -373,9 +373,9 @@
+ item != NULL;
+ item = item->nextSibling())
+ {
+- if (item->text(1) == oldName)
++ if (item->text(1) == QString::fromUtf8(oldName))
+ {
+- item->setText(1, newName);
++ item->setText(1, QString::fromUtf8(newName));
+ break;
+ }
+ }
+@@ -390,7 +390,7 @@
+ item != NULL;
+ item = item->nextSibling())
+ {
+- if (item->text(1) == user)
++ if (item->text(1) == QString::fromUtf8(user))
+ {
+ delete item;
+ break;
+@@ -473,7 +473,7 @@
+ if (text[text.length() - 1] == '\n')
+ text.remove(text.length() - 1, 1);
+
+- gaim_conv_chat_send(GAIM_CONV_CHAT(conv), text);
++ gaim_conv_chat_send(GAIM_CONV_CHAT(conv), text.utf8());
+
+ entry->setText("");
+ }
+@@ -650,7 +650,7 @@
+ if (text[text.length() - 1] == '\n')
+ text.remove(text.length() - 1, 1);
+
+- gaim_conv_im_send(GAIM_CONV_IM(conv), text);
++ gaim_conv_im_send(GAIM_CONV_IM(conv), text.utf8());
+
+ entry->setText("");
+
+@@ -995,7 +995,7 @@
+ int result = QMessageBox::information(this,
+ tr("Remove Buddy"),
+ tr("<p>You are about to remove %1 from your buddy list.</p>\n"
+- "<p>Do you want to continue?</p>").arg(name),
++ "<p>Do you want to continue?</p>").arg(QString::fromUtf8(name)),
+ tr("&Remove Buddy"), tr("&Cancel"),
+ QString::null, 1, 1);
+
+Index: qpe-gaim/src/QGaimDialogs.cpp
+===================================================================
+--- qpe-gaim.orig/src/QGaimDialogs.cpp 2005-03-06 21:16:47.105867562 +0100
++++ qpe-gaim/src/QGaimDialogs.cpp 2005-03-06 21:16:47.358831660 +0100
+@@ -141,7 +141,7 @@
+ {
+ GaimGroup *g = (GaimGroup *)node;
+
+- groupCombo->insertItem(g->name);
++ groupCombo->insertItem(QString::fromUtf8(g->name));
+ }
+ }
+ }
+@@ -151,9 +151,9 @@
+ QGaimAddBuddyDialog::accept()
+ {
+ GaimConversation *conv;
+- QString screenname = screenNameEntry->text();
+- QString alias = aliasEntry->text();
+- QString group_name = groupCombo->currentText();
++ QString screenname = screenNameEntry->text().utf8();
++ QString alias = aliasEntry->text().utf8();
++ QString group_name = groupCombo->currentText().utf8();
+ GaimAccount *account;
+ GaimBuddy *buddy;
+ GaimGroup *group;
+@@ -290,7 +290,7 @@
+ {
+ GaimGroup *g = (GaimGroup *)node;
+
+- groupCombo->insertItem(g->name);
++ groupCombo->insertItem(QString::fromUtf8(g->name));
+ }
+ }
+ }
+@@ -371,8 +371,8 @@
+ GaimGroup *group;
+ GList *chatInfoList, *l;
+ GHashTable *components;
+- QString alias = aliasEntry->text();
+- QString groupName = groupCombo->currentText();
++ QString alias = aliasEntry->text().utf8();
++ QString groupName = groupCombo->currentText().utf8();
+ QWidget *widget;
+ struct proto_chat_entry *pce;
+
+@@ -495,7 +495,7 @@
+ void
+ QGaimNewImDialog::accept()
+ {
+- QString screenname = screenNameEntry->text();
++ QString screenname = screenNameEntry->text().utf8();
+ GaimAccount *account;
+ GaimConversation *conv;
+
+Index: qpe-gaim/src/QGaimRequest.cpp
+===================================================================
+--- qpe-gaim.orig/src/QGaimRequest.cpp 2005-03-06 21:16:47.109866995 +0100
++++ qpe-gaim/src/QGaimRequest.cpp 2005-03-06 21:16:47.358831660 +0100
+@@ -68,7 +68,7 @@
+ dialog->setInfoText(message);
+
+ if (defaultValue != NULL)
+- dialog->setDefaultValue(defaultValue);
++ dialog->setDefaultValue(QString::fromUtf8(defaultValue));
+
+ if (masked)
+ dialog->setMasked();
+@@ -85,7 +85,7 @@
+ if (result == 1)
+ {
+ if (okCb != NULL)
+- ((GaimRequestInputCb)okCb)(userData, dialog->getText());
++ ((GaimRequestInputCb)okCb)(userData, dialog->getText().utf8());
+ }
+ else if (cancelCb != NULL)
+ ((GaimRequestInputCb)cancelCb)(userData, NULL);
diff --git a/packages/qpe-gaim/qpe-gaim1_1.1.4.bb b/packages/qpe-gaim/qpe-gaim1_1.1.4.bb
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/qpe-gaim/qpe-gaim1_1.1.4.bb
+++ /dev/null
diff --git a/packages/qpe-gaim/qpe-gaim_20041030.bb b/packages/qpe-gaim/qpe-gaim_20041030.bb
index a5298edae6..9193afaa3e 100644
--- a/packages/qpe-gaim/qpe-gaim_20041030.bb
+++ b/packages/qpe-gaim/qpe-gaim_20041030.bb
@@ -9,11 +9,10 @@ APPNAME = "gaim"
APPTYPE = "binary"
LICENSE = "GPL"
APPDESKTOP = "${S}"
-PV = "0.4+cvs-20041030"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.vanille.de/mirror/qpe-gaim_20041030.tar.bz2 \
- file://libopie2.patch;patch=1 \
+ file://qpe-gaim.patch;patch=1 \
file://vit.patch;patch=1"
S = "${WORKDIR}/qpe-gaim"
diff --git a/packages/qpe-gaim/qpe-libgaim1_1.1.4.bb b/packages/qpe-gaim/qpe-libgaim1_1.1.4.bb
deleted file mode 100644
index 824dee5c39..0000000000
--- a/packages/qpe-gaim/qpe-libgaim1_1.1.4.bb
+++ /dev/null
@@ -1,53 +0,0 @@
-DESCRIPTION = "A multi protocol instant messager library, Qt/Embedded based Palmtop Environments Edition"
-SECTION = "opie/applications"
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-DEPENDS = "glib-2.0 gnutls"
-RDEPENDS = "libgaim-plugins"
-LICENSE = "GPL"
-HOMEPAGE = "http://gaim.sourceforge.net/"
-PR = "r3"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/gaim/gaim-${PV}.tar.bz2 \
- file://dont-look-for-gtk.patch;patch=1 \
- file://libgaim.patch;patch=1 "
-
-S = "${WORKDIR}/gaim-${PV}"
-
-inherit autotools
-
-EXTRA_OE_CONF = "--disable-audio --disable-gtkspell --disable-perl \
- --disable-screensaver --disable-sm --disable-glibtest \
- --disable-gtktest --disable-startup-notification \
- --disable-gevolution --disable-aotest --disable-audiofiletest \
- --disable-x --without-x --without-gtk --disable-gtk \
- --enable-gnutls=y"
-
-CFLAGS_append = " -I${STAGING_INCDIR}/glib-2.0"
-
-do_stage() {
- oe_libinstall -so -C src libgaim ${QTDIR}/lib
-
- # install headers
- GAIM_DIR=${STAGING_INCDIR}/gaim
- install -d $GAIM_DIR
-
- for header in account.h accountopt.h away.h blist.h buddyicon.h cmds.h config.h connection.h conversation.h core.h debug.h eventloop.h ft.h gaim.h imgstore.h log.h md5.h network.h notify.h plugin.h pluginpref.h pounce.h prefix.h prefs.h privacy.h proxy.h prpl.h request.h roomlist.h server.h sha.h signals.h sound.h sslconn.h status.h stringref.h util.h value.h version.h xmlnode.h
- do
- if [ -e ${S}/src/$header ]; then
- install -m 0644 ${S}/src/$header $GAIM_DIR
- fi
- if [ -e ${S}/$header ]; then
- install -m 0644 ${S}/$header $GAIM_DIR
- fi
- done
-}
-
-#FIXME: use do_packages to create individual packages for each of the plugins
-python populate_packages_prepend () {
- plugindir = bb.data.expand('${libdir}/gaim', d)
- do_split_packages(d, plugindir, '^lib(.*)\.so$', 'libgaim-protocol-%s', 'GAIM plugin for %s protocol', extra_depends='' )
-}
-
-PACKAGES += "libgaim-plugins"
-FILES_libgaim-plugins = "${libdir}/gaim/autorecon.so ${libdir}/gaim/s*.so"
-
diff --git a/packages/qpe-gaim/files/vit-1.1.4.patch b/packages/qpe-gaim/qpe-libgaim_1.1.4.bb
index e69de29bb2..e69de29bb2 100644
--- a/packages/qpe-gaim/files/vit-1.1.4.patch
+++ b/packages/qpe-gaim/qpe-libgaim_1.1.4.bb
diff --git a/packages/qpe-gaim/qpe-libgaim_20041030.bb b/packages/qpe-gaim/qpe-libgaim_20041030.bb
deleted file mode 100644
index c9a168fb79..0000000000
--- a/packages/qpe-gaim/qpe-libgaim_20041030.bb
+++ /dev/null
@@ -1,46 +0,0 @@
-DESCRIPTION = "A multi protocol instant messager library, Qt/Embedded based Palmtop Environments Edition"
-SECTION = "opie/applications"
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-DEPENDS = "openssl glib-2.0"
-RDEPENDS = "libgaim-plugins"
-LICENSE = "GPL"
-HOMEPAGE = "http://qpe-gaim.sourceforge.net/"
-PV = "0.4+cvs-20041030"
-PR = "r3"
-
-SRC_URI = "http://www.vanille.de/mirror/qpe-gaim_20041030.tar.bz2 \
- file://fix-compilation.patch;patch=1 \
- file://dont-look-for-gtk.patch;patch=1"
-S = "${WORKDIR}/libgaim"
-
-inherit autotools
-
-EXTRA_OE_CONF = "--disable-audio --disable-gtkspell --disable-perl \
- --with-dynamic-prpls=gg,irc,jabber,msn,napster,oscar,yahoo \
- --disable-screensaver --disable-sm --disable-glibtest \
- --disable-gtktest --disable-startup-notification \
- --disable-gevolution --disable-aotest --disable-audiofiletest"
-
-CFLAGS_append = " -I${STAGING_INCDIR}/glib-2.0"
-
-do_configure_prepend() {
- ln -s src libgaim
- touch intl/Makefile.in
- touch po/Makefile.in.in
- install -d build-root
- touch build-root/mkipk.sh.in.in
-}
-
-do_stage() {
- oe_libinstall -so -C src libgaim ${QTDIR}/lib
-}
-
-#FIXME: use do_packages to create individual packages for each of the plugins
-python populate_packages_prepend () {
- plugindir = bb.data.expand('${libdir}/gaim', d)
- do_split_packages(d, plugindir, '^lib(.*)\.so$', 'libgaim-protocol-%s', 'GAIM plugin for %s protocol', extra_depends='' )
-}
-
-PACKAGES += "libgaim-plugins"
-FILES_libgaim-plugins = "${libdir}/gaim/autorecon.so ${libdir}/gaim/s*.so"
-