aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qpobox
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-07-14 14:09:27 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-14 14:09:27 +0000
commitcc127cca7bb25d1858e98ccd891b75c6613d1a9a (patch)
treed2b882b9ac2725ec467b6889abb1e15838230b7c /packages/qpobox
parent90ec691068e8b36791f1590f4fa0da382f81094e (diff)
downloadopenembedded-cc127cca7bb25d1858e98ccd891b75c6613d1a9a.tar.gz
qpobox: update Tota's code patches, but keep my .bb changes intact. closes #1114
Diffstat (limited to 'packages/qpobox')
-rw-r--r--packages/qpobox/files/qpobox-0.5.4-opie.patch (renamed from packages/qpobox/files/ashikase.patch)0
-rw-r--r--packages/qpobox/files/qpobox.patch57
-rw-r--r--packages/qpobox/qpobox_0.5.4.bb11
3 files changed, 66 insertions, 2 deletions
diff --git a/packages/qpobox/files/ashikase.patch b/packages/qpobox/files/qpobox-0.5.4-opie.patch
index 91b9db712a..91b9db712a 100644
--- a/packages/qpobox/files/ashikase.patch
+++ b/packages/qpobox/files/qpobox-0.5.4-opie.patch
diff --git a/packages/qpobox/files/qpobox.patch b/packages/qpobox/files/qpobox.patch
new file mode 100644
index 0000000000..eb2549ecb6
--- /dev/null
+++ b/packages/qpobox/files/qpobox.patch
@@ -0,0 +1,57 @@
+diff -Naur qpobox.orig/pbclient.cpp qpobox/pbclient.cpp
+--- qpobox.orig/pbclient.cpp 2003-06-21 04:56:31.000000000 +0200
++++ qpobox/pbclient.cpp 2006-05-11 22:49:00.000000000 +0200
+@@ -28,7 +28,8 @@
+ m_address(address), m_port(port)
+ {
+ m_sock = new QSocket(this);
+- m_conv = QTextCodec::codecForName("EUC-JP");
++ //m_conv = QTextCodec::codecForName("EUC-JP");
++ m_conv = QTextCodec::codecForName("eucJP");
+
+ connect(m_sock, SIGNAL(readyRead()), this, SLOT(socketReadyRead()));
+ connect(m_sock, SIGNAL(error(int)), this, SLOT(socketError(int)));
+diff -Naur qpobox.orig/qpobox.key qpobox/qpobox.key
+--- qpobox.orig/qpobox.key 2003-08-12 22:23:15.000000000 +0200
++++ qpobox/qpobox.key 2006-05-12 23:27:19.000000000 +0200
+@@ -1,15 +1,15 @@
+ [INIT]
+ Shift+Space = THRU
+ Space = NEXT
+- Shift+Return = THRU_MODE
++ Shift+Enter = THRU_MODE
+ F21 = CLOSE
+ F25 = IM_MODE
+
+ [INPUT]
+ Shift+Space = PREV
+ Space = NEXT
+- Shift+Return = FIX
+- Return = EXACT
++ Shift+Enter = FIX
++ Enter = EXACT
+ BackSpace = BS
+ Delete = DELETE
+ Left = SHRINK
+@@ -22,7 +22,7 @@
+ [SELECT]
+ Shift+Space = PREV
+ Space = NEXT
+- Return = FIX
++ Enter = FIX
+ BackSpace = BS
+ Delete = NOP
+ Left = PREV
+diff -Naur qpobox.orig/qpoboxconfig.cpp qpobox/qpoboxconfig.cpp
+--- qpobox.orig/qpoboxconfig.cpp 2005-01-09 06:53:44.000000000 +0100
++++ qpobox/qpoboxconfig.cpp 2006-05-11 22:38:22.000000000 +0200
+@@ -224,7 +224,8 @@
+ if (t != m_key_loaded) {
+ if (f.open(IO_ReadOnly)) {
+ QTextStream ts(&f);
+- QTextCodec *codec=QTextCodec::codecForName("UTF-8");
++ //QTextCodec *codec=QTextCodec::codecForName("UTF-8");
++ QTextCodec *codec=QTextCodec::codecForName("eucJP");
+ ts.setCodec(codec);
+ poboxmode_t mode = MODE_INIT;
+
diff --git a/packages/qpobox/qpobox_0.5.4.bb b/packages/qpobox/qpobox_0.5.4.bb
index c2ed6938b7..002522afa3 100644
--- a/packages/qpobox/qpobox_0.5.4.bb
+++ b/packages/qpobox/qpobox_0.5.4.bb
@@ -1,11 +1,18 @@
DESCRIPTION = "A japanese inputmethod for Qt/Embedded based palmtop environments."
SECTION = "opie/inputmethods"
-RDEPENDS = "poboxserver"
+RDEPENDS = "poboxserver virtual/japanese-font"
LICENSE = "GPL"
+HOMEPAGE = "http://takahr.dhis.portside.net/cgi-bin/rwiki.cgi?cmd=view;name=QPOBox"
+PR = "r0"
SRC_URI = "http://www.vanille.de/mirror/qpobox-${PV}.tar.gz \
- file://ashikase.patch;patch=1"
+ file://qpobox-0.5.4-opie.patch;patch=1 \
+ file://qpobox.patch;patch=1"
S = "${WORKDIR}/qpobox"
inherit opie
+do_install() {
+ install -d ${D}${palmtopdir}/share
+ install -m 644 qpobox.key ${D}${palmtopdir}/share
+}