aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qt4
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2008-01-20 22:49:28 +0000
committerHolger Freyther <zecke@selfish.org>2008-01-20 22:49:28 +0000
commit620b4535290d9d45724d00eaca5dde4ed4fdc2e1 (patch)
treee2dd14f09897edc7686066b181fe3de86946a27a /packages/qt4
parent37f1ff2ab29c485abab10005d25b363373a23dc9 (diff)
downloadopenembedded-620b4535290d9d45724d00eaca5dde4ed4fdc2e1.tar.gz
packages/qt4/qtopia-core: Build the features that are available as plugin as plugin
-Build whatever can be build as plugin as plugin (graphics driver, mouse...) -Change the configure script to find plugins -Packaging needs to be done
Diffstat (limited to 'packages/qt4')
-rw-r--r--packages/qt4/qtopia-core-4.3.3/allow-configure-plugins.patch62
-rw-r--r--packages/qt4/qtopia-core.inc10
-rw-r--r--packages/qt4/qtopia-core_4.3.3.bb3
3 files changed, 73 insertions, 2 deletions
diff --git a/packages/qt4/qtopia-core-4.3.3/allow-configure-plugins.patch b/packages/qt4/qtopia-core-4.3.3/allow-configure-plugins.patch
new file mode 100644
index 0000000000..601f2fc369
--- /dev/null
+++ b/packages/qt4/qtopia-core-4.3.3/allow-configure-plugins.patch
@@ -0,0 +1,62 @@
+Index: qtopia-core-opensource-src-4.3.3/configure
+===================================================================
+--- qtopia-core-opensource-src-4.3.3.orig/configure 2008-01-20 11:42:07.000000000 +0100
++++ qtopia-core-opensource-src-4.3.3/configure 2008-01-20 22:31:37.000000000 +0100
+@@ -639,10 +639,10 @@
+
+ CFG_SQL_AVAILABLE=
+ if [ -d "$relpath/src/plugins/sqldrivers" ]; then
+- for a in "$relpath/src/plugins/sqldrivers/"*; do
+- if [ -d "$a" ]; then
+- base_a=`basename $a`
+- CFG_SQL_AVAILABLE="${CFG_SQL_AVAILABLE} ${base_a}"
++ for a in `ls $relpath/src/plugins/sqldrivers/`; do
++ dir="$relpath/src/plugins/sqldrivers/$a"
++ if [ -d "$dir" ]; then
++ CFG_SQL_AVAILABLE="${CFG_SQL_AVAILABLE} ${a}"
+ eval "CFG_SQL_${base_a}=auto"
+ fi
+ done
+@@ -650,30 +650,30 @@
+
+ CFG_DECORATION_PLUGIN_AVAILABLE=
+ if [ -d "$relpath/src/plugins/decorations" ]; then
+- for a in "$relpath/src/plugins/decorations/"*; do
+- if [ -d "$a" ]; then
+- base_a=`basename $a`
+- CFG_DECORATION_PLUGIN_AVAILABLE="${CFG_DECORATION_PLUGIN_AVAILABLE} ${base_a}"
++ for a in `ls $relpath/src/plugins/decorations/`; do
++ dir="$relpath/src/plugins/decorations/$a"
++ if [ -d "$dir" ]; then
++ CFG_DECORATION_PLUGIN_AVAILABLE="${CFG_DECORATION_PLUGIN_AVAILABLE} ${a}"
+ fi
+ done
+ fi
+
+ CFG_MOUSE_PLUGIN_AVAILABLE=
+ if [ -d "$relpath/src/plugins/mousedrivers" ]; then
+- for a in "$relpath/src/plugins/mousedrivers/"*; do
+- if [ -d "$a" ]; then
+- base_a=`basename $a`
+- CFG_MOUSE_PLUGIN_AVAILABLE="${CFG_MOUSE_PLUGIN_AVAILABLE} ${base_a}"
++ for a in `ls $relpath/src/plugins/mousedrivers/`; do
++ dir="$relpath/src/plugins/mousedrivers/$a"
++ if [ -d "$dir" ]; then
++ CFG_MOUSE_PLUGIN_AVAILABLE="${CFG_MOUSE_PLUGIN_AVAILABLE} ${a}"
+ fi
+ done
+ fi
+
+ CFG_GFX_PLUGIN_AVAILABLE=
+ if [ -d "$relpath/src/plugins/gfxdrivers" ]; then
+- for a in "$relpath/src/plugins/gfxdrivers/"*; do
+- if [ -d "$a" ]; then
+- base_a=`basename $a`
+- CFG_GFX_PLUGIN_AVAILABLE="${CFG_GFX_PLUGIN_AVAILABLE} ${base_a}"
++ for a in `ls $relpath/src/plugins/gfxdrivers/`; do
++ dir="$relpath/src/plugins/gfxdrivers/$a"
++ if [ -d "$dir" ]; then
++ CFG_GFX_PLUGIN_AVAILABLE="${CFG_GFX_PLUGIN_AVAILABLE} ${a}"
+ fi
+ done
+ CFG_GFX_OFF="$CFG_GFX_AVAILABLE" # assume all off
diff --git a/packages/qt4/qtopia-core.inc b/packages/qt4/qtopia-core.inc
index 05727b7c90..16f67ac629 100644
--- a/packages/qt4/qtopia-core.inc
+++ b/packages/qt4/qtopia-core.inc
@@ -17,7 +17,15 @@ S = "${WORKDIR}/qtopia-core-opensource-src-${PV}"
QT_CONFIG_FLAGS += " \
-nomake demos -nomake examples -nomake tools -qtlibinfix E\
- -qt-mouse-tslib -qt-gfx-transformed -embedded ${QT_ARCH}"
+ -embedded ${QT_ARCH} \
+ -qt-decoration-styled -plugin-decoration-default -plugin-decoration-windows \
+ -plugin-gfx-transformed -plugin-gfx-qvfb -plugin-gfx-vnc\
+ -plugin-mouse-tslib -qt-mouse-pc -qt-mouse-qvfb\
+ -qt-kbd-tty -qt-kbd-usb -qt-kbd-qvfb\
+ ${QT_QCONFIG} \
+ "
+
+QT_QCONFIG = ""
QT_BASE_NAME = "qtopiacore"
QT_BASE_LIB = "libqtopiacore"
QT_DIR_NAME = "qtopia"
diff --git a/packages/qt4/qtopia-core_4.3.3.bb b/packages/qt4/qtopia-core_4.3.3.bb
index 9dad97f49a..40ec78ef04 100644
--- a/packages/qt4/qtopia-core_4.3.3.bb
+++ b/packages/qt4/qtopia-core_4.3.3.bb
@@ -2,4 +2,5 @@ require qtopia-core.inc
SRC_URI += " \
file://0006-freetype-host-includes.patch;patch=1 \
file://0007-openssl-host-includes.patch;patch=1 \
- file://0008-backport-qt-lib-infix.patch;patch=1"
+ file://0008-backport-qt-lib-infix.patch;patch=1 \
+ file://allow-configure-plugins.patch;patch=1 "