aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qt
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-04-11 12:25:44 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-11 12:25:44 +0000
commitd74366a6f1a7f8282c1ca5426e8f0940db0f3a40 (patch)
treec745169afb21f0870959addd780ef31a4fbefb9a /packages/qt
parent4dbac5bc4465261136bca6e3b9b2c35ddab50174 (diff)
downloadopenembedded-d74366a6f1a7f8282c1ca5426e8f0940db0f3a40.tar.gz
qt4: install native tools to where they are expected in qmake generated Makefiles
Diffstat (limited to 'packages/qt')
-rw-r--r--packages/qt/qt4-x11-free_4.1.1.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/packages/qt/qt4-x11-free_4.1.1.bb b/packages/qt/qt4-x11-free_4.1.1.bb
index 15a87bdf94..6c32026f38 100644
--- a/packages/qt/qt4-x11-free_4.1.1.bb
+++ b/packages/qt/qt4-x11-free_4.1.1.bb
@@ -6,7 +6,7 @@ LICENSE = "GPL QPL"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
DEPENDS = "uicmoc4-native qmake2-native freetype jpeg libx11 xft libxext libxrender libxrandr libxcursor"
PROVIDES = "qt4x11"
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-opensource-src-${PV}.tar.gz \
file://cross-compile.patch;patch=1 \
@@ -69,6 +69,10 @@ PARTS = "3Support Core Designer DesignerComponents Gui Network Sql Svg Test Xml"
do_stage() {
oe_runmake install INSTALL_ROOT=/
+ install -m 0755 ${STAGING_BINDIR}/rcc4 ${STAGING_QT_DIR}/bin/rcc
+ install -m 0755 ${STAGING_BINDIR}/moc4 ${STAGING_QT_DIR}/bin/moc
+ install -m 0755 ${STAGING_BINDIR}/uic4 ${STAGING_QT_DIR}/bin/uic
+
}
# FIXME: Might want to call oe_runmake install INSTALL_ROOT=${D}/${prefix} as well...