aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qte-fonts-common
diff options
context:
space:
mode:
authorHolger Schurig <schurig@mn-solutions.de>2005-04-05 07:39:56 +0000
committerHolger Schurig <schurig@mn-solutions.de>2005-04-05 07:39:56 +0000
commit6dd7535cbfcf31c5e1abb7a8354587037b52cfe1 (patch)
tree4f1f84d9851e987f98061dde7176824da77774dc /packages/qte-fonts-common
parent4bd4501a8a5a3b2001593ec14d6dbd4db20a603c (diff)
downloadopenembedded-6dd7535cbfcf31c5e1abb7a8354587037b52cfe1.tar.gz
update-qtfontdir: added -f switch and other goodies
qte-fonts-common: added postrm scripts BKrev: 425240ccRw4xfTtfGwW8Ok1ahLcxiQ
Diffstat (limited to 'packages/qte-fonts-common')
-rw-r--r--packages/qte-fonts-common/qte-fonts-common/update-qtfontdir78
-rw-r--r--packages/qte-fonts-common/qte-fonts-common_3.3.3.bb72
2 files changed, 112 insertions, 38 deletions
diff --git a/packages/qte-fonts-common/qte-fonts-common/update-qtfontdir b/packages/qte-fonts-common/qte-fonts-common/update-qtfontdir
index 788c0b307d..857dc6c0d5 100644
--- a/packages/qte-fonts-common/qte-fonts-common/update-qtfontdir
+++ b/packages/qte-fonts-common/qte-fonts-common/update-qtfontdir
@@ -2,69 +2,73 @@
usage()
{
- echo "usage: $0 [font directory, defaults to QTDIR/lib/fonts]"
- exit 1
+ echo "usage: $0 [font directory, defaults to \$QTDIR/lib/fonts]"
+ exit 1
}
setVar()
{
- eval "$1='$2'"
+ eval "$1='$2'"
}
getVar()
{
- eval "echo \$$1"
+ eval "echo \$$1"
}
handleQPF()
{
- base=`basename $1`
- family=`echo $base|cut -d_ -f1`
- pt=`echo $base|cut -d_ -f2`
- weight=`echo $base|cut -d_ -f3|sed -e 's,i$,,'`
- if (echo $base|cut -d_ -f3|grep -q 'i$'); then
- italic="y"
- else
- italic="n"
- fi
- echo "$family $base.qpf QPF $italic $weight $pt u"
+ base=`basename $1`
+ family=`echo $base|cut -d_ -f1`
+ pt=`echo $base|cut -d_ -f2`
+ weight=`echo $base|cut -d_ -f3|sed -e 's,i$,,'`
+ if (echo $base|cut -d_ -f3|grep -q 'i$'); then
+ italic="y"
+ else
+ italic="n"
+ fi
+ echo "$family $base.qpf QPF $italic $weight $pt u"
}
+if [ "$1" = "-f" ]; then
+ FORCE=1
+ shift
+else
+ FORCE=0
+fi
+
if [ -z "$1" ]; then
- if [ -n "$QTDIR" ]; then
- fontdir=$QTDIR/lib/fonts
- else
- fontdir=/opt/QtPalmtop/lib/fonts
- fi
+ if [ -n "$QTDIR" ]; then
+ fontdir=$QTDIR/lib/fonts
+ else
+ fontdir=/opt/QtPalmtop/lib/fonts
+ fi
else
- fontdir=$1
+ fontdir=$1
fi
-
+
if ! [ -d $fontdir ]; then
- echo Error: $fontdir not a directory
- exit 1
+ echo Error: $fontdir not a directory
+ exit 1
fi
if [ -e $fontdir/fontdir ]; then
- if find $fontdir -newer $fontdir/fontdir | grep "\(qpf\|ttf\)"; then
- echo "fontdir needs updating..."
- else
- echo "fontdir already up to date - exiting"
- exit 0
- fi
- cat $fontdir/fontdir | grep -v '\.qpf' > $fontdir/fontdir.new
-else
- echo "fontdir not existing. creating..."
+ if find $fontdir -newer $fontdir/fontdir | grep -q "\(qpf\|ttf\)"; then
+ #echo "fontdir needs updating..."
+ :
+ elif [ "$FORCE" = "0" ]; then
+ #echo "fontdir already up to date - exiting"
+ exit 0
+ fi
+ cat $fontdir/fontdir | grep -v '\.qpf' > $fontdir/fontdir.new
fi
(
- for file in `ls $fontdir/*.qpf|sed -e's,\.qpf$,,; s,_t[^_]*$,,;'|sort -u`; do
- handleQPF $file
- done
+ for file in `ls $fontdir/*.qpf 2>/dev/null |sed -e's,\.qpf$,,; s,_t[^_]*$,,;'|sort -u`; do
+ handleQPF $file
+ done
) >> $fontdir/fontdir.new
mv $fontdir/fontdir.new $fontdir/fontdir
exit 0
-
-# vim:ai:et:sts=4:sw=4:tw=0:
diff --git a/packages/qte-fonts-common/qte-fonts-common_3.3.3.bb b/packages/qte-fonts-common/qte-fonts-common_3.3.3.bb
index 803d6923be..d9138a002e 100644
--- a/packages/qte-fonts-common/qte-fonts-common_3.3.3.bb
+++ b/packages/qte-fonts-common/qte-fonts-common_3.3.3.bb
@@ -3,7 +3,7 @@ DESCRIPTION= "Tools to update the Qt fontdir"
MAINTAINER = "M&N Solutions <info@mn-solutions.de>"
LICENSE = "GPL/QPL"
PACKAGE_ARCH = "all"
-PR = "r2"
+PR = "r3"
SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-free-${PV}.tar.gz"
SRC_URI += "file://update-qtfontdir"
@@ -42,6 +42,13 @@ set -e
. /etc/profile
${sbindir}/update-qtfontdir
}
+pkg_postrm_qte-font-fixed() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+set -e
+. /etc/profile
+${sbindir}/update-qtfontdir -f
+}
PACKAGES += "qte-font-helvetica-small"
PROVIDES += "qte-font-helvetica-small"
@@ -55,6 +62,13 @@ set -e
. /etc/profile
${sbindir}/update-qtfontdir
}
+pkg_postrm_qte-font-helvetica-small() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+set -e
+. /etc/profile
+${sbindir}/update-qtfontdir -f
+}
PACKAGES += "qte-font-helvetica-large"
PROVIDES += "qte-font-helvetica-large"
@@ -68,6 +82,13 @@ set -e
. /etc/profile
${sbindir}/update-qtfontdir
}
+pkg_postrm_qte-font-helvetica-large() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+set -e
+. /etc/profile
+${sbindir}/update-qtfontdir -f
+}
PACKAGES += "qte-font-smoothtimes"
PROVIDES += "qte-font-smoothtimes"
@@ -80,6 +101,13 @@ set -e
. /etc/profile
${sbindir}/update-qtfontdir
}
+pkg_postrm_qte-font-smoothtimes() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+set -e
+. /etc/profile
+${sbindir}/update-qtfontdir -f
+}
PACKAGES += "qte-font-smallsmooth"
PROVIDES += "qte-font-smallsmooth"
@@ -92,6 +120,13 @@ set -e
. /etc/profile
${sbindir}/update-qtfontdir
}
+pkg_postrm_qte-font-smallsmooth() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+set -e
+. /etc/profile
+${sbindir}/update-qtfontdir -f
+}
PACKAGES += "qte-font-unicode"
PROVIDES += "qte-font-unicode"
@@ -104,6 +139,13 @@ set -e
. /etc/profile
${sbindir}/update-qtfontdir
}
+pkg_postrm_qte-font-unicode() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+set -e
+. /etc/profile
+${sbindir}/update-qtfontdir -f
+}
PACKAGES += "qte-font-micro"
PROVIDES += "qte-font-micro"
@@ -116,6 +158,13 @@ set -e
. /etc/profile
${sbindir}/update-qtfontdir
}
+pkg_postrm_qte-font-micro() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+set -e
+. /etc/profile
+${sbindir}/update-qtfontdir -f
+}
# Not in the QtE/3 tar file:
#PACKAGES += "qte-font-lcd"
@@ -129,6 +178,13 @@ ${sbindir}/update-qtfontdir
#. /etc/profile
#${sbindir}/update-qtfontdir
#}
+#pkg_postrm_qte-font-lcd() {
+##!/bin/sh
+#if [ -n "$D" ]; then exit 1; fi
+#set -e
+#. /etc/profile
+#${sbindir}/update-qtfontdir -f
+#}
# Not in the QtE/3 tar file:
#PACKAGES += "qte-font-japanese"
@@ -142,6 +198,13 @@ ${sbindir}/update-qtfontdir
#. /etc/profile
#${sbindir}/update-qtfontdir
#}
+#pkg_postrm_qte-font-japanese() {
+##!/bin/sh
+#if [ -n "$D" ]; then exit 1; fi
+#set -e
+#. /etc/profile
+#${sbindir}/update-qtfontdir -f
+#}
# Not in the QtE/3 tar file:
#PACKAGES += "qte-font-courier"
@@ -155,3 +218,10 @@ ${sbindir}/update-qtfontdir
#. /etc/profile
#${sbindir}/update-qtfontdir
#}
+#pkg_postrm_qte-font-courier() {
+##!/bin/sh
+#if [ -n "$D" ]; then exit 1; fi
+#set -e
+#. /etc/profile
+#${sbindir}/update-qtfontdir -f
+#}