aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qte-fonts-common
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/qte-fonts-common
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/qte-fonts-common')
-rw-r--r--packages/qte-fonts-common/qte-fonts-common_3.3.3.bb157
1 files changed, 157 insertions, 0 deletions
diff --git a/packages/qte-fonts-common/qte-fonts-common_3.3.3.bb b/packages/qte-fonts-common/qte-fonts-common_3.3.3.bb
index e69de29bb2..1cda5ac913 100644
--- a/packages/qte-fonts-common/qte-fonts-common_3.3.3.bb
+++ b/packages/qte-fonts-common/qte-fonts-common_3.3.3.bb
@@ -0,0 +1,157 @@
+SECTION = "opie/base"
+DESCRIPTION= "Tools to update the Qt fontdir"
+MAINTAINER = "M&N Solutions <info@mn-solutions.de>"
+LICENSE = "GPL/QPL"
+PACKAGE_ARCH = "all"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-free-${PV}.tar.gz"
+SRC_URI += "file://update-qtfontdir"
+S = "${WORKDIR}/qt-embedded-free-${PV}"
+
+do_compile() {
+}
+
+do_install() {
+ mkdir -p ${D}${sbindir}
+ install -m 755 ${WORKDIR}/update-qtfontdir ${D}${sbindir}
+ mkdir -p ${D}${palmtopdir}/lib/fonts
+ cp -a lib/fonts/* ${D}${palmtopdir}/lib/fonts
+ # Delete all other font formats, Qt/E would have a dead slow
+ # application start time if it had to use any other font format
+ # as *.qpf ...
+ find ${D}${palmtopdir}/lib/fonts \
+ -name "*.bdf" \
+ -o -name "*.ttf" \
+ -o -name "*.pfa" \
+ -o -name "*.pfb" | xargs rm
+}
+
+PACKAGES = "qte-fonts-common"
+FILES_${PN} = "${sbindir}"
+
+
+PACKAGES += "qte-font-fixed"
+PROVIDES += "qte-font-fixed"
+FILES_qte-font-fixed = "${palmtopdir}/lib/fonts/fixed*"
+RDEPENDS_qte-font-fixed = "qte-fonts-common"
+pkg_postinst_qte-font-fixed() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+set -e
+. /etc/profile
+${sbindir}/update-qtfontdir
+}
+
+PACKAGES += "qte-font-helvetica-small"
+PROVIDES += "qte-font-helvetica-small"
+FILES_qte-font-helvetica-small = "${palmtopdir}/lib/fonts/helvetica_80*.qpf \
+ ${palmtopdir}/lib/fonts/helvetica_100*.qpf ${palmtopdir}/lib/fonts/helvetica_120*.qpf"
+RDEPENDS_qte-font-helvetica-small = "qte-fonts-common"
+pkg_postinst_qte-font-helvetica-small() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+set -e
+. /etc/profile
+${sbindir}/update-qtfontdir
+}
+
+PACKAGES += "qte-font-helvetica-large"
+PROVIDES += "qte-font-helvetica-large"
+FILES_qte-font-helvetica-large = "${palmtopdir}/lib/fonts/helvetica_140*.qpf \
+ ${palmtopdir}/lib/fonts/helvetica_180*.qpf ${palmtopdir}/lib/fonts/helvetica_240*.qpf"
+RDEPENDS_qte-font-helvetica-large = "qte-fonts-common"
+pkg_postinst_qte-font-helvetica-large() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+set -e
+. /etc/profile
+${sbindir}/update-qtfontdir
+}
+
+PACKAGES += "qte-font-smoothtimes"
+PROVIDES += "qte-font-smoothtimes"
+FILES_qte-font-smoothtimes = "${palmtopdir}/lib/fonts/smoothtimes*"
+RDEPENDS_qte-font-smoothtimes = "qte-fonts-common"
+pkg_postinst_qte-font-smoothtimes() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+set -e
+. /etc/profile
+${sbindir}/update-qtfontdir
+}
+
+PACKAGES += "qte-font-smallsmooth"
+PROVIDES += "qte-font-smallsmooth"
+FILES_qte-font-smallsmooth = "${palmtopdir}/lib/fonts/smallsmooth*"
+RDEPENDS_qte-smallsmooth = "qte-fonts-common"
+pkg_postinst_qte-font-smallsmooth() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+set -e
+. /etc/profile
+${sbindir}/update-qtfontdir
+}
+
+PACKAGES += "qte-font-unicode"
+PROVIDES += "qte-font-unicode"
+FILES_qte-font-unicode = "${palmtopdir}/lib/fonts/unifont*.qpf"
+RDEPENDS_qte-font-unicode = "qte-fonts-common"
+pkg_postinst_qte-font-unicode() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+set -e
+. /etc/profile
+${sbindir}/update-qtfontdir
+}
+
+PACKAGES += "qte-font-micro"
+PROVIDES += "qte-font-micro"
+FILES_qte-font-micro = "${palmtopdir}/lib/fonts/micro*.qpf"
+#RDEPENDS_qte-font-micro = "qte-fonts-common"
+pkg_postinst_qte-font-micro() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi
+set -e
+. /etc/profile
+${sbindir}/update-qtfontdir
+}
+
+# Not in the QtE/3 tar file:
+#PACKAGES += "qte-font-lcd"
+#PROVIDES += "qte-font-lcd"
+#RDEPENDS_qte-font-lcd = "qte-fonts-common"
+#FILES_qte-font-lcd = "${palmtopdir}/lib/fonts/lcd*"
+#pkg_postinst_qte-font-lcd () {
+##!/bin/sh
+#if [ -n "$D" ]; then exit 1; fi
+#set -e
+#. /etc/profile
+#${sbindir}/update-qtfontdir
+#}
+
+# Not in the QtE/3 tar file:
+#PACKAGES += "qte-font-japanese"
+#PROVIDES += "qte-font-japanese"
+#FILES_qte-font-japanese = "${palmtopdir}/lib/fonts/japanese*"
+#RDEPENDS_qte-font-japanese = "qte-fonts-common"
+#pkg_postinst_qte-font-japanese() {
+##!/bin/sh
+#if [ -n "$D" ]; then exit 1; fi
+#set -e
+#. /etc/profile
+#${sbindir}/update-qtfontdir
+#}
+
+# Not in the QtE/3 tar file:
+#PACKAGES += "qte-font-courier"
+#PROVIDES += "qte-font-courier"
+#FILES_qte-font-courier = "${palmtopdir}/lib/fonts/cour*"
+#RDEPENDS_qte-font-courier = "qte-fonts-common"
+#pkg_postinst_qte-font-courier() {
+##!/bin/sh
+#if [ -n "$D" ]; then exit 1; fi
+#set -e
+#. /etc/profile
+#${sbindir}/update-qtfontdir
+#}