aboutsummaryrefslogtreecommitdiffstats
path: root/packages/quagga
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-05-26 08:10:45 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-26 08:10:45 +0000
commit50f316141f109701317bb6453483f1a80f8aba6c (patch)
treeaa799fa35b476ecf29868b4a059f1d4d07db94b4 /packages/quagga
parent1bdd82295819fdd8eda7a2a2dfa0f75b92eb1f40 (diff)
downloadopenembedded-50f316141f109701317bb6453483f1a80f8aba6c.tar.gz
quagga: Add 0.99.4, fix bgp package name, some cleanups.
* Added version 0.99.4 which fixes a number of bugs in the previous release, several critical bugs. See quagga homepage for details. * Fix the name of BGP package and init scripts - it should be bgpd not bpgd. Discovered when looking at the change log for the OWMNR project. * Added myself as the maintainer. * Add a prerm script from the base quagga package which stops all the sub deamons. Otherwise if you just erase the main package all the sub daemons keep running. Normally dependencies stop this, so this only if the user forces deletion. * Bump PR on 0.99.2 and 0.99.3 to pick up changes. * Remove PR from the .inc file, this is to be specified in the .bb files. * Re-order header to match style guide layout on the wiki. * Allow a directory addition to be passed through from .bb to the .inc. Use it in the 0.99.2 to indicate that the source for that version are now in the attic subdirectory.
Diffstat (limited to 'packages/quagga')
-rw-r--r--packages/quagga/quagga.inc24
-rw-r--r--packages/quagga/quagga_0.99.2.bb3
-rw-r--r--packages/quagga/quagga_0.99.3.bb2
-rw-r--r--packages/quagga/quagga_0.99.4.bb2
4 files changed, 20 insertions, 11 deletions
diff --git a/packages/quagga/quagga.inc b/packages/quagga/quagga.inc
index f5c6378c24..34f4a6a1ab 100644
--- a/packages/quagga/quagga.inc
+++ b/packages/quagga/quagga.inc
@@ -1,4 +1,3 @@
-SECTION = "network"
DESCRIPTION = "Quagga is a routing software suite, providing \
implementations of OSPFv2, OSPFv3, RIP v1 and v2, RIPv3 and BGPv4 for \
Unix platforms, particularly FreeBSD, Linux, Solaris and NetBSD. \
@@ -6,11 +5,14 @@ Quagga is a fork of GNU Zebra which was developed by Kunihiro \
Ishiguro. The Quagga tree aims to build a more involved community \
around Quagga than the current centralised model of GNU Zebra."
HOMEPAGE = "http://www.quagga.net/"
+SECTION = "network"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
LICENSE = "GPL"
DEPENDS = "readline ncurses perl-native"
-PR = "r0"
-SRC_URI = "http://www.quagga.net/download/quagga-${PV}.tar.gz \
+# ${QUAGGASUBDIR} is deal with old versions. Set to "/attic" for old
+# versions and leave it empty for recent versions.
+SRC_URI = "http://www.quagga.net/download${QUAGGASUBDIR}/quagga-${PV}.tar.gz \
file://fix-for-lib-inpath.patch;patch=1 \
file://quagga.init \
file://quagga.default \
@@ -53,11 +55,11 @@ EXTRA_OECONF = "--prefix=${prefix} \
# Split into a main package and seperate per-protocol packages
PACKAGES = "${PN} \
- ${PN}-ospfd ${PN}-ospf6d ${PN}-bpgd ${PN}-ripd ${PN}-ripngd ${PN}-isisd \
+ ${PN}-ospfd ${PN}-ospf6d ${PN}-bgpd ${PN}-ripd ${PN}-ripngd ${PN}-isisd \
${PN}-ospfclient ${PN}-watchquagga ${PN}-dev ${PN}-doc"
FILES_${PN}-ospfd = "${libdir}/quagga/ospfd /usr/lib/libospf.so.*"
FILES_${PN}-ospf6d = "${libdir}/quagga/ospf6d"
-FILES_${PN}-bpgd = "${libdir}/quagga/bgpd"
+FILES_${PN}-bgpd = "${libdir}/quagga/bgpd"
FILES_${PN}-ripd = "${libdir}/quagga/ripd"
FILES_${PN}-ripngd = "${libdir}/quagga/ripngd"
FILES_${PN}-isisd = "${libdir}/quagga/isisd"
@@ -77,7 +79,7 @@ PKG_${PN}-ospfclient = ${PN}-ospfclient
# Each of the per-protocol packages depends on the main package
RDEPENDS_${PN}-ospfd = ${PN}
RDEPENDS_${PN}-ospf6d = ${PN}
-RDEPENDS_${PN}-bpgd = ${PN}
+RDEPENDS_${PN}-bgpd = ${PN}
RDEPENDS_${PN}-ripd = ${PN}
RDEPENDS_${PN}-ripngd = ${PN}
RDEPENDS_${PN}-isisd = ${PN}
@@ -106,12 +108,16 @@ do_install () {
# Add quagga's user and groups
pkg_postinst_${PN} () {
- grep -q quagga: /etc/group || addgroup quagga
+ grep -q quagga: /etc/group || addgroup quagga
grep -q quaggavty: /etc/group || addgroup quaggavty
- grep -q quagga: /etc/passwd || adduser --disabled-password --home=/var/run/quagga/ --ingroup quagga -g "Quagga routing suite" quagga
+ grep -q quagga: /etc/passwd || adduser --disabled-password --home=/var/run/quagga/ --ingroup quagga -g "Quagga routing suite" quagga
}
# Stop apps before uninstall
+pkg_prerm_${PN} () {
+ ${sysconfdir}/init.d/quagga stop
+}
+
pkg_prerm_${PN}-ospfd () {
${sysconfdir}/init.d/quagga stop ospfd
}
@@ -121,7 +127,7 @@ pkg_prerm_${PN}-ospf6d () {
}
pkg_prerm_${PN}-bgpd () {
- ${sysconfdir}/init.d/quagga stop bpgd
+ ${sysconfdir}/init.d/quagga stop bgpd
}
pkg_prerm_${PN}-ripd () {
diff --git a/packages/quagga/quagga_0.99.2.bb b/packages/quagga/quagga_0.99.2.bb
index 9214ea6155..2789d7eb1a 100644
--- a/packages/quagga/quagga_0.99.2.bb
+++ b/packages/quagga/quagga_0.99.2.bb
@@ -1,3 +1,4 @@
+QUAGGASUBDIR = "/attic"
include quagga.inc
-PR = "r0"
+PR = "r1"
SRC_URI += "file://ospfd-no-opaque-lsa-fix.patch;patch=1"
diff --git a/packages/quagga/quagga_0.99.3.bb b/packages/quagga/quagga_0.99.3.bb
index 52b47348f3..e61c80d651 100644
--- a/packages/quagga/quagga_0.99.3.bb
+++ b/packages/quagga/quagga_0.99.3.bb
@@ -1,2 +1,2 @@
include quagga.inc
-PR = "r0"
+PR = "r1"
diff --git a/packages/quagga/quagga_0.99.4.bb b/packages/quagga/quagga_0.99.4.bb
new file mode 100644
index 0000000000..52b47348f3
--- /dev/null
+++ b/packages/quagga/quagga_0.99.4.bb
@@ -0,0 +1,2 @@
+include quagga.inc
+PR = "r0"