aboutsummaryrefslogtreecommitdiffstats
path: root/packages/rtaudio
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-09-21 17:09:53 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-21 17:09:53 +0000
commitff284b3d8b85c0d75df6f31996f437e2e4bae558 (patch)
tree3f3dadfa424ead8ed7070d7727568bf167a10dff /packages/rtaudio
parentcac237d6d44bb53b78e92e2381fe969103ef166b (diff)
downloadopenembedded-ff284b3d8b85c0d75df6f31996f437e2e4bae558.tar.gz
add librtaudio + tests
rtaudio is a highly efficient and portable C++ sound abstraction layer supporting OSS, ALSA, JACK.
Diffstat (limited to 'packages/rtaudio')
-rw-r--r--packages/rtaudio/.mtn2git_empty0
-rw-r--r--packages/rtaudio/librtaudio_3.0.1.bb29
-rw-r--r--packages/rtaudio/rtaudio-tests_3.0.1.bb26
3 files changed, 55 insertions, 0 deletions
diff --git a/packages/rtaudio/.mtn2git_empty b/packages/rtaudio/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/rtaudio/.mtn2git_empty
diff --git a/packages/rtaudio/librtaudio_3.0.1.bb b/packages/rtaudio/librtaudio_3.0.1.bb
new file mode 100644
index 0000000000..62ed46860b
--- /dev/null
+++ b/packages/rtaudio/librtaudio_3.0.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "RtAudio is a set of C++ classes which provide a common API \
+for realtime audio input/output across Linux (native ALSA, JACK, and OSS), \
+Macintosh OS X, SGI, and Windows (DirectSound and ASIO) operating systems."
+SECTION = "libs"
+LICENSE = "rtaudio"
+HOMEPAGE = "http://www.music.mcgill.ca/~gary/rtaudio"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "alsa-lib"
+PR = "r0"
+
+SRC_URI = "http://music.mcgill.ca/~gary/rtaudio/release/rtaudio-${PV}.tar.gz"
+S = "${WORKDIR}/rtaudio-${PV}"
+
+inherit qmake qt3x11
+
+do_configure_prepend() {
+ qmake -project -t lib -nopwd *.cpp *.h
+}
+
+EXTRA_QMAKEVARS_POST = "CONFIG=console CONFIG+=thread DEFINES+=__LINUX_OSS__ DEFINES+=__LINUX_ALSA__ LIBS+=-lasound"
+
+do_stage() {
+ install -m 0644 *.h ${STAGING_INCDIR}
+ oe_libinstall -so librtaudio-3.0.1 ${STAGING_LIBDIR}
+}
+
+do_install() {
+ oe_libinstall -so librtaudio-3.0.1 ${D}${libdir}
+}
diff --git a/packages/rtaudio/rtaudio-tests_3.0.1.bb b/packages/rtaudio/rtaudio-tests_3.0.1.bb
new file mode 100644
index 0000000000..53752b73c0
--- /dev/null
+++ b/packages/rtaudio/rtaudio-tests_3.0.1.bb
@@ -0,0 +1,26 @@
+include librtaudio_${PV}.bb
+
+inherit autotools
+
+EXTRA_OECONF = "--with-alsa --with-oss"
+EXTRA_OEMAKE = "-e"
+export CC = "${CXX}"
+CFLAGS += "-I${S}"
+export LIBRARY = "-lasound -lpthread ${LDFLAGS}"
+
+do_compile() {
+ oe_runmake -C tests
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ for binary in `find tests -perm 0755 -type f`
+ do
+ install -m 0755 $binary ${D}${bindir}
+ done
+}
+