aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ruby/ruby.inc
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-01-17 20:37:08 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-01-17 20:37:08 +0000
commitd14bedf242c95183dfdaeaa5ec8a06a45ca18d26 (patch)
tree8e7aad86f0949dfe5ae1a68479fc45477783a0c9 /packages/ruby/ruby.inc
parentb4ec03df90824ca0f7c1130ef19f40724b800c3b (diff)
downloadopenembedded-d14bedf242c95183dfdaeaa5ec8a06a45ca18d26.tar.gz
ruby: unified, fixed build
Diffstat (limited to 'packages/ruby/ruby.inc')
-rw-r--r--packages/ruby/ruby.inc25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/ruby/ruby.inc b/packages/ruby/ruby.inc
new file mode 100644
index 0000000000..9fe8333f6f
--- /dev/null
+++ b/packages/ruby/ruby.inc
@@ -0,0 +1,25 @@
+DESCRIPTION = "Ruby is an interpreted scripting language \
+for quick and easy object-oriented programming."
+SECTION = "devel/ruby"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/ruby-${PV}.tar.gz \
+ file://extmk_run.patch;patch=1 \
+ file://disable_wide_getaddrinfo_check.patch;patch=1"
+
+S = "${WORKDIR}/ruby-${PV}"
+
+inherit autotools
+
+# This snippet lets compiled extensions which rely on external libraries,
+# such as zlib, compile properly. If we don't do this, then when extmk.rb
+# runs, it uses the native libraries instead of the target libraries, and so
+# none of the linking operations succeed -- which makes extconf.rb think
+# that the libraries aren't available and hence that the extension can't be
+# built.
+
+do_configure_prepend() {
+ sed -i "s#%%TARGET_CFLAGS%%#$TARGET_CFLAGS#; s#%%TARGET_LDFLAGS%%#$TARGET_LDFLAGS#" ${S}/common.mk
+ rm -rf ${S}/ruby/
+}