summaryrefslogtreecommitdiffstats
path: root/packages/samba
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-02-19 07:01:12 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-02-19 07:01:12 +0000
commited9ebd540be222e5b58baaace39c3f6b4bc87a08 (patch)
treebe09077b76669fd0f6228e81dacf889995c10a71 /packages/samba
parent819a65b9f09509d58ac631fcd063f1ae2d206dd8 (diff)
downloadopenembedded-ed9ebd540be222e5b58baaace39c3f6b4bc87a08.tar.gz
samba: Make fetching more robust (closes 1885). Unify some more. Sanitize.
Diffstat (limited to 'packages/samba')
-rw-r--r--packages/samba/samba-essential.inc9
-rw-r--r--packages/samba/samba-essential_3.0.20.bb13
-rw-r--r--packages/samba/samba.inc16
-rw-r--r--packages/samba/samba_3.0.10.bb5
-rw-r--r--packages/samba/samba_3.0.14a.bb12
-rw-r--r--packages/samba/samba_3.0.20.bb12
-rw-r--r--packages/samba/samba_3.0.23c.bb12
-rw-r--r--packages/samba/samba_3.0.5.bb5
-rw-r--r--packages/samba/samba_3.0.9.bb5
9 files changed, 33 insertions, 56 deletions
diff --git a/packages/samba/samba-essential.inc b/packages/samba/samba-essential.inc
index fca08d1735..d718fc8a96 100644
--- a/packages/samba/samba-essential.inc
+++ b/packages/samba/samba-essential.inc
@@ -1,10 +1,15 @@
SECTION = "console/network"
-DEPENDS = "readline"
LICENSE = "GPL"
+DEPENDS = "readline"
+SRC_URI = "http://samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://cifs.patch;patch=1"
+S = "${WORKDIR}/samba-${PV}/source"
+
inherit autotools
-EXTRA_OECONF='--disable-cups --with-readline=${STAGING_LIBDIR}/.. \
+EXTRA_OECONF = '--disable-cups --with-readline=${STAGING_LIBDIR}/.. \
--without-ads --without-automount --without-smbmount --without-syslog \
--without-ldapsam --without-quotas --without-nisplus-home \
--without-sys-quotas --without-libsmbclient --without-winbind \
diff --git a/packages/samba/samba-essential_3.0.20.bb b/packages/samba/samba-essential_3.0.20.bb
index 365d208028..75febf4ab1 100644
--- a/packages/samba/samba-essential_3.0.20.bb
+++ b/packages/samba/samba-essential_3.0.20.bb
@@ -1,22 +1,17 @@
+require samba-essential.inc
+inherit update-rc.d
+
PR = "r5"
-SRC_URI = "http://us2.samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
- file://configure.patch;patch=1 \
- file://cifs.patch;patch=1 \
- file://config-lfs.patch;patch=1 \
+SRC_URI = "file://config-lfs.patch;patch=1 \
file://init-essential \
file://quota.patch;patch=1;pnum=0 \
file://smb-essential.conf \
file://smb-essential-inactive.conf \
file://Managing-Samba.txt"
-S := "${WORKDIR}/samba-${PV}/source"
-
RCONFLICTS = "samba"
-require samba-essential.inc
-inherit update-rc.d
-
INITSCRIPT_NAME = "samba"
# No dependencies, goes in at level 20 (NOTE: take care with the
# level, later levels put the shutdown later too - see the links
diff --git a/packages/samba/samba.inc b/packages/samba/samba.inc
index f9dce44072..aa3083d1f6 100644
--- a/packages/samba/samba.inc
+++ b/packages/samba/samba.inc
@@ -1,6 +1,16 @@
SECTION = "console/network"
-DEPENDS = "readline"
LICENSE = "GPL"
+DEPENDS = "readline"
+
+SRC_URI = "http://samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://cifs.patch;patch=1"
+S = "${WORKDIR}/samba-${PV}/source"
+
+inherit autotools
+
+EXTRA_OECONF='--disable-cups --with-readline=${STAGING_LIBDIR}/.. \
+ --without-ads --without-automount --with-smbmount'
PACKAGES =+ "libsmbclient libsmbclient-dev cifs cifs-doc"
FILES_cifs = "${bindir}/mount.cifs"
@@ -8,10 +18,6 @@ FILES_cifs-doc = "${docdir}/mount.cifs.8"
FILES_libsmbclient = "${libdir}/libsmbclient.so.*"
FILES_libsmbclient-dev = "${libdir}/libsmbclient.so ${includedir}"
-inherit autotools
-
-EXTRA_OECONF='--disable-cups --with-readline=${STAGING_LIBDIR}/.. \
- --without-ads --without-automount --with-smbmount'
do_configure_prepend () {
./script/mkversion.sh
if [ ! -e acinclude.m4 ]; then
diff --git a/packages/samba/samba_3.0.10.bb b/packages/samba/samba_3.0.10.bb
index 4aa262920c..895ce6b337 100644
--- a/packages/samba/samba_3.0.10.bb
+++ b/packages/samba/samba_3.0.10.bb
@@ -1,6 +1 @@
-SRC_URI := "http://us2.samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
- file://${FILESDIR}/configure.patch;patch=1 \
- file://${FILESDIR}/cifs.patch;patch=1"
-S := "${WORKDIR}/${P}/source"
-
require samba.inc
diff --git a/packages/samba/samba_3.0.14a.bb b/packages/samba/samba_3.0.14a.bb
index 08d3c390e7..d191363cd6 100644
--- a/packages/samba/samba_3.0.14a.bb
+++ b/packages/samba/samba_3.0.14a.bb
@@ -1,16 +1,12 @@
+require samba.inc
+inherit update-rc.d
+
PR = "r15"
-SRC_URI = "http://us2.samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
- file://configure.patch;patch=1 \
- file://cifs.patch;patch=1 \
- file://config-lfs.patch;patch=1 \
+SRC_URI += "file://config-lfs.patch;patch=1 \
file://init \
file://quota.patch;patch=1;pnum=0 \
"
-S = "${WORKDIR}/${P}/source"
-
-require samba.inc
-inherit update-rc.d
INITSCRIPT_NAME = "samba"
# No dependencies, goes in at level 20 (NOTE: take care with the
diff --git a/packages/samba/samba_3.0.20.bb b/packages/samba/samba_3.0.20.bb
index 7aa3d53626..fb2407c74f 100644
--- a/packages/samba/samba_3.0.20.bb
+++ b/packages/samba/samba_3.0.20.bb
@@ -1,16 +1,12 @@
+require samba.inc
+inherit update-rc.d
+
PR = "r5"
-SRC_URI = "http://us2.samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
- file://configure.patch;patch=1 \
- file://cifs.patch;patch=1 \
- file://config-lfs.patch;patch=1 \
+SRC_URI += "file://config-lfs.patch;patch=1 \
file://init \
file://quota.patch;patch=1;pnum=0 \
"
-S = "${WORKDIR}/${P}/source"
-
-require samba.inc
-inherit update-rc.d
INITSCRIPT_NAME = "samba"
# No dependencies, goes in at level 20 (NOTE: take care with the
diff --git a/packages/samba/samba_3.0.23c.bb b/packages/samba/samba_3.0.23c.bb
index acec5afdd8..5317bcc62a 100644
--- a/packages/samba/samba_3.0.23c.bb
+++ b/packages/samba/samba_3.0.23c.bb
@@ -1,16 +1,10 @@
-PR = "r0"
+require samba.inc
+inherit update-rc.d
-SRC_URI = "http://us2.samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
- file://configure.patch;patch=1 \
- file://cifs.patch;patch=1 \
- file://config-lfs.patch;patch=1 \
+SRC_URI += "file://config-lfs.patch;patch=1 \
file://init \
file://quota.patch;patch=1;pnum=0 \
"
-S = "${WORKDIR}/${P}/source"
-
-include samba.inc
-inherit update-rc.d
INITSCRIPT_NAME = "samba"
# No dependencies, goes in at level 20 (NOTE: take care with the
diff --git a/packages/samba/samba_3.0.5.bb b/packages/samba/samba_3.0.5.bb
index 4aa262920c..895ce6b337 100644
--- a/packages/samba/samba_3.0.5.bb
+++ b/packages/samba/samba_3.0.5.bb
@@ -1,6 +1 @@
-SRC_URI := "http://us2.samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
- file://${FILESDIR}/configure.patch;patch=1 \
- file://${FILESDIR}/cifs.patch;patch=1"
-S := "${WORKDIR}/${P}/source"
-
require samba.inc
diff --git a/packages/samba/samba_3.0.9.bb b/packages/samba/samba_3.0.9.bb
index 4aa262920c..895ce6b337 100644
--- a/packages/samba/samba_3.0.9.bb
+++ b/packages/samba/samba_3.0.9.bb
@@ -1,6 +1 @@
-SRC_URI := "http://us2.samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
- file://${FILESDIR}/configure.patch;patch=1 \
- file://${FILESDIR}/cifs.patch;patch=1"
-S := "${WORKDIR}/${P}/source"
-
require samba.inc