aboutsummaryrefslogtreecommitdiffstats
path: root/packages/samba
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-07-01 00:09:21 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-01 00:09:21 +0000
commitc0275c59a51e3635c1975a5390f4b4c365bec3af (patch)
tree8040065917ee7abb49c507ae8c8bf6ef3e03a5eb /packages/samba
parent50a11bc87ed05e700fb8756a037c1c4bd806debd (diff)
downloadopenembedded-c0275c59a51e3635c1975a5390f4b4c365bec3af.tar.gz
Fix paths issue.
Add initscript.
Diffstat (limited to 'packages/samba')
-rw-r--r--packages/samba/samba_3.0.14a.bb46
1 files changed, 40 insertions, 6 deletions
diff --git a/packages/samba/samba_3.0.14a.bb b/packages/samba/samba_3.0.14a.bb
index 0f18f4b1d4..d58b939399 100644
--- a/packages/samba/samba_3.0.14a.bb
+++ b/packages/samba/samba_3.0.14a.bb
@@ -1,21 +1,55 @@
-PR = "r1"
+PR = "r6"
-SRC_URI := "http://us2.samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
- file://${FILESDIR}/configure.patch;patch=1 \
- file://${FILESDIR}/cifs.patch;patch=1"
+# Ugly patch to hack configure.in to set the CPPFLAGS without actually checking for LFS support
+# For nslu2. Will probably work for forcing for other archs as well.
+LFS_SRC_URI = ""
+LFS_SRC_URI_nslu2 = "file://configure.lfs.patch;patch=1"
+
+SRC_URI = "http://us2.samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://cifs.patch;patch=1 \
+ ${LFS_SRC_URI} \
+ file://init \
+ "
S := ${WORKDIR}/${P}/source
include samba.inc
-EXTRA_OECONF += "--with-mandir=${mandir}"
+INITSCRIPT_NAME = "samba"
+# No dependencies, goes in at level 20 (NOTE: take care with the
+# level, later levels put the shutdown later too - see the links
+# in rc6.d, the shutdown must precede network shutdown).
+INITSCRIPT_PARAMS = "defaults"
+
+# The file system settings --foodir=dirfoo and overridden unconditionally
+# in the samba config by --with-foodir=dirfoo - even if the --with is not
+# specified! Fix that here. Set the privatedir to /etc/samba/private.
+EXTRA_OECONF += "\
+ --with-configdir=${sysconfdir}/samba \
+ --with-privatedir=${sysconfdir}/samba/private \
+ --with-lockdir=${localstatedir}/lock \
+ --with-piddir=${localstatedir}/run \
+ --with-logfilebase=${localstatedir}/log \
+ --with-libdir=${libdir} \
+ --with-mandir=${mandir} \
+ --with-swatdir=${datadir}/swat \
+ "
do_install_append() {
+ install -d "${D}${localstatedir}/log"
rm -f ${D}/sbin/mount.smbfs
rmdir ${D}/sbin
ln -sf smbmount ${D}${bindir}/mount.smbfs
+ install -d "${D}${sysconfdir}/init.d"
+ install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/samba
+ install -d "${D}${sysconfdir}/samba"
+ install -c -m 644 ../examples/smb.conf.default ${D}${sysconfdir}/samba/smb.conf.default
}
PACKAGES =+ "swat"
-FILES_swat = "${sbindir}/swat ${prefix}/swat ${libdir}/*.msg"
+FILES_swat = "${sbindir}/swat ${datadir}/swat ${libdir}/*.msg"
FILES_${PN} += "${libdir}/vfs/*.so ${libdir}/charset/*.so ${libdir}/*.dat"
+#
+# bug fix for samba.inc:
+FILES_cifs-doc = "${mandir}/man8/mount.cifs.8"