aboutsummaryrefslogtreecommitdiffstats
path: root/packages/slutils
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2005-09-02 18:00:05 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-02 18:00:05 +0000
commit85804786bcde3d7cd77db5d4c1918659a2a7d636 (patch)
tree306b13a3dce00b1d4806684aa59044ece80554c9 /packages/slutils
parent809d7e642cf1a5bbcd184acb316c6ffeb79e7077 (diff)
downloadopenembedded-85804786bcde3d7cd77db5d4c1918659a2a7d636.tar.gz
slutils: add slfb, a command-line utility to turn on/off the FrameBuffer for 2.4 Zaurus kernels
Diffstat (limited to 'packages/slutils')
-rw-r--r--packages/slutils/slutils-0.1.0/slfb/.mtn2git_empty0
-rw-r--r--packages/slutils/slutils-0.1.0/slfb/slfb.c34
-rw-r--r--packages/slutils/slutils-0.1.0/slfb/slfb.pro5
-rw-r--r--packages/slutils/slutils_0.1.0.bb10
4 files changed, 46 insertions, 3 deletions
diff --git a/packages/slutils/slutils-0.1.0/slfb/.mtn2git_empty b/packages/slutils/slutils-0.1.0/slfb/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/slutils/slutils-0.1.0/slfb/.mtn2git_empty
diff --git a/packages/slutils/slutils-0.1.0/slfb/slfb.c b/packages/slutils/slutils-0.1.0/slfb/slfb.c
new file mode 100644
index 0000000000..9cb72d12d2
--- /dev/null
+++ b/packages/slutils/slutils-0.1.0/slfb/slfb.c
@@ -0,0 +1,34 @@
+#include <stdio.h>
+#include <fcntl.h>
+#include <stdlib.h>
+#include <sys/ioctl.h>
+
+int main(int argc, char ** argv) {
+ int fd = open("/dev/fb0", O_WRONLY|O_NONBLOCK );
+ int on;
+ int res = 0;
+
+ if (argc != 2) {
+ printf("You must specify on or off\n");
+ return 0;
+ }
+
+ on = !strncmp(argv[1], "on", (strlen(argv[1]) > 1 ? 2 : 1));
+
+ printf((on ? "on\n" : "off\n"));
+
+ if ( fd )
+ {
+ int ioctlnum = 0x4611;
+ int vesaMode = on ? 0 : 3;
+ res = ioctl ( fd, ioctlnum, vesaMode );
+ printf("%i\n", res);
+ close ( fd );
+ }
+ else
+ {
+ printf("failed\n");
+ }
+ return res;
+}
+
diff --git a/packages/slutils/slutils-0.1.0/slfb/slfb.pro b/packages/slutils/slutils-0.1.0/slfb/slfb.pro
new file mode 100644
index 0000000000..35db7f20b9
--- /dev/null
+++ b/packages/slutils/slutils-0.1.0/slfb/slfb.pro
@@ -0,0 +1,5 @@
+CONFIG = console
+TEMPLATE = app
+INCLUDEPATH += .
+
+SOURCES += slfb.c
diff --git a/packages/slutils/slutils_0.1.0.bb b/packages/slutils/slutils_0.1.0.bb
index 4b18d2855a..958fab46d5 100644
--- a/packages/slutils/slutils_0.1.0.bb
+++ b/packages/slutils/slutils_0.1.0.bb
@@ -1,9 +1,12 @@
DESCRIPTION = "Console utilities for certain hardware aspects of Sharp Linux based Zaurii"
+DESCRIPTION_slfb = "A command-line utility to turn on/off the FrameBuffer on Linux 2.4-based Zaurii"
+DESCRIPTION_slbl = "A command-line utility to control the BackLight on Linux 2.4-based Zaurii"
+DESCRIPTION_sltime = "A ustility to save and restore the time on Sharp Linux based Zaurii"
SECTION = "console/utils"
PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
LICENSE = "GPL"
-PR = "r3"
+PR = "r4"
inherit qmake update-rc.d
@@ -12,7 +15,7 @@ SRC_URI = "file://sltime.sh"
INITSCRIPT_NAME = "sltime"
INITSCRIPT_PARAMS = "defaults 5"
-export UTILS = "sltime slbl"
+export UTILS = "sltime slbl slfb"
do_fetch() {
for u in ${UTILS}
@@ -37,6 +40,7 @@ do_install() {
install -m 0755 ${WORKDIR}/sltime.sh ${D}${sysconfdir}/init.d/sltime
}
-PACKAGES =+ "slbl"
+PACKAGES =+ "slbl slfb"
FILES_slbl = "${sbindir}/slbl"
+FILES_slfb = "${sbindir}/slfb"