aboutsummaryrefslogtreecommitdiffstats
path: root/packages/snes9x
diff options
context:
space:
mode:
authorManuel Teira <manuel.teira@telefonica.net>2007-04-29 19:23:42 +0000
committerKoen Kooi <koen@openembedded.org>2007-04-29 19:23:42 +0000
commit299a342a86994d5bc40edaec9be7a08c5aea0d24 (patch)
tree576288eb8e82cdc2a6ef0e3980837a7a361a9a98 /packages/snes9x
parent91a272da8c2875e7f56113afe07f4a05b932cf1d (diff)
downloadopenembedded-299a342a86994d5bc40edaec9be7a08c5aea0d24.tar.gz
snes9x: fix linkage and gcc4 problems, closes #2154
Diffstat (limited to 'packages/snes9x')
-rw-r--r--packages/snes9x/snes9x-sdl/gcc-4.1.patch28
-rw-r--r--packages/snes9x/snes9x-sdl_1.39.bb5
2 files changed, 31 insertions, 2 deletions
diff --git a/packages/snes9x/snes9x-sdl/gcc-4.1.patch b/packages/snes9x/snes9x-sdl/gcc-4.1.patch
new file mode 100644
index 0000000000..a63c0519d3
--- /dev/null
+++ b/packages/snes9x/snes9x-sdl/gcc-4.1.patch
@@ -0,0 +1,28 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- snes9x-sdl-1.39/dsp1.h~gcc-4.1
++++ snes9x-sdl-1.39/dsp1.h
+@@ -233,8 +233,8 @@
+ void S9xResetDSP1 ();
+ uint8 S9xGetDSP (uint16 Address);
+ void S9xSetDSP (uint8 Byte, uint16 Address);
+-END_EXTERN_C
+
+ extern struct SDSP1 DSP1;
++END_EXTERN_C
+
+ #endif
+--- snes9x-sdl-1.39/unix/unix.cpp~gcc-4.1
++++ snes9x-sdl-1.39/unix/unix.cpp
+@@ -1046,7 +1046,7 @@
+ {
+ }
+
+-static uint8 Buf[MAX_BUFFER_SIZE];
++static uint8 Buf[MAX_BUFFER_SIZE] __attribute__((aligned(4)));
+
+ #define FIXED_POINT 0x10000
+ #define FIXED_POINT_SHIFT 16
diff --git a/packages/snes9x/snes9x-sdl_1.39.bb b/packages/snes9x/snes9x-sdl_1.39.bb
index ce6f5fa265..ea4eb44666 100644
--- a/packages/snes9x/snes9x-sdl_1.39.bb
+++ b/packages/snes9x/snes9x-sdl_1.39.bb
@@ -3,10 +3,11 @@ SECTION = "games"
PRIORITY = "optional"
DEPENDS = "virtual/libsdl zlib"
LICENSE = "snes9x"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.vanille.de/mirror/snes9x-sdl-${PV}.tar.bz2 \
- file://compile.patch;patch=1"
+ file://compile.patch;patch=1 \
+ file://gcc-4.1.patch;patch=1"
S = "${WORKDIR}/snes9x-sdl-${PV}"
do_compile() {