aboutsummaryrefslogtreecommitdiffstats
path: root/packages/squeak
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/squeak
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/squeak')
-rw-r--r--packages/squeak/.mtn2git_empty0
-rw-r--r--packages/squeak/files/.mtn2git_empty0
-rw-r--r--packages/squeak/files/Makefile.in84
-rw-r--r--packages/squeak/files/ipaq/.mtn2git_empty0
-rw-r--r--packages/squeak/files/ipaq/Makefile.in84
-rw-r--r--packages/squeak/files/mnci/.mtn2git_empty0
-rw-r--r--packages/squeak/files/mnci/Makefile.in84
-rw-r--r--packages/squeak/files/simpad/.mtn2git_empty0
-rw-r--r--packages/squeak/files/simpad/Makefile.in84
-rw-r--r--packages/squeak/files/zaurus/.mtn2git_empty0
-rw-r--r--packages/squeak/files/zaurus/Makefile.in84
-rw-r--r--packages/squeak/squeak-nox_3.4-2.bb42
12 files changed, 462 insertions, 0 deletions
diff --git a/packages/squeak/.mtn2git_empty b/packages/squeak/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/squeak/.mtn2git_empty
diff --git a/packages/squeak/files/.mtn2git_empty b/packages/squeak/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/squeak/files/.mtn2git_empty
diff --git a/packages/squeak/files/Makefile.in b/packages/squeak/files/Makefile.in
index e69de29bb2..9be8c7d2a9 100644
--- a/packages/squeak/files/Makefile.in
+++ b/packages/squeak/files/Makefile.in
@@ -0,0 +1,84 @@
+# Makefile for core VM -*- makefile -*-
+#
+# Copyright (C) 1996-2002 Ian Piumarta and other authors/contributors
+# as listed elsewhere in this file.
+# All rights reserved.
+#
+# This file is part of Unix Squeak.
+#
+# This file is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE.
+#
+# You may use and/or distribute this file ONLY as part of Squeak, under
+# the terms of the Squeak License as described in `LICENSE' in the base of
+# this distribution, subject to the following restrictions:
+#
+# 1. The origin of this software must not be misrepresented; you must not
+# claim that you wrote the original software. If you use this software
+# in a product, an acknowledgment to the original author(s) (and any
+# other contributors mentioned herein) in the product documentation
+# would be appreciated but is not required.
+#
+# 2. This notice must not be removed or altered in any source distribution.
+#
+# Using (or modifying this file for use) in any context other than Squeak
+# changes these copyright conditions. Read the file `COPYING' in the
+# directory `platforms/unix/doc' before proceeding with any such use.
+#
+# You are not allowed to distribute a modified version of this file
+# under its original name without explicit permission to do so. If
+# you change it, rename it.
+#
+# Author: ian.piumarta@inria.fr
+#
+# Last edited: 2002-12-01 10:20:57 by piumarta on calvin.inria.fr
+
+[make_cfg]
+[make_plg]
+
+MOC = $(QTDIR)/bin/moc
+OBJS = $(INTERP)$o sqNamedPrims$o sqVirtualMachine$o \
+ aio$o osExports$o sqUnixExternalPrims$o sqQPEWindow$o moc_sqQPEWindow$o sqQPEGlue$o
+TARGET = ${OBJS}
+
+XINCLUDES = [includes] -I$(topdir)/platforms/Cross/plugins/FilePlugin -I$(topdir)/platforms/Cross/plugins/JoystickTabletPlugin
+XCPPINCLUDES = -I$(QTDIR)/include
+CPPFLAGS = -fno-exceptions -DQWS -fno-rtti -fno-exceptions -DQT_NO_QWS_LINUXFB -DQT_NO_QWS_TRANSFORMED
+
+TARGET = vm$a
+
+$(TARGET) : $(OBJS) Makefile
+ $(LINK) $(TARGET) $(OBJS)
+ $(RANLIB) $(TARGET)
+
+# rebuild sqNamedPrims.o if sqNamedPrims.h changes
+
+sqNamedPrims$o : $(srcdir)/vm/sqNamedPrims.h
+
+# rebuild sqExtPrims (VM_LIBDIR) sqXWin (VM_VERSION) if config.h changes
+
+sqUnixExternalPrims$o sqXWindow$o : ../config.h $(topdir)/platforms/unix/vm/dlfcn-dyld.c
+
+# GNUify the interpreter if needed
+
+gnu-interp$o : gnu-interp.c
+ $(COMPILE) $@ gnu-interp.c
+
+gnu-interp.c : $(srcdir)/vm/interp.c
+ $(AWK) -f $(topdir)/platforms/unix/config/gnuify $(srcdir)/vm/interp.c > $@.out
+ mv $@.out $@
+
+moc_sqQPEWindow$o: moc_sqQPEWindow.cpp
+ g++ ${INCLUDES} ${XINCLUDES} ${CFLAGS} ${CPPFLAGS} ${XCPPINCLUDES} -DNON_ZAURUS_ENVIRONMENT -c -o moc_sqQPEWindow$o moc_sqQPEWindow.cpp
+
+moc_sqQPEWindow.cpp: $(topdir)/platforms/unix/vm/sqQPEWindow.h
+ $(MOC) $(topdir)/platforms/unix/vm/sqQPEWindow.h -o moc_sqQPEWindow.cpp
+
+sqQPEWindow$o: $(topdir)/platforms/unix/vm/sqQPEWindow.cpp
+ g++ ${INCLUDES} ${XINCLUDES} ${CFLAGS} ${CPPFLAGS} ${XCPPINCLUDES} -DNON_ZAURUS_ENVIRONMENT -c -o sqQPEWindow$o $(topdir)/platforms/unix/vm/sqQPEWindow.cpp
+
+
+[make_targets]
+
+.force :
diff --git a/packages/squeak/files/ipaq/.mtn2git_empty b/packages/squeak/files/ipaq/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/squeak/files/ipaq/.mtn2git_empty
diff --git a/packages/squeak/files/ipaq/Makefile.in b/packages/squeak/files/ipaq/Makefile.in
index e69de29bb2..94e995faaa 100644
--- a/packages/squeak/files/ipaq/Makefile.in
+++ b/packages/squeak/files/ipaq/Makefile.in
@@ -0,0 +1,84 @@
+# Makefile for core VM -*- makefile -*-
+#
+# Copyright (C) 1996-2002 Ian Piumarta and other authors/contributors
+# as listed elsewhere in this file.
+# All rights reserved.
+#
+# This file is part of Unix Squeak.
+#
+# This file is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE.
+#
+# You may use and/or distribute this file ONLY as part of Squeak, under
+# the terms of the Squeak License as described in `LICENSE' in the base of
+# this distribution, subject to the following restrictions:
+#
+# 1. The origin of this software must not be misrepresented; you must not
+# claim that you wrote the original software. If you use this software
+# in a product, an acknowledgment to the original author(s) (and any
+# other contributors mentioned herein) in the product documentation
+# would be appreciated but is not required.
+#
+# 2. This notice must not be removed or altered in any source distribution.
+#
+# Using (or modifying this file for use) in any context other than Squeak
+# changes these copyright conditions. Read the file `COPYING' in the
+# directory `platforms/unix/doc' before proceeding with any such use.
+#
+# You are not allowed to distribute a modified version of this file
+# under its original name without explicit permission to do so. If
+# you change it, rename it.
+#
+# Author: ian.piumarta@inria.fr
+#
+# Last edited: 2002-12-01 10:20:57 by piumarta on calvin.inria.fr
+
+[make_cfg]
+[make_plg]
+
+MOC = $(QTDIR)/bin/moc
+OBJS = $(INTERP)$o sqNamedPrims$o sqVirtualMachine$o \
+ aio$o osExports$o sqUnixExternalPrims$o sqQPEWindow$o moc_sqQPEWindow$o sqQPEGlue$o
+TARGET = ${OBJS}
+
+XINCLUDES = [includes] -I$(topdir)/platforms/Cross/plugins/FilePlugin -I$(topdir)/platforms/Cross/plugins/JoystickTabletPlugin
+XCPPINCLUDES = -I$(QTDIR)/include
+CPPFLAGS = -fno-exceptions -DQT_QWS_EBX -DQT_QWS_CUSTOM -DQWS -fno-rtti -fno-exceptions -DNO_DEBUG
+
+TARGET = vm$a
+
+$(TARGET) : $(OBJS) Makefile
+ $(LINK) $(TARGET) $(OBJS)
+ $(RANLIB) $(TARGET)
+
+# rebuild sqNamedPrims.o if sqNamedPrims.h changes
+
+sqNamedPrims$o : $(srcdir)/vm/sqNamedPrims.h
+
+# rebuild sqExtPrims (VM_LIBDIR) sqXWin (VM_VERSION) if config.h changes
+
+sqUnixExternalPrims$o sqXWindow$o : ../config.h $(topdir)/platforms/unix/vm/dlfcn-dyld.c
+
+# GNUify the interpreter if needed
+
+gnu-interp$o : gnu-interp.c
+ $(COMPILE) $@ gnu-interp.c
+
+gnu-interp.c : $(srcdir)/vm/interp.c
+ $(AWK) -f $(topdir)/platforms/unix/config/gnuify $(srcdir)/vm/interp.c > $@.out
+ mv $@.out $@
+
+moc_sqQPEWindow$o: moc_sqQPEWindow.cpp
+ arm-linux-g++ ${INCLUDES} ${XINCLUDES} ${CFLAGS} ${CPPFLAGS} ${XCPPINCLUDES} -c -o moc_sqQPEWindow$o moc_sqQPEWindow.cpp
+
+moc_sqQPEWindow.cpp: $(topdir)/platforms/unix/vm/sqQPEWindow.h
+ $(MOC) $(topdir)/platforms/unix/vm/sqQPEWindow.h -o moc_sqQPEWindow.cpp
+
+sqQPEWindow$o: $(topdir)/platforms/unix/vm/sqQPEWindow.cpp
+ arm-linux-g++ ${INCLUDES} ${XINCLUDES} ${CFLAGS} ${CPPFLAGS} ${XCPPINCLUDES} -UUSE_SL_FILESELECTOR -UUSE_CFXGA -DIPAQ -c -o sqQPEWindow$o $(topdir)/platforms/unix/vm/sqQPEWindow.cpp
+
+
+[make_targets]
+
+.force :
diff --git a/packages/squeak/files/mnci/.mtn2git_empty b/packages/squeak/files/mnci/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/squeak/files/mnci/.mtn2git_empty
diff --git a/packages/squeak/files/mnci/Makefile.in b/packages/squeak/files/mnci/Makefile.in
index e69de29bb2..4f97cf801b 100644
--- a/packages/squeak/files/mnci/Makefile.in
+++ b/packages/squeak/files/mnci/Makefile.in
@@ -0,0 +1,84 @@
+# Makefile for core VM -*- makefile -*-
+#
+# Copyright (C) 1996-2002 Ian Piumarta and other authors/contributors
+# as listed elsewhere in this file.
+# All rights reserved.
+#
+# This file is part of Unix Squeak.
+#
+# This file is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE.
+#
+# You may use and/or distribute this file ONLY as part of Squeak, under
+# the terms of the Squeak License as described in `LICENSE' in the base of
+# this distribution, subject to the following restrictions:
+#
+# 1. The origin of this software must not be misrepresented; you must not
+# claim that you wrote the original software. If you use this software
+# in a product, an acknowledgment to the original author(s) (and any
+# other contributors mentioned herein) in the product documentation
+# would be appreciated but is not required.
+#
+# 2. This notice must not be removed or altered in any source distribution.
+#
+# Using (or modifying this file for use) in any context other than Squeak
+# changes these copyright conditions. Read the file `COPYING' in the
+# directory `platforms/unix/doc' before proceeding with any such use.
+#
+# You are not allowed to distribute a modified version of this file
+# under its original name without explicit permission to do so. If
+# you change it, rename it.
+#
+# Author: ian.piumarta@inria.fr
+#
+# Last edited: 2002-12-01 10:20:57 by piumarta on calvin.inria.fr
+
+[make_cfg]
+[make_plg]
+
+MOC = moc
+OBJS = $(INTERP)$o sqNamedPrims$o sqVirtualMachine$o \
+ aio$o osExports$o sqUnixExternalPrims$o sqQPEWindow$o moc_sqQPEWindow$o sqQPEGlue$o
+TARGET = ${OBJS}
+
+XINCLUDES = [includes] -I$(topdir)/platforms/Cross/plugins/FilePlugin -I$(topdir)/platforms/Cross/plugins/JoystickTabletPlugin
+XCPPINCLUDES = -I$(QTDIR)/include
+CPPFLAGS = -fno-exceptions -DQT_QWS_EBX -DQT_QWS_CUSTOM -DQWS -fno-rtti -fno-exceptions -DNO_DEBUG
+
+TARGET = vm$a
+
+$(TARGET) : $(OBJS) Makefile
+ $(LINK) $(TARGET) $(OBJS)
+ $(RANLIB) $(TARGET)
+
+# rebuild sqNamedPrims.o if sqNamedPrims.h changes
+
+sqNamedPrims$o : $(srcdir)/vm/sqNamedPrims.h
+
+# rebuild sqExtPrims (VM_LIBDIR) sqXWin (VM_VERSION) if config.h changes
+
+sqUnixExternalPrims$o sqXWindow$o : ../config.h $(topdir)/platforms/unix/vm/dlfcn-dyld.c
+
+# GNUify the interpreter if needed
+
+gnu-interp$o : gnu-interp.c
+ $(COMPILE) $@ gnu-interp.c
+
+gnu-interp.c : $(srcdir)/vm/interp.c
+ $(AWK) -f $(topdir)/platforms/unix/config/gnuify $(srcdir)/vm/interp.c > $@.out
+ mv $@.out $@
+
+moc_sqQPEWindow$o: moc_sqQPEWindow.cpp
+ arm-linux-g++ ${INCLUDES} ${XINCLUDES} ${CFLAGS} ${CPPFLAGS} ${XCPPINCLUDES} -c -o moc_sqQPEWindow$o moc_sqQPEWindow.cpp
+
+moc_sqQPEWindow.cpp: $(topdir)/platforms/unix/vm/sqQPEWindow.h
+ $(MOC) $(topdir)/platforms/unix/vm/sqQPEWindow.h -o moc_sqQPEWindow.cpp
+
+sqQPEWindow$o: $(topdir)/platforms/unix/vm/sqQPEWindow.cpp
+ arm-linux-g++ ${INCLUDES} ${XINCLUDES} ${CFLAGS} ${CPPFLAGS} ${XCPPINCLUDES} -DUSE_CFXGA -UIPAQ -c -o sqQPEWindow$o $(topdir)/platforms/unix/vm/sqQPEWindow.cpp
+
+
+[make_targets]
+
+.force :
diff --git a/packages/squeak/files/simpad/.mtn2git_empty b/packages/squeak/files/simpad/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/squeak/files/simpad/.mtn2git_empty
diff --git a/packages/squeak/files/simpad/Makefile.in b/packages/squeak/files/simpad/Makefile.in
index e69de29bb2..08dc13b467 100644
--- a/packages/squeak/files/simpad/Makefile.in
+++ b/packages/squeak/files/simpad/Makefile.in
@@ -0,0 +1,84 @@
+# Makefile for core VM -*- makefile -*-
+#
+# Copyright (C) 1996-2002 Ian Piumarta and other authors/contributors
+# as listed elsewhere in this file.
+# All rights reserved.
+#
+# This file is part of Unix Squeak.
+#
+# This file is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE.
+#
+# You may use and/or distribute this file ONLY as part of Squeak, under
+# the terms of the Squeak License as described in `LICENSE' in the base of
+# this distribution, subject to the following restrictions:
+#
+# 1. The origin of this software must not be misrepresented; you must not
+# claim that you wrote the original software. If you use this software
+# in a product, an acknowledgment to the original author(s) (and any
+# other contributors mentioned herein) in the product documentation
+# would be appreciated but is not required.
+#
+# 2. This notice must not be removed or altered in any source distribution.
+#
+# Using (or modifying this file for use) in any context other than Squeak
+# changes these copyright conditions. Read the file `COPYING' in the
+# directory `platforms/unix/doc' before proceeding with any such use.
+#
+# You are not allowed to distribute a modified version of this file
+# under its original name without explicit permission to do so. If
+# you change it, rename it.
+#
+# Author: ian.piumarta@inria.fr
+#
+# Last edited: 2002-12-01 10:20:57 by piumarta on calvin.inria.fr
+
+[make_cfg]
+[make_plg]
+
+OBJS = $(INTERP)$o sqNamedPrims$o sqVirtualMachine$o \
+ aio$o osExports$o sqUnixExternalPrims$o sqQPEWindow$o moc_sqQPEWindow$o sqQPEGlue$o
+TARGET = ${OBJS}
+
+XINCLUDES = [includes] -I$(topdir)/platforms/Cross/plugins/FilePlugin -I$(topdir)/platforms/Cross/plugins/JoystickTabletPlugin
+XCPPINCLUDES = -I$(QTDIR)/include -I$(QPEDIR)/include
+CPPFLAGS = -fno-exceptions -DQT_QWS_EBX -DQT_QWS_CUSTOM -DQWS -fno-rtti -fno-exceptions -DNO_DEBUG
+LDFLAGS= -L${QTDIR}/lib -L${QPEDIR}/lib -lqtopia
+
+TARGET = vm$a
+
+$(TARGET) : $(OBJS) Makefile
+ $(LINK) $(TARGET) $(OBJS)
+ $(RANLIB) $(TARGET)
+
+# rebuild sqNamedPrims.o if sqNamedPrims.h changes
+
+sqNamedPrims$o : $(srcdir)/vm/sqNamedPrims.h
+
+# rebuild sqExtPrims (VM_LIBDIR) sqXWin (VM_VERSION) if config.h changes
+
+sqUnixExternalPrims$o sqXWindow$o : ../config.h $(topdir)/platforms/unix/vm/dlfcn-dyld.c
+
+# GNUify the interpreter if needed
+
+gnu-interp$o : gnu-interp.c
+ $(COMPILE) $@ gnu-interp.c
+
+gnu-interp.c : $(srcdir)/vm/interp.c
+ $(AWK) -f $(topdir)/platforms/unix/config/gnuify $(srcdir)/vm/interp.c > $@.out
+ mv $@.out $@
+
+moc_sqQPEWindow$o: moc_sqQPEWindow.cpp
+ arm-linux-g++ ${INCLUDES} ${XINCLUDES} ${CFLAGS} ${CPPFLAGS} ${XCPPINCLUDES} -c -o moc_sqQPEWindow$o moc_sqQPEWindow.cpp
+
+moc_sqQPEWindow.cpp: $(topdir)/platforms/unix/vm/sqQPEWindow.h
+ $(OE_QMAKE_MOC) $(topdir)/platforms/unix/vm/sqQPEWindow.h -o moc_sqQPEWindow.cpp
+
+sqQPEWindow$o: $(topdir)/platforms/unix/vm/sqQPEWindow.cpp
+ arm-linux-g++ ${INCLUDES} ${XINCLUDES} ${CFLAGS} ${CPPFLAGS} ${XCPPINCLUDES} -UUSE_SL_FILESELECTOR -UUSE_CFXGA -UIPAQ -DSIMPAD -c -o sqQPEWindow$o $(topdir)/platforms/unix/vm/sqQPEWindow.cpp
+
+
+[make_targets]
+
+.force :
diff --git a/packages/squeak/files/zaurus/.mtn2git_empty b/packages/squeak/files/zaurus/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/squeak/files/zaurus/.mtn2git_empty
diff --git a/packages/squeak/files/zaurus/Makefile.in b/packages/squeak/files/zaurus/Makefile.in
index e69de29bb2..b5bb346cd3 100644
--- a/packages/squeak/files/zaurus/Makefile.in
+++ b/packages/squeak/files/zaurus/Makefile.in
@@ -0,0 +1,84 @@
+# Makefile for core VM -*- makefile -*-
+#
+# Copyright (C) 1996-2002 Ian Piumarta and other authors/contributors
+# as listed elsewhere in this file.
+# All rights reserved.
+#
+# This file is part of Unix Squeak.
+#
+# This file is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE.
+#
+# You may use and/or distribute this file ONLY as part of Squeak, under
+# the terms of the Squeak License as described in `LICENSE' in the base of
+# this distribution, subject to the following restrictions:
+#
+# 1. The origin of this software must not be misrepresented; you must not
+# claim that you wrote the original software. If you use this software
+# in a product, an acknowledgment to the original author(s) (and any
+# other contributors mentioned herein) in the product documentation
+# would be appreciated but is not required.
+#
+# 2. This notice must not be removed or altered in any source distribution.
+#
+# Using (or modifying this file for use) in any context other than Squeak
+# changes these copyright conditions. Read the file `COPYING' in the
+# directory `platforms/unix/doc' before proceeding with any such use.
+#
+# You are not allowed to distribute a modified version of this file
+# under its original name without explicit permission to do so. If
+# you change it, rename it.
+#
+# Author: ian.piumarta@inria.fr
+#
+# Last edited: 2002-12-01 10:20:57 by piumarta on calvin.inria.fr
+
+[make_cfg]
+[make_plg]
+
+MOC = $(QTDIR)/bin/moc
+OBJS = $(INTERP)$o sqNamedPrims$o sqVirtualMachine$o \
+ aio$o osExports$o sqUnixExternalPrims$o sqQPEWindow$o moc_sqQPEWindow$o sqQPEGlue$o
+TARGET = ${OBJS}
+
+XINCLUDES = [includes] -I$(topdir)/platforms/Cross/plugins/FilePlugin -I$(topdir)/platforms/Cross/plugins/JoystickTabletPlugin
+XCPPINCLUDES = -I$(QTDIR)/include
+CPPFLAGS = -fno-exceptions -DQT_QWS_EBX -DQT_QWS_CUSTOM -DQWS -fno-rtti -fno-exceptions -DNO_DEBUG
+
+TARGET = vm$a
+
+$(TARGET) : $(OBJS) Makefile
+ $(LINK) $(TARGET) $(OBJS)
+ $(RANLIB) $(TARGET)
+
+# rebuild sqNamedPrims.o if sqNamedPrims.h changes
+
+sqNamedPrims$o : $(srcdir)/vm/sqNamedPrims.h
+
+# rebuild sqExtPrims (VM_LIBDIR) sqXWin (VM_VERSION) if config.h changes
+
+sqUnixExternalPrims$o sqXWindow$o : ../config.h $(topdir)/platforms/unix/vm/dlfcn-dyld.c
+
+# GNUify the interpreter if needed
+
+gnu-interp$o : gnu-interp.c
+ $(COMPILE) $@ gnu-interp.c
+
+gnu-interp.c : $(srcdir)/vm/interp.c
+ $(AWK) -f $(topdir)/platforms/unix/config/gnuify $(srcdir)/vm/interp.c > $@.out
+ mv $@.out $@
+
+moc_sqQPEWindow$o: moc_sqQPEWindow.cpp
+ arm-linux-g++ ${INCLUDES} ${XINCLUDES} ${CFLAGS} ${CPPFLAGS} ${XCPPINCLUDES} -c -o moc_sqQPEWindow$o moc_sqQPEWindow.cpp
+
+moc_sqQPEWindow.cpp: $(topdir)/platforms/unix/vm/sqQPEWindow.h
+ $(MOC) $(topdir)/platforms/unix/vm/sqQPEWindow.h -o moc_sqQPEWindow.cpp
+
+sqQPEWindow$o: $(topdir)/platforms/unix/vm/sqQPEWindow.cpp
+ arm-linux-g++ ${INCLUDES} ${XINCLUDES} ${CFLAGS} ${CPPFLAGS} ${XCPPINCLUDES} -DUSE_SL_FILESELECTOR -DUSE_CFXGA -UIPAQ -c -o sqQPEWindow$o $(topdir)/platforms/unix/vm/sqQPEWindow.cpp
+
+
+[make_targets]
+
+.force :
diff --git a/packages/squeak/squeak-nox_3.4-2.bb b/packages/squeak/squeak-nox_3.4-2.bb
index e69de29bb2..02c3520c09 100644
--- a/packages/squeak/squeak-nox_3.4-2.bb
+++ b/packages/squeak/squeak-nox_3.4-2.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Squeak VM for QtEmbedded"
+SECTION = "devel"
+PRIORITY = "optional"
+MAINTAINER = "Torsten Sadowski <tsadowski@gmx.net>"
+LICENSE = "Squeak License"
+HOMEPAGE = "http://www.squeak.org"
+DEPENDS = "virtual/libqpe"
+PROVIDES = "virtual/squeak-nox"
+PR = "r1"
+
+SRC_URI = "http://keepcool.kf.tu-berlin.de/public/mitarbeiter/sadowski/qtopia-squeak-${PV}_patched.tar.gz \
+ file://Makefile.in"
+S = "${WORKDIR}"
+
+EXTRA_OECONF = ' --host=arm-linux --without-x --without-npsqueak --with-audio=oss'
+
+inherit palmtop
+
+do_configure() {
+ cp platforms/unix/vm/aio.h platforms/unix/vm/sqaio.h
+ cp ${WORKDIR}/Makefile.in platforms/unix/vm/Makefile.in
+ rm -rf build
+ mkdir build
+ cd build
+ ../platforms/unix/config/configure ${EXTRA_OECONF}
+}
+
+do_compile() {
+ cd build
+ make
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin/
+ install -m 0755 ${WORKDIR}/build/squeak-nox ${D}${palmtopdir}/bin/
+ install -d ${D}/${palmtopdir}/apps/Applications/
+ install -m 0644 squeak.desktop ${D}/${palmtopdir}/apps/Applications/squeak.desktop
+ install -d ${D}/${palmtopdir}/pics/
+ install -m 0644 SqueakLogo.png ${D}/${palmtopdir}/pics/SqueakLogo.png
+ install -d ${D}/${palmtopdir}/share/apps/squeak/
+ install -m 0644 README ${D}/${palmtopdir}/share/apps/squeak/
+}