aboutsummaryrefslogtreecommitdiffstats
path: root/packages/squid
diff options
context:
space:
mode:
authorT Kemp <tkemp@klc.net.nz>2007-11-12 11:31:51 +0000
committerKoen Kooi <koen@openembedded.org>2007-11-12 11:31:51 +0000
commite8f739857126075e2af0af0a27467b0b72214358 (patch)
treea83eb16279e85ade261e2a2c48644bbbaab2fd3e /packages/squid
parent2fa6bfb314afdfc9d1ebda35acc29a0cba58b0bd (diff)
downloadopenembedded-e8f739857126075e2af0af0a27467b0b72214358.tar.gz
squid: apply patches for #2884
Diffstat (limited to 'packages/squid')
-rw-r--r--packages/squid/squid-native_2.6.STABLE14.bb11
-rw-r--r--packages/squid/squid_2.6.STABLE14.bb16
2 files changed, 25 insertions, 2 deletions
diff --git a/packages/squid/squid-native_2.6.STABLE14.bb b/packages/squid/squid-native_2.6.STABLE14.bb
new file mode 100644
index 0000000000..0730bc15af
--- /dev/null
+++ b/packages/squid/squid-native_2.6.STABLE14.bb
@@ -0,0 +1,11 @@
+inherit native autotools
+
+SRC_URI = "http://www.squid-cache.org/Versions/v2/2.6/squid-$PV}.tar.bz2"
+S = "${WORKDIR}/squid-${PV}"
+
+inherit native autotools
+
+do_stage() {
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 0755 src/cf_gen ${STAGING_BINDIR_NATIVE}/cf_gen
+}
diff --git a/packages/squid/squid_2.6.STABLE14.bb b/packages/squid/squid_2.6.STABLE14.bb
index 580ec52ac6..beef3ba2b0 100644
--- a/packages/squid/squid_2.6.STABLE14.bb
+++ b/packages/squid/squid_2.6.STABLE14.bb
@@ -1,11 +1,23 @@
DESCRIPTION = "Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more"
LICENSE = "GPLv2"
-DEPENDS = "aio"
+DEPENDS = "squid-native-${PV}"
-SRC_URI = "http://www.squid-cache.org/Versions/v2/2.6/squid-2.6.STABLE14.tar.bz2"
+SRC_URI = "http://www.squid-cache.org/Versions/v2/2.6/squid-${PV}.tar.bz2"
inherit autotools
+EXTRA_OECONF = "--disable-epoll --disable-nls"
+do_configure_append() {
+ sed -i -e 's|./cf_gen |${STAGING_BINDIR_NATIVE}/cf_gen |g' src/Makefile
+}
+# this packages the languages better and saves some space, installs
+# English as errors default and the others in locale package
+
+FILES_${PN} += " ${datadir}/errors/English/* \
+ ${datadir}/icons/* \
+ ${datadir}/mib.txt"
+
+FILES_${PN}-locale += " ${datadir}/errors/* "