aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sysvinit/sysvinit_2.86.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/sysvinit/sysvinit_2.86.bb
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/sysvinit/sysvinit_2.86.bb')
-rw-r--r--packages/sysvinit/sysvinit_2.86.bb44
1 files changed, 22 insertions, 22 deletions
diff --git a/packages/sysvinit/sysvinit_2.86.bb b/packages/sysvinit/sysvinit_2.86.bb
index 36b7812f78..1d9d4d0af4 100644
--- a/packages/sysvinit/sysvinit_2.86.bb
+++ b/packages/sysvinit/sysvinit_2.86.bb
@@ -38,7 +38,7 @@ ALTERNATIVE_PATH = "/sbin/init.sysvinit"
ALTERNATIVE_PRIORITY = "50"
PACKAGES =+ "sysvinit-pidof sysvinit-sulogin"
-FILES_${PN} += "/sbin /bin"
+FILES_${PN} += "${base_sbindir} /bin"
FILES_sysvinit-pidof = "/bin/pidof"
FILES_sysvinit-sulogin = "/sbin/sulogin"
@@ -59,11 +59,11 @@ do_install () {
${D}/${sysconfdir}/init.d
install -m 0644 ${WORKDIR}/inittab ${D}/${sysconfdir}/inittab
if [ ! -z "${SERIAL_CONSOLE}" ]; then
- echo "S:2345:respawn:/sbin/getty ${SERIAL_CONSOLE}" >> ${D}/etc/inittab
+ echo "S:2345:respawn:${base_sbindir}/getty ${SERIAL_CONSOLE}" >> ${D}/${sysconfdir}/inittab
fi
if [ "${USE_VT}" == "1" ]; then
- cat <<EOF >>${D}/etc/inittab
-# /sbin/getty invocations for the runlevels.
+ cat <<EOF >>${D}/${sysconfdir}/inittab
+# ${base_sbindir}/getty invocations for the runlevels.
#
# The "id" field MUST be the same as the last
# characters of the device (after "tty").
@@ -71,34 +71,34 @@ do_install () {
# Format:
# <id>:<runlevels>:<action>:<process>
#
-1:2345:respawn:/sbin/getty 38400 tty1
-# 2:23:respawn:/sbin/getty 38400 tty2
-# 3:23:respawn:/sbin/getty 38400 tty3
-# 4:23:respawn:/sbin/getty 38400 tty4
+1:2345:respawn:${base_sbindir}/getty 38400 tty1
+# 2:23:respawn:${base_sbindir}/getty 38400 tty2
+# 3:23:respawn:${base_sbindir}/getty 38400 tty3
+# 4:23:respawn:${base_sbindir}/getty 38400 tty4
EOF
fi
- install -m 0644 ${WORKDIR}/rcS-default ${D}/etc/default/rcS
- install -m 0755 ${WORKDIR}/rc ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/rcS ${D}/etc/init.d
- install -m 0755 ${WORKDIR}/bootlogd.init ${D}/etc/init.d/bootlogd
- ln -sf bootlogd ${D}/etc/init.d/stop-bootlogd
- install -d ${D}/etc/rcS.d
- ln -sf ../init.d/bootlogd ${D}/etc/rcS.d/S07bootlogd
+ install -m 0644 ${WORKDIR}/rcS-default ${D}/${sysconfdir}/default/rcS
+ install -m 0755 ${WORKDIR}/rc ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/rcS ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/bootlogd.init ${D}/${sysconfdir}/init.d/bootlogd
+ ln -sf bootlogd ${D}/${sysconfdir}/init.d/stop-bootlogd
+ install -d ${D}/${sysconfdir}/rcS.d
+ ln -sf ../init.d/bootlogd ${D}/${sysconfdir}/rcS.d/S07bootlogd
for level in 2 3 4 5; do
- install -d ${D}/etc/rc$level.d
- ln -s ../init.d/stop-bootlogd ${D}/etc/rc$level.d/S99stop-bootlogd
+ install -d ${D}/${sysconfdir}/rc$level.d
+ ln -s ../init.d/stop-bootlogd ${D}/${sysconfdir}/rc$level.d/S99stop-bootlogd
done
- mv ${D}/sbin/init ${D}/sbin/init.sysvinit
+ mv ${D}/${base_sbindir}/init ${D}/${base_sbindir}/init.sysvinit
}
do_install_append_ramses () {
- cat <<EOF >>${D}/etc/inittab
+ cat <<EOF >>${D}/${sysconfdir}/inittab
# Bluetooth
-#1:2345:respawn:/sbin/getty -L 115200 tts/1
+#1:2345:respawn:${base_sbindir}/getty -L 115200 tts/1
# External serial port
-4:2345:respawn:/sbin/getty -L 115200 tts/4
+4:2345:respawn:${base_sbindir}/getty -L 115200 tts/4
# Framebuffer
-v1:2345:respawn:/sbin/getty -L 115200 vc/1
+v1:2345:respawn:${base_sbindir}/getty -L 115200 vc/1
EOF
}