aboutsummaryrefslogtreecommitdiffstats
path: root/packages/telepathy
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-04-24 11:40:21 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-04-24 11:40:21 +0000
commit02778e9ad7ba700da87410fcab3982d4d07288b1 (patch)
tree4fa582bfe1991dd009bf4e342311493bfa06a6cf /packages/telepathy
parent8852b5e4efa8bb076177083808aecfc78d97c89a (diff)
downloadopenembedded-02778e9ad7ba700da87410fcab3982d4d07288b1.tar.gz
telepathy-glib: added 0.5.10 (from Poky)
Diffstat (limited to 'packages/telepathy')
-rw-r--r--packages/telepathy/telepathy-glib_0.5.10.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/packages/telepathy/telepathy-glib_0.5.10.bb b/packages/telepathy/telepathy-glib_0.5.10.bb
new file mode 100644
index 0000000000..f6b6a6c6b3
--- /dev/null
+++ b/packages/telepathy/telepathy-glib_0.5.10.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Telepathy framework - GLib library"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus python-native dbus-native"
+LICENSE = "LGPL"
+
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-glib/${P}.tar.gz "
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
+
+do_stage() {
+ #
+ # copied autotools_stage_all because telepathy-glib has one lib only built as static
+ # so it can not be oe_libinstalled
+ #
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ oe_runmake DESTDIR="${STAGE_TEMP}" install
+ if [ -d ${STAGE_TEMP}/${includedir} ]; then
+ cp -fpPR ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
+ fi
+ if [ -d ${STAGE_TEMP}/${libdir} ]
+ then
+ for i in ${STAGE_TEMP}/${libdir}/*.la
+ do
+ if [ ! -f "$i" ]; then
+ cp -fpPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}
+ break
+ fi
+ done
+ oe_libinstall -so -C telepathy-glib/.libs libtelepathy-glib ${STAGING_LIBDIR}
+ fi
+ if [ -d ${STAGE_TEMP}/${datadir}/aclocal ]; then
+ install -d ${STAGING_DATADIR}/aclocal
+ cp -fpPR ${STAGE_TEMP}/${datadir}/aclocal/* ${STAGING_DATADIR}/aclocal
+ fi
+ rm -rf ${STAGE_TEMP}
+}