aboutsummaryrefslogtreecommitdiffstats
path: root/packages/tetex/tetex_3.0.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-01 20:00:33 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-01 20:00:33 +0000
commit99debd0e40cdc43a2095532f47cd62324c4ed876 (patch)
treed683c31847e6d736b02847764db10d5efbbed11c /packages/tetex/tetex_3.0.bb
parentab67190c725b7084dcb313a800dd2efa679789cb (diff)
downloadopenembedded-99debd0e40cdc43a2095532f47cd62324c4ed876.tar.gz
add teTeX - a complete TeX distribution for UNIX compatible systems
Diffstat (limited to 'packages/tetex/tetex_3.0.bb')
-rw-r--r--packages/tetex/tetex_3.0.bb77
1 files changed, 77 insertions, 0 deletions
diff --git a/packages/tetex/tetex_3.0.bb b/packages/tetex/tetex_3.0.bb
new file mode 100644
index 0000000000..75f39170b2
--- /dev/null
+++ b/packages/tetex/tetex_3.0.bb
@@ -0,0 +1,77 @@
+DESCRIPTION = "teTeX is a complete TeX distribution for UNIX compatible systems"
+LICENSE = "GPL"
+SECTION = "console/utils"
+DEPENDS = "tetex-native flex gd ncurses libpng t1lib x11 xau xext xt zlib"
+RDEPENDS_tetex = "tetex-data"
+TETEX_BUILDSYSTEM_TAMER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+PR = "r0"
+
+SRC_URI = "ftp://dante.ctan.org/tex-archive/systems/unix/teTeX/current/distrib/tetex-src-${PV}.tar.gz \
+ file://configure.patch;patch=1"
+S = ${WORKDIR}/tetex-src-${PV}
+
+inherit autotools
+
+PARALLEL_MAKE = ""
+
+export BUILDCC = "${BUILD_CC}"
+export BUILDCFLAGS = "${BUILD_CFLAGS}"
+export BUILDLDFLAGS = "${BUILD_LDFLAGS}"
+export BUILDCCLD = "${BUILD_CC}"
+
+EXTRA_OECONF = "--with-system-libgd \
+ --with-system-ncurses \
+ --with-ncurses-include=${STAGING_INCDIR} \
+ --with-system-pnglib \
+ --with-system-t1lib \
+ --with-system-zlib \
+ --without-dialog \
+ --without-xdvik"
+
+# NOTE: In theory, teTeX has a good buildsystem, which automatically detects
+# whether we are cross-compiling and compiles the necessary host tools.
+# Unfortunately it doesn't work in our case and it looks easier to add
+# tetex-native for the time being. Cheers, Mickey.
+do_configure () {
+ oe_runconf
+ ln -sf ${STAGING_BINDIR} ${S}/utils/texinfo/tools/info
+ ln -sf ${STAGING_BINDIR} ${S}/utils/texinfo/tools/makeinfo
+ cat >${S}/utils/texinfo/tools/Makefile <<EOF
+install:
+ echo "done"
+all:
+ echo "done"
+EOF
+}
+
+# NOTE: This is really ugly. Unfortunately the teTeX people seem not to know about PREFIX...
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${libdir}
+ install -d ${D}${datadir}/texmf
+
+ export bindir="${D}${bindir}" \
+ sbindir="${D}${sbindir}" \
+ libexecdir="${D}${libexecdir}" \
+ datadir="${D}${datadir}" \
+ sysconfdir="${D}${sysconfdir}" \
+ sharedstatedir="${D}${sharedstatedir}" \
+ localstatedir="${D}${localstatedir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ oldincludedir="${D}${oldincludedir}" \
+ infodir="${D}${infodir}" \
+ mandir="${D}${mandir}" \
+ texmf="${D}${datadir}/texmf" \
+ scriptdir="${D}${bindir}" \
+ web2cdir="${D}${datadir}" \
+ kpathsea="${D}${libdir}/libkpathsea.la" \
+ DESTDIR=""
+ MAKE="make -e" oe_runmake -e install
+}
+
+#
+# FIXME: Package more fine granular
+#
+PACKAGES += "tetex-data"
+FILES_tetex-data = "${datadir}"