aboutsummaryrefslogtreecommitdiffstats
path: root/packages/timezones
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/timezones
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/timezones')
-rw-r--r--packages/timezones/timezones_cvs.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/packages/timezones/timezones_cvs.bb b/packages/timezones/timezones_cvs.bb
index 58282a7d07..4b6a81491e 100644
--- a/packages/timezones/timezones_cvs.bb
+++ b/packages/timezones/timezones_cvs.bb
@@ -10,9 +10,9 @@ SRC_URI = "${HANDHELDS_CVS};module=opie/root"
S = "${WORKDIR}/root"
do_install() {
- install -d ${D}/usr/share/
- cp -fa usr/share/zoneinfo ${D}/usr/share/
- find ${D}/usr/share -name "CVS"|xargs rm -rf
+ install -d ${D}${datadir}/
+ cp -fa usr/share/zoneinfo ${D}${datadir}/
+ find ${D}${datadir} -name "CVS"|xargs rm -rf
}
python populate_packages_prepend() {
@@ -20,7 +20,7 @@ python populate_packages_prepend() {
pkgpattern = "timezones-%s"
pkgdescription = "Timezone for %s"
- do_split_packages(d, root='/usr/share/zoneinfo/', file_regex=pkgregex, output_pattern=pkgpattern,
+ do_split_packages(d, root='${datadir}/zoneinfo/', file_regex=pkgregex, output_pattern=pkgpattern,
description=pkgdescription,allow_dirs=True )
}