aboutsummaryrefslogtreecommitdiffstats
path: root/packages/tinc
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2005-02-15 02:59:56 +0000
committerRene Wagner <rw@handhelds.org>2005-02-15 02:59:56 +0000
commit5c43290bf342418b7aac7e3379354a9e188ba194 (patch)
tree1a4b02505eab3e9a516e09779b9a794f20e925d7 /packages/tinc
parenta1d8d152aaffdbc2944f8340ce2d982cbe9e44b8 (diff)
downloadopenembedded-5c43290bf342418b7aac7e3379354a9e188ba194.tar.gz
tinc: demote kernel-module-tun to RRECOMMENDS
BKrev: 421165acwJOe8VM3pozk80X4sxeVIw
Diffstat (limited to 'packages/tinc')
-rw-r--r--packages/tinc/tinc_1.0.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/tinc/tinc_1.0.2.bb b/packages/tinc/tinc_1.0.2.bb
index e69de29bb2..d9f1717ffe 100644
--- a/packages/tinc/tinc_1.0.2.bb
+++ b/packages/tinc/tinc_1.0.2.bb
@@ -0,0 +1,32 @@
+SECTION = "console/network"
+DESCRIPTION ="tinc is a Virtual Private Network (VPN) daemon"
+HOMEPAGE = "http://www.tinc-vpn.org/"
+LICENSE = "GPLv2"
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+PR = "r1"
+
+SRC_URI="http://www.tinc-vpn.org/packages/tinc-1.0.2.tar.gz \
+ file://mtu-vlan.diff;patch=1 \
+ file://public-key-fix.diff;patch=1 \
+ file://init"
+
+DEPENDS = "openssl lzo zlib"
+RRECOMMENDS = "kernel-module-tun"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-maintainer-mode --disable-tracing"
+
+do_configure() {
+ oe_runconf
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/tinc
+}